Bug 49485 - Get an Exceptional Error pop up during instalation
Get an Exceptional Error pop up during instalation
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-19 20:41 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-15 20:01:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
These are the 4 errors I receive trying to install the OS. (908 bytes, text/plain)
2001-07-19 20:42 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-07-19 20:41:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
When I try to install the program on a clean 8 gig HD I get 3 anaconda 
errors and an OS Error.

How reproducible:
Always

Steps to Reproduce:
1.Choose the type of setup I want-workstation or custom
2.Choose the programs I want to install
3.begin instalation
	
These are the actual errors..........

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1543, in 
doInstall
    self.instCallback, p)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1298, in 
instCallback
    self.rpmFD = os.open(fn, os.O_RDONLY)
OSError: [Errno 2] No such file or 
directory: '/mnt/source/RedHat/RPMS/which-2.11-4.i386.rpm'

Local variables in innermost frame:
fn: /mnt/source/RedHat/RPMS/which-2.11-4.i386.rpm
total: 0
self: <todo.ToDo instance at 84a1898>
h: <header object at 8bec780>
amount: 0
intf: <progress_gui.InstallProgressWindow instance at 8463720>
what: 2

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I1
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>

Actual Results:  The program will begin to load the selected files and get 
about a quarter of the way through the instalation then I get the pop up 
with the 4 errors. I have tried useing another Linux 7.0 Instsallation 
Disk and get the same results.

Expected Results:  The installation should have gone smooth with no errors.

Additional info:

I have a Athlon 1.1 gig processor, 256 ram, Creative Labs Sound Blaster 
Live X Gamer Sound Card, G Force 32meg 3D Video Card, CD and CDR drive.
Comment 1 Need Real Name 2001-07-19 20:42:56 EDT
Created attachment 24247 [details]
These are the 4 errors I receive trying to install the OS.
Comment 2 Matt Wilson 2001-07-20 17:26:18 EDT
Where did you get your Red Hat Linux CDs from?
Comment 3 Brent Fox 2001-08-10 11:12:17 EDT
Closing due to inactivity. Please reopen if you have more information.
Comment 4 Need Real Name 2001-08-10 20:15:37 EDT
I purchased the Red Hat 7.0 box set from Office Max in Denver, Co.
Comment 5 Need Real Name 2001-08-10 20:17:36 EDT
I also have a copy on 2 disks That came with the book (The Complete Referance 
Linux Fourth Edition).
Comment 6 pbsimon 2001-08-12 16:30:52 EDT
I get a similar error message, as described above.  I am using the disk set 
from Sams "Red Hat Linux 7 Unleashed".  Below is the text of the error:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "fstab.py", line 715, in mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 208813
fsystem: ext2
self: <fstab.GuiFstab instance at 8403ad8>
msg: Invalid argument
doFormat: 0
errno: 22
device: hda10
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Please let me know what I can do to get around this.
Comment 7 Brent Fox 2001-08-13 11:59:06 EDT
pbsimon, your bug report is a duplicate of bug #16686, but I think that this is
different from the bug reported by beartrax.
Comment 8 Brent Fox 2001-08-13 12:01:56 EDT
beartrax, when the installer crashes, press <Ctrl><Alt><F4> and see if there are
any error related to the cdrom.  I suspect that the disc is bad.  Do you see any
error messages?
Comment 9 Need Real Name 2001-08-13 16:35:25 EDT
I tried to install again, and as expected I got the same 4 errors as stated 
above. I then hit the <CRTL><ALT><F4> and saw no errors related to the CD Rom.
 The first installatiion was from your Red Hat 7.0 Box Kit. I then tried the 
install again useing the CD's from the Linux 4th Edition Complete Referance. 
Once again I received the 4 errors and <CRTL><ALT><F4> again with no referance 
to errors related to the CD Rom.
Comment 10 Brent Fox 2001-08-15 00:22:16 EDT
Strange.  The reason I ask is because the error you are getting is indicative of
a bad cd.  Are you sure that the cdrom drive is good?  The installer is trying
to find the 'which' RPM on the cd, and it's having trouble reading it.  Is the
error always with the 'which' package, even on the different sets of cds?

Have a look at bug #18031 for bugs related to bad cd's and you'll see that they
are very similar to the debug message you attached above.
Comment 11 Need Real Name 2001-08-15 08:52:55 EDT
Yes they are very simular indeed. With this being the case how do you suggest I 
correct this situation. I have tried to install Red Hat on both my 44x CD Rom 
and my 12x CD Burner with no luck. I know both Roms are in good working order 
because I burn CD's all the time. If it is indeed a bad copy of Red Hat both in 
your Box Set and in the Complete Referance of Linux Forth Edition (which is 
very unlikley both are bad)what can Red Hat do to remidy this situation?
Comment 12 Brent Fox 2001-08-15 15:53:19 EDT
I don't really know how to proceed here.  I think the chances that all three
sets of cd's are bad is extremely low, but all the symptoms point to a bad disc.
 So are the errors always with the 'which' package, even on the different sets
of cds?

Comment 13 Need Real Name 2001-08-15 20:01:11 EDT
You know I thank you for all your time and effort but I think it would be 
better left alone at this point. I will stick with Windows 98 and forget about 
Linux. Please close this case as I am not going to try to install Linux again. 
Again Thank You.

Note You need to log in before you can comment on or make changes to this bug.