This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 495884 - Updated NetworkManager breaks anaconda networking
Updated NetworkManager breaks anaconda networking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 495984 496180 (view as bug list)
Depends On:
Blocks: F11Preview 494832
  Show dependency treegraph
 
Reported: 2009-04-15 09:06 EDT by James Laska
Modified: 2013-09-02 02:34 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 15:24:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tty4 screenshot (203.01 KB, image/jpeg)
2009-04-15 09:06 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-04-15 09:06:38 EDT
Created attachment 339682 [details]
tty4 screenshot

Description of problem:

The latest rawhide (with a previously working anaconda-11.5.0.44) and a *new* NetworkManager fails to activate networking.  Not sure if anaconda needs to be changed to accommodate an NM change, or if NM has a bug.  Happy to reassign as needed.

Version-Release number of selected component (if applicable):

 * NetworkManager-0.7.1-2.git20090414.fc11.i586
 * anaconda-11.5.0.44

How reproducible:


Steps to Reproduce:
1. Boot rawhide installer
2. Select lang/keymap
3. Select URL installation method
4. Select NIC, then select DHCP
  
Actual results:

+=====================================================
 There was an error configuring your network device

 [ RETRY ]
+=====================================================

tty4 shows (see attachment) ...

nm-system-settings: update: assertion `context != NULL' failed

Expected results:


Additional info:
Comment 1 Chris Lumens 2009-04-15 11:23:56 EDT
Dan - any idea what's going on here?
Comment 2 Dan Williams 2009-04-16 08:25:12 EDT
Looks like it requires a fix in NM, not anaconda's fault.
Comment 3 James Laska 2009-04-16 08:35:14 EDT
reassigning to NM
Comment 5 Geoff Levand 2009-04-16 12:35:48 EDT
*** Bug 495984 has been marked as a duplicate of this bug. ***
Comment 6 Geoff Levand 2009-04-17 14:55:34 EDT
I tested today's build (17-Apr-2009 12:02) on PS3 game console, and this problem seems to be fixed.

 sha1sum ppc/os/ppc/ppc64/{ramdisk.image.gz,vmlinuz}
 b901b623ce3e5ddaca8cb62b8e0fc31ea9874931  ppc/os/ppc/ppc64/ramdisk.image.gz
 9de8ff3a4428d87b07c589eb991696218ba76a33  ppc/os/ppc/ppc64/vmlinuz

-Geoff
Comment 7 Orion Poplawski 2009-04-17 15:24:00 EDT
Confirmed for me too.
Comment 8 Dan Williams 2009-04-17 15:51:46 EDT
https://fedorahosted.org/rel-eng/ticket/1492
Comment 9 Geoff Levand 2009-04-17 17:31:21 EDT
*** Bug 496180 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.