Bug 498155 - LiveUSB boot failure: Unable to find root filesystem
LiveUSB boot failure: Unable to find root filesystem
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 02:32 EDT by Christopher Beland
Modified: 2009-06-04 17:19 EDT (History)
9 users (show)

See Also:
Fixed In Version: 017.3-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-04 17:19:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslinux.cfg from the LiveUSB image (1009 bytes, text/plain)
2009-04-29 02:32 EDT, Christopher Beland
no flags Details

  None (edit)
Description Christopher Beland 2009-04-29 02:32:25 EDT
Created attachment 341707 [details]
syslinux.cfg from the LiveUSB image

When using liveusb-creator-3.6.5-2.fc11.noarch (Fedora 11 Preview via yum update) to create a Fedora 11 Preview LiveUSB, I am unable to boot the resulting LiveUSB.  The boot sequence of the LiveUSB stops at a screen with the following:

>>
-------------------------------------
WARNING: Cannot find root filesystem!
-------------------------------------

Create symlink /dev/root and then exit this shell to continue the boot sequence. 

<<

There are further reports here:
https://fedorahosted.org/liveusb-creator/ticket/53
Comment 1 James Laska 2009-05-18 14:13:50 EDT
Christopher, it seems folks are having difficulty reproducing this issue.  Are you still experiencing this problem using the latest F11 rawhide content?

Are you able to boot official Fedora 11 live images, or is this only when creating and booting live images you create?

If using livecd-creator, can you post the full log for review?  Perhaps lmacken might be able to spot something from the logs.
Comment 2 Michael Monreal 2009-05-20 03:28:41 EDT
Christopher, are you able to boot other systems from USB? I created a live USB system from the F11 Beta and while working fine on my laptop, IIRC I got a very similar error when trying to boot in on my desktop. For me the conclusion was broken USB boot support in my hardware.
Comment 3 James Laska 2009-05-20 16:27:28 EDT
Greetings Christopher,

This issue may be removed from the F11Live blocker bug list unless we are able to further isolate the failure.  Let us know if you continue to experience this issue, and if possible any livecd-creator logs, or description of the environment used to create the live media.  A final F11 blocker review meeting will be held this Friday to discuss outstanding issues and this defect will be reviewed again.

Thanks,
James
Comment 4 Christopher Beland 2009-05-20 22:19:42 EDT
To answer your questions:

* I am not using livecd-creator; this is a liveusb-creator bug.
* I am trying to boot the official F11 Preview Live ISO.
* I get the same error whether I try to boot this Live image on my desktop or my laptop, so I presume it is not a hardware-specific issue.

The machine I am creating the LiveUSB image on is running Fedora 11 with the latest updates, including updates-testing.  Specifically, it has:

dosfstools-3.0.1-4.fc11.x86_64
liveusb-creator-3.6.5-2.fc11.noarch

Here is exactly what I did:

* I plugged in the USB stick.

* As root, I ran these commands:
 umount /dev/sdb1
 /sbin/mkdosfs -F 16 -n usbdisk /dev/sdb1
 liveusb-creator

* Since F11 Preview is not in the GUI, I downloaded:

http://torrent.fedoraproject.org/torrents/F11-Preview-i686-Live.torrent

and after downloading the resulting ISO via BitTorrent checked it with:

sha256sum F11-Preview-i686-Live.iso 
6db32456854bc01892a0b6445e30a3fbac727b790867cf485d2d2be052d4d38f  F11-Preview-i686-Live.iso

* In the GUI I clicked on "Use existing Live CD" and specified F11-Preview-i686-Live.iso.

* I cranked "Persistent Storage" all the way up, to 1305 MB.

* I clicked "Create Live USB".

--

Output on the command line:

[gui:343] Device is not yet mounted, so we cannot determine the amount of free space.  Setting a maximum limit of 8G for the persistent storage.
[gui:351] Partition is FAT16; Restricting overlay size to 2G
/dev/sdb1
sdb1

--

Output in the GUI:

F11-Preview-i686-Live.iso selected
Verifying filesystem...
Verifying ISO MD5 checksum
Extracting live image to USB device...
Wrote to device at 12 MB/sec
Creating 1305MB persistent overlay
Setting up OLPC boot file...
Installing bootloader...
Complete! (0:03:59)

--

Output in /var/log/messages:

May 20 21:29:27 free-spin hald: mounted /dev/sdb1 on behalf of uid 0
May 20 21:29:27 free-spin gnome-keyring-daemon[2227]: adding removable location: volume_uuid_F155_B64B at /media/usbdisk
May 20 21:49:06 free-spin hald: unmounted /dev/sdb1 from '/media/usbdisk' on behalf of uid 0
May 20 21:49:06 free-spin gnome-keyring-daemon[2227]: removing removable location: volume_uuid_F155_B64B
Comment 5 Christopher Beland 2009-05-20 22:46:44 EDT
I should note that because the fix for bug 492370 has not been backported to Fedora 9, the F9 -> F11 via LiveUSB upgrade path is completely blocked, at least looking at the instructions at: https://fedoraproject.org/wiki/FedoraLiveCD/USBHowTo
Comment 6 James Laska 2009-05-22 13:11:05 EDT
kushaldas: do you have any thoughts based on the feedback posted in comment#4?
Comment 7 kushaldas@gmail.com 2009-05-22 13:21:08 EDT
I don't have much clue except the following line looks suspicious: 

"[gui:343] Device is not yet mounted, so we cannot determine the amount of free
space.  Setting a maximum limit of 8G for the persistent storage.
"

lmaken should be best guy to comment on this.
Comment 8 Rahul Sundaram 2009-05-25 00:49:37 EDT
This problem seems to be from using a older version of syslinux. Explanation and solution at 

http://fedoraproject.org/wiki/Fedora_11_Beta_release_notes#Live_Image_issues
Comment 9 Christopher Beland 2009-05-25 22:37:33 EDT
The solution in the beta release notes doesn't work; I get the following error from yum:

Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by syslinux-3.75-1.fc11.i586
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])
Comment 10 James Laska 2009-05-26 09:36:58 EDT
beland: see the first entry in http://fedoraproject.org/wiki/YumUpgradeFaq#Fedora_10_-.3E_Fedora_11_.28tentative.29.

The package is available in bodhi as https://admin.fedoraproject.org/updates/F10/FEDORA-2009-5214

Can you upgrade your F10 rpm to this package, and retest?  Thanks!
Comment 11 Christopher Beland 2009-05-26 12:45:08 EDT
You want me to upgrade my entire Fedora 9 system to Fedora 10 just so I can work around bug 492370 and make a Fedora 11 LiveUSB?  Is there not going to be a fix so people can make Fedora 11 LiveUSBs from Fedora 9 directly?  (I first ran into this bug, 498155, on Fedora 9.)
Comment 12 James Laska 2009-05-26 13:26:57 EDT
(In reply to comment #11)
> You want me to upgrade my entire Fedora 9 system to Fedora 10 just so I can
> work around bug 492370 and make a Fedora 11 LiveUSB?  

beland: I'm suggesting that in order to work around the rpmlib(FileDigests) problem you reported while attempting to install the latest syslinux package, that you would update to a rpm version that understands the new signatures.  However, apologies ... I didn't know you were coming from F9.

A fix for this issue was made available for F10 users (see bug#492370).  However, I don't believe such a fix is available for F9 users.  If you can confirm that this is indeed the issue you are seeing, we can reassign this bug to get a fix for F9 users before F9 is EOL'd.
Comment 13 Bill Nottingham 2009-05-26 13:42:02 EDT
Removing from the F11 blocker; would still be nice to solve the issue with the F9 tools.b
Comment 14 Christopher Beland 2009-05-26 13:51:06 EDT
Yes, the error in comment #9 is with Fedora 9, and is the reason bug 492370 still affects F9.
Comment 15 James Laska 2009-05-26 15:45:10 EDT
beland: Can you try creating the live image using this livecd-iso-to-disk script located at http://katzj.fedorapeople.org/livecd-iso-to-disk-f9.sh ?

If this works for you, jeremy will work up a patch and build officially for Fedora 9.
Comment 16 Christopher Beland 2009-05-27 02:31:08 EDT
Yes, I can successfully boot the LiveUSB I made with that script under Fedora 9.
Comment 17 James Laska 2009-05-27 10:05:24 EDT
katzj: looks like your script was successful.  Not sure how you would like to handle this.  Should we reassign this bug (component and owner) to livecd-tools with you as the owner?  Or do you have a preferred resolution?
Comment 18 Fedora Update System 2009-05-27 10:27:39 EDT
livecd-tools-017.3-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/livecd-tools-017.3-1.fc9
Comment 19 Jeremy Katz 2009-05-27 10:30:28 EDT
Update to the Fedora 9 livecd-tools package should be headed to updates-testing shortly (built and submitted) and will then get pushed to final after a week of making sure it doesn't break anything else
Comment 20 James Laska 2009-05-27 10:51:13 EDT
Thanks Jeremy!  A note has been added to the Common_F11_Bugs page direction Fedora 9 users to test the updated livecd-tools package.

https://fedoraproject.org/wiki/Common_F11_bugs#498155
Comment 21 Christopher Beland 2009-05-27 15:34:16 EDT
So while this fixes bug 492370 for Fedora 9 (which is excellent, since it provides a feasible LiveUSB F9->F11 install path), I am still getting a grey screen when I use liveusb-creator-3.6.3-1.fc9.noarch to create a Fedora 11 Preview LiveUSB image.  (As originally reported above, this also affects current Rawhide.)
Comment 22 Christopher Beland 2009-05-28 03:31:30 EDT
Whoops, the grey screen issue is actually being tracked over at Bug 494000.
Comment 23 Fedora Update System 2009-05-28 04:07:10 EDT
livecd-tools-017.3-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update livecd-tools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-5600
Comment 24 Fedora Update System 2009-06-04 17:19:40 EDT
livecd-tools-017.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.