Bug 494000 - Gray screen on boot with Fedora 11 LiveCD made on Fedora 9, 10
Gray screen on boot with Fedora 11 LiveCD made on Fedora 9, 10
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: liveusb-creator (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: kushaldas@gmail.com
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, Patch, Reopened, Triaged
: 495402 496378 (view as bug list)
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-04-03 12:52 EDT by zachary charlop-powers
Modified: 2013-01-10 00:08 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 04:11:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the "bullseye" (2.82 MB, image/jpeg)
2009-04-03 14:59 EDT, zachary charlop-powers
no flags Details
the "grub menu" and password prompt (3.35 MB, image/jpeg)
2009-04-03 15:00 EDT, zachary charlop-powers
no flags Details

  None (edit)
Description zachary charlop-powers 2009-04-03 12:52:55 EDT
Description of problem: I cannot boot from a liveusb.  I enter what should be the grub menu but actually is a bunch of concentric gray rings that looks like a bullseye. If I don't do anything this screen stays as is. If I touch the keyboard I get the outline box of a grub menu but no text is visible. If I press enter I am then prompted for a password. I tried my system password, "fedora," "guest", and a few others to see what would happen. Nothing happens.


Version-Release number of selected component (if applicable): fedora-11-beta-livecd-iso


How reproducible: every time


Steps to Reproduce:
1. insert usb that has livecd Fedora11 Beta image
2. on Dell bios choose to boot form usb
3. boots into stalled screen
  
Actual results: see above.


Expected results: boot into livecd menu and be able to use the livecd


Additional info: i am using a dell optiplex with an ATI FireGl card (r300, I think). Nothing special.
Comment 1 Chris Lumens 2009-04-03 13:09:56 EDT
Can you attach a picture of the screen you are stuck at?  I don't know what screen you're talking about.
Comment 2 zachary charlop-powers 2009-04-03 13:26:36 EDT
how do i do a screen capture of a boot sequence?
Comment 3 Chris Lumens 2009-04-03 14:04:15 EDT
With a camera?
Comment 4 zachary charlop-powers 2009-04-03 14:59:02 EDT
Created attachment 338104 [details]
the "bullseye"
Comment 5 zachary charlop-powers 2009-04-03 15:00:45 EDT
Created attachment 338106 [details]
the "grub menu" and password prompt

the backgourd box is by itself. when you press enter you are prompted to enter a password (foreground)
Comment 6 zachary charlop-powers 2009-04-03 15:02:40 EDT
re: comment 3


man, that was a no-brainer, eh? i thought you might introduce me to some new pre-X-server screenshot capture technology. but hey, cameras work too.
Comment 7 Avalone 2009-04-07 06:36:18 EDT
see https://fedorahosted.org/liveusb-creator/ticket/585

as posted - download and reinstall syslinux after liveusb creator will solve this (checked with ver 3.7.4pre19)

i'm think this will be fixed in next version of liveusbcreator
Comment 8 Chris Lumens 2009-04-13 13:58:11 EDT
Avalone - thanks for pointing that out.  It looks very much like what the reporter here is seeing as well.  Reassigning.
Comment 9 Chris Lumens 2009-04-13 13:59:50 EDT
*** Bug 495402 has been marked as a duplicate of this bug. ***
Comment 10 Christopher Beland 2009-04-24 05:44:15 EDT
Will the fix be available before Fedora 11 general release, or should an updated syslinux be pushed to Fedora 9 and 10 to fix it that way?  Otherwise, everyone using this nice GUI method to create Fedora 11 LiveUSB media from F9 or F10 will need to employ a manual workaround, which will need to be included in the release notes.
Comment 11 Jeremy Katz 2009-04-29 09:55:53 EDT
Luke -- you probably want to put in something like the bad hack I did in livecd-iso-to-disk.sh to basically copy over the menu files from the host system onto the usb stick as the com32 abi isn't stable apparently.

See commit 42233b2d2d6abb722d713e21cdac7d7895b0d623 in the livecd tools repo
Comment 12 Adam Williamson 2009-04-29 12:37:49 EDT
this is just a dupe of 492370, where the fix is being worked on.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 492370 ***
Comment 13 Jeremy Katz 2009-04-29 15:18:13 EDT
Not a dupe as this is liveusb-creator, not the livecd-iso-to-disk shell script distributed with livecd-tools.  Eventually the two will hopefully be one and the same, but we're not there yet
Comment 14 Adam Williamson 2009-04-29 20:53:53 EDT
eek, sorry, that'll teach me to bugzap with quarter of a brain awake...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Jeremy Katz 2009-05-04 15:19:56 EDT
*** Bug 496378 has been marked as a duplicate of this bug. ***
Comment 16 Christopher Beland 2009-05-28 03:40:58 EDT
Still a problem with liveusb-creator-3.6.3-1.fc9.noarch.  Is there hope of getting this fixed before Fedora 9 is EOL, or should I just update the instructions (http://fedoraproject.org/wiki/How_to_create_and_use_Live_USB) to tell people to use livecd-iso-to-disk and avoid liveusb-creator if they are trying to upgrade?
Comment 17 Christopher Beland 2009-05-28 03:42:19 EDT
(The workaround at https://fedorahosted.org/liveusb-creator/ticket/585 doesn't work for F9 due to RPM checksum incompatibilities with Rawhide.)
Comment 18 Bug Zapper 2009-06-09 09:13:09 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 Luke Macken 2009-06-12 03:57:16 EDT
(In reply to comment #11)
> Luke -- you probably want to put in something like the bad hack I did in
> livecd-iso-to-disk.sh to basically copy over the menu files from the host
> system onto the usb stick as the com32 abi isn't stable apparently.
> 
> See commit 42233b2d2d6abb722d713e21cdac7d7895b0d623 in the livecd tools repo  

Thanks Jeremy, I ported your hack to the liveusb-creator.

https://fedorahosted.org/liveusb-creator/changeset/aff9357adbe48b8212cf4690a6dbea4bec23635c

https://admin.fedoraproject.org/updates/liveusb-creator-3.6.7-1.fc11 is on it's way to testing.
Comment 20 Julian Sikorski 2009-06-12 10:33:52 EDT
The bug report states that F11 live usbs cannot be created under Fedora 10 and 9. Please build the fixed liveusb-creator for these branches as well. TIA.
Comment 21 Fedora Update System 2009-06-15 22:14:56 EDT
liveusb-creator-3.6.7-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update liveusb-creator'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6344
Comment 22 Julian Sikorski 2009-06-16 03:49:20 EDT
Fedora 11 Live USBs created on Fedora 11 have always worked, so there is no way to test it. Please fix the bug in the branch it actually exists (I'm aware the release field was wrong at the beginning).
Comment 23 Fedora Update System 2009-06-24 15:04:40 EDT
liveusb-creator-3.7-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/liveusb-creator-3.7-1.fc11
Comment 24 Bug Zapper 2009-11-18 04:58:23 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 25 Bug Zapper 2009-12-18 04:11:11 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.