Bug 498553 - Live image installs allow clicking Next during FS creation - results in FSError: filesystem has not been created
Live image installs allow clicking Next during FS creation - results in FSErr...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:62198c3623e52bd61...
: CommonBugs
: 502771 504981 505861 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 22:47 EDT by Antonio Hernandez
Modified: 2010-07-16 10:07 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 10:36:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (179.71 KB, text/plain)
2009-04-30 22:47 EDT, Antonio Hernandez
no flags Details
Attached traceback automatically from anaconda. (65.27 KB, text/plain)
2009-05-21 12:25 EDT, Rebecca Fine
no flags Details
Attached traceback automatically from anaconda. (100.46 KB, text/plain)
2009-05-26 10:56 EDT, jmccann
no flags Details
Attached traceback automatically from anaconda. (749.35 KB, text/plain)
2009-06-10 06:45 EDT, Bastien Nocera
no flags Details
Attached traceback automatically from anaconda. (205.97 KB, text/plain)
2009-06-19 01:47 EDT, Justin Kay
no flags Details
Attached traceback automatically from anaconda. (66.04 KB, text/plain)
2009-06-22 11:04 EDT, Dave Shaffer
no flags Details
Attached traceback automatically from anaconda. (165.34 KB, text/plain)
2009-06-23 06:50 EDT, Luis Bernardo
no flags Details
Attached traceback automatically from anaconda. (73.83 KB, text/plain)
2009-06-30 14:33 EDT, Alex Z.
no flags Details
Attached traceback automatically from anaconda. (98.25 KB, text/plain)
2009-07-31 22:34 EDT, atrizu
no flags Details
Attached traceback automatically from anaconda. (300.42 KB, text/plain)
2009-08-14 14:10 EDT, John Albers
no flags Details
Attached traceback automatically from anaconda. (102.91 KB, text/plain)
2009-08-22 10:13 EDT, Olivier
no flags Details
Attached traceback automatically from anaconda. (192.47 KB, text/plain)
2009-09-20 18:16 EDT, Daniel Hendrycks
no flags Details
Attached traceback automatically from anaconda. (97.26 KB, text/plain)
2009-09-22 20:12 EDT, Daniel Hendrycks
no flags Details
Attached traceback automatically from anaconda. (101.88 KB, text/plain)
2009-09-28 19:38 EDT, Robert Townley
no flags Details
Attached traceback automatically from anaconda. (669.17 KB, text/plain)
2009-10-17 09:47 EDT, Alexander Todorov
no flags Details
Attached traceback automatically from anaconda. (103.63 KB, text/plain)
2009-10-20 23:56 EDT, dharmesh96
no flags Details
Attached traceback automatically from anaconda. (65.69 KB, text/plain)
2010-07-16 10:06 EDT, lagend
no flags Details

  None (edit)
Description Antonio Hernandez 2009-04-30 22:47:23 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/fs.py", line 538, in unmount
    raise FSError("filesystem has not been created")
  File "/usr/lib/anaconda/storage/formats/fs.py", line 730, in teardown
    return self.unmount(*args, **kwargs)
  File "/usr/lib/anaconda/storage/__init__.py", line 1577, in umountFilesystems
    device.format.teardown()
  File "/usr/lib/anaconda/livecd.py", line 163, in doPreInstall
    swapoff = False)
  File "/usr/lib/anaconda/backend.py", line 282, in doPreInstall
    anaconda.backend.doPreInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1330, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1351, in handleRenderCallback
    self.currentWindow.renderCallback()
FSError: filesystem has not been created
Comment 1 Antonio Hernandez 2009-04-30 22:47:34 EDT
Created attachment 342033 [details]
Attached traceback automatically from anaconda.
Comment 2 Jeremy Katz 2009-05-06 21:45:22 EDT
What version of anaconda is on the livecd you're using?
Comment 3 James Laska 2009-05-15 12:20:17 EDT
katzj: bug#500991 is very similar (from rawhide and not a LiveCD) ... Does that have the information you're looking for?
Comment 4 Jeremy Katz 2009-05-15 15:56:13 EDT
The traceback is similar, but a bit different so not sure if it's the same or not.

Antonio -- more information on exactly what livecd you're using and what partitioning setup you tried to do would help here
Comment 5 Rebecca Fine 2009-05-21 12:25:11 EDT
Created attachment 344987 [details]
Attached traceback automatically from anaconda.
Comment 6 jmccann 2009-05-26 10:56:09 EDT
Created attachment 345476 [details]
Attached traceback automatically from anaconda.
Comment 7 James Laska 2009-05-26 11:50:28 EDT
jmccann: can you describe how you are reproducing this failure?  What are the steps you are following that lead up to the traceback?
Comment 8 jmccann 2009-05-26 18:08:36 EDT
* Booted i686 live (converted to usb) from http://alt.fedoraproject.org/pub/alt/stage/f11-rc0.1/  on an Acer Aspire One netbook.

* Clicked Install to HD.
* Clicked Next
* Selected US English & clicked Next
* Set hostname & clicked Next
* Clicked Next to set default timezone
* Set root password & clicked Next
* Selected "Use entire drive" from dropdown & clicked Next
* Clicked "Write changes to disk" on popup dialog
* Dialog went away
* Clicked Next on same page that showed "use entire drive"
* Crashed
Comment 9 Chris Lumens 2009-05-27 10:25:02 EDT
*** Bug 502771 has been marked as a duplicate of this bug. ***
Comment 10 Traxtopel 2009-05-27 10:35:27 EDT
I worked around the issue with the following.

--- storage/formats/fs.py.orig	2009-05-27 16:18:04.000000000 +0200
+++ storage/formats/fs.py	2009-05-27 16:17:25.000000000 +0200
@@ -349,8 +349,7 @@
             rc = iutil.execWithPulseProgress(self.mkfsProg,
                                              argv,
                                              stdout="/dev/tty5",
-                                             stderr="/dev/tty5",
-                                             progress=w)
+                                             stderr="/dev/tty5")
         except Exception as e:
             raise FormatCreateError(e, self.device)
         finally:


Its the pulse progress bar which does not appear on the small netbooks, could it be it needs the window to show correctly, on the netbooks anaconda appears in fullscreen mode.
Comment 11 jmccann 2009-05-27 15:01:58 EDT
That workaround also allowed my install to continue.
Comment 12 James Laska 2009-05-27 15:11:02 EDT
jmccann: Just to confirm, you used an updates.img to provide the patch posted to comment#10 to work around the bug you are reporting in comment#8?
Comment 13 jmccann 2009-05-27 15:36:21 EDT
No, I vi'd the fs.py file directly (as in comment 10) in the running livecd and removed the .pyc and .pyo files then ran the installer again.
Comment 14 James Laska 2009-05-29 09:38:42 EDT
I've completed many live image installs on many platforms and not seen this issue using the very clear steps described in comment#8.

I finally read a comment from Traxtopel in the bug#502771 (cloned to this bug):

>> When you have selected the partitioning of the harddisk, clicked next and
>> waiting for the install to start. The NEXT button is still clickable, if you
>> click on this by mistake or think the install is not running, it will fail.
>> 
>> Perhaps this is only present on slower machines.
>> 
>> Would it be possible to disable Next after paritioning starts, so this cannot
>> fail?

I've now reproduced the problem by feverishly clicking the "Next" button while file system creation is underway.  I cannot reproduce this in normal installs, only live installs.  Perhaps there is a window focus problem.
Comment 15 Ray Strode [halfline] 2009-05-29 09:45:05 EDT
    so clumens and I looked into this a bit yesterday.

    We think the problem is this:

    1) metacity is starting progress dialogs between pages below the fullscreen
    installer window even though they are transient to the installer window.  or
    potentially a None parent is getting passed in so they aren't getting set
    transient properly.
    2) anaconda isn't setting progress dialogs to modal so the next button still
    works when it shouldn't
    3) the next button doesn't expect to get clicked while the dialog is up and
    behaves in all sorts of weird ways at that point

    The anaconda fixes are:

    1) make the progress dialogs modal to the fullscreen window
    2) verify that the parent getting passed in is not None
    3) potentially explicitly raise the dialog to work around them showing up
    behind the fullscreen window if they're showing up behind because of a metacity
    bug and not 2)
Comment 16 James Laska 2009-05-29 10:13:45 EDT
Thanks everyone!  This really helps outline the failure conditions as well as the changes required to properly address the issue.

I've discussed this issue with clumens and rstrode, and we've agreed to add the circumstances described into the https://fedoraproject.org/wiki/Common_F11_bugs page and address this post-F11.  I've added the keyword CommonBugs.  I, or another QA member will revisit this bug and document the issue in the coming days.  

However, if someone would like to help and draft a note ... please see https://fedoraproject.org/wiki/Common_F11_bugs#My_bug_is_not_listed
Comment 17 Chris Lumens 2009-05-29 10:36:21 EDT
This should be fixed in the next build of anaconda in Rawhide, post F11.  Thanks for the bug report and testing.
Comment 18 Traxtopel 2009-06-05 06:18:14 EDT
This is closed but running 11.5.0.59 the problem still exists.
Do I need to move to anaconda-11.1.2.183-1 for this bug to be resolved?
Comment 19 James Laska 2009-06-05 07:54:55 EDT
traxtopel: you got it, this won't be fixed until an anaconda build post-F11.  I don't believe a version has been cut yet for this, but the fix is in the master git branch in anaconda (http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=48ebe93bb6d76dcabc98fb4f1af6375f7464ff5f).
Comment 20 Traxtopel 2009-06-05 09:55:34 EDT
But does this fix
https://bugzilla.redhat.com/show_bug.cgi?id=502771

I am still seeing this issue, i.e. when installing from liveusb the harddisk does not get formatted.
Comment 21 James Laska 2009-06-09 08:04:52 EDT
This issue has been documented at https://fedoraproject.org/wiki/Common_F11_bugs#498553
Comment 22 Bastien Nocera 2009-06-10 06:45:30 EDT
Created attachment 347197 [details]
Attached traceback automatically from anaconda.
Comment 23 Chris Lumens 2009-06-10 13:43:08 EDT
*** Bug 504981 has been marked as a duplicate of this bug. ***
Comment 24 Justin Kay 2009-06-19 01:47:12 EDT
Created attachment 348605 [details]
Attached traceback automatically from anaconda.
Comment 25 Dave Shaffer 2009-06-22 11:04:17 EDT
Created attachment 348926 [details]
Attached traceback automatically from anaconda.
Comment 26 Dave Shaffer 2009-06-22 11:16:35 EDT
I am a big newbie at Linux so any help understanding the processes to get this resolved would be appreciated. I am installing this in Sun's Virtual Box as a guest. The host is Windows Vista Premium.
Comment 27 Luis Bernardo 2009-06-23 06:50:51 EDT
Created attachment 349076 [details]
Attached traceback automatically from anaconda.
Comment 28 Ray Strode [halfline] 2009-06-23 15:44:40 EDT
Hi Dave,

The problem is already resolved upstream, but not fixed in F11.

The bug is caused by hitting the Next button when the installer is busy processing a previous next button click.

To work around this bug, be very careful when you hit the Next button.  Only hit the button one time after being asked for information and then wait until the installer switches pages before clicking again.  This waiting period can be several minutes for some of the steps (normally there would be progress dialogs for the slow steps, but the bug prevents the dialogs from showing up).
Comment 29 Alex Z. 2009-06-30 14:33:11 EDT
Created attachment 349999 [details]
Attached traceback automatically from anaconda.
Comment 30 atrizu 2009-07-31 22:34:59 EDT
Created attachment 355871 [details]
Attached traceback automatically from anaconda.
Comment 31 Chris Lumens 2009-08-12 09:51:19 EDT
*** Bug 505861 has been marked as a duplicate of this bug. ***
Comment 32 John Albers 2009-08-14 14:10:07 EDT
Created attachment 357488 [details]
Attached traceback automatically from anaconda.
Comment 33 Olivier 2009-08-22 10:13:46 EDT
Created attachment 358305 [details]
Attached traceback automatically from anaconda.
Comment 34 Olivier 2009-08-22 10:18:15 EDT
Comment on attachment 358305 [details]
Attached traceback automatically from anaconda.

Can't install F11 on Sun Virtual Box 2.2.4r47978
Exception when formatting /dev/sda1 when installing from fresh ISO CD.
Comment 35 Daniel Hendrycks 2009-09-20 18:16:06 EDT
Created attachment 361842 [details]
Attached traceback automatically from anaconda.
Comment 36 Daniel Hendrycks 2009-09-22 20:12:56 EDT
Created attachment 362153 [details]
Attached traceback automatically from anaconda.
Comment 37 Robert Townley 2009-09-28 19:38:38 EDT
Created attachment 362948 [details]
Attached traceback automatically from anaconda.
Comment 38 Alexander Todorov 2009-10-17 09:47:50 EDT
Created attachment 365121 [details]
Attached traceback automatically from anaconda.
Comment 39 dharmesh96 2009-10-20 23:56:42 EDT
Created attachment 365457 [details]
Attached traceback automatically from anaconda.
Comment 40 lagend 2010-07-16 10:06:56 EDT
Created attachment 432392 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.