Bug 498589 - [enh] Inform the user when trying to add VPN's when the VPN plug-in is not installed
[enh] Inform the user when trying to add VPN's when the VPN plug-in is not in...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: FutureFeature
: 480354 (view as bug list)
Depends On:
Blocks: 798294
  Show dependency treegraph
 
Reported: 2009-05-01 06:52 EDT by Stephen Rowles
Modified: 2012-02-28 09:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 798294 (view as bug list)
Environment:
Last Closed: 2012-02-28 09:58:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 625160 None None None Never

  None (edit)
Description Stephen Rowles 2009-05-01 06:52:43 EDT
Description of problem:

Network manager, as installed by default in Fedora 10, doesn't have the vpn component installed. However network manager still shows the VPN tab but with the Add... button greyed out.

There is no indication to the user that this is because the appropriate NetworkManager component is not installed and it took a lot of searching on the web to discover this was the case.

The VPN tab be replaced with a panel saying "Install one of the vpn network manager packages to use this functionality" (or similar) if the appropriate package components are not installed to use that tab. At the moment as the tab is fully populated with buttons it looks like a configuration / permission problem that a VPN connection cannot be added.

Version-Release number of selected component (if applicable):

Fedora 10
NetworkManager 0.7.0.99
Release: 5.git20090326.fc10

How reproducible:

Always

Steps to Reproduce:
1. Right click on NetworkManager icon
2. Select VPN tab
  
Actual results:

All buttons are greyed out and cannot be clicked on, no indication of how to remedy this situation.

Expected results:

Some indication of what I need to do to get the buttons enabled, ideally a "click here to install", but a simple piece of text telling me to install a NetworkManager vpn component would be a great help!


Additional info:
Comment 1 Niels Haase 2009-05-02 04:54:17 EDT
Reporter, thanks for filling this bug.

It looks like more than a enhancement request. Therefore I changed the title to
reflect the enhancement request.


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Niels Haase 2009-05-07 14:52:43 EDT
*** Bug 480354 has been marked as a duplicate of this bug. ***
Comment 3 Jirka Klimes 2012-02-28 09:58:40 EST
This was implemented some time ago.
Upstream bug is https://bugzilla.gnome.org/show_bug.cgi?id=625160

Note You need to log in before you can comment on or make changes to this bug.