Bug 798294 - [enh] Inform the user when trying to add VPN's when the VPN plug-in is not installed
Summary: [enh] Inform the user when trying to add VPN's when the VPN plug-in is not in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager
Version: 6.3
Hardware: All
OS: Linux
medium
low
Target Milestone: rc
: 6.3
Assignee: Dan Williams
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 498589
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-28 14:55 UTC by Jirka Klimes
Modified: 2016-01-04 06:02 UTC (History)
7 users (show)

Fixed In Version: NetworkManager-0.8.1-21.el6
Doc Type: Enhancement
Doc Text:
Clone Of: 498589
Environment:
Last Closed: 2012-06-20 13:42:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 625160 None None None Never
Red Hat Product Errata RHBA-2012:0832 normal SHIPPED_LIVE NetworkManager bug fix and enhancement update 2012-06-19 20:49:16 UTC

Description Jirka Klimes 2012-02-28 14:55:14 UTC
+++ This bug was initially created as a clone of Bug #498589 +++

Description of problem:

Network manager, as installed by default in Fedora 10, doesn't have the vpn component installed. However network manager still shows the VPN tab but with the Add... button greyed out.

There is no indication to the user that this is because the appropriate NetworkManager component is not installed and it took a lot of searching on the web to discover this was the case.

The VPN tab be replaced with a panel saying "Install one of the vpn network manager packages to use this functionality" (or similar) if the appropriate package components are not installed to use that tab. At the moment as the tab is fully populated with buttons it looks like a configuration / permission problem that a VPN connection cannot be added.

Version-Release number of selected component (if applicable):

Fedora 10
NetworkManager 0.7.0.99
Release: 5.git20090326.fc10

How reproducible:

Always

Steps to Reproduce:
1. Right click on NetworkManager icon
2. Select VPN tab
  
Actual results:

All buttons are greyed out and cannot be clicked on, no indication of how to remedy this situation.

Expected results:

Some indication of what I need to do to get the buttons enabled, ideally a "click here to install", but a simple piece of text telling me to install a NetworkManager vpn component would be a great help!


Additional info:

--- Additional comment from arxs@fedoraproject.org on 2009-05-02 04:54:17 EDT ---

Reporter, thanks for filling this bug.

It looks like more than a enhancement request. Therefore I changed the title to
reflect the enhancement request.


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from arxs@fedoraproject.org on 2009-05-07 14:52:43 EDT ---

*** Bug 480354 has been marked as a duplicate of this bug. ***

Comment 1 Jirka Klimes 2012-02-28 15:06:45 UTC
The upstream patch is 0330ecae2eec0d4dfccd57921f1992b8e245e2da

It adds a tooltip for greyed "Add" button, telling the user that he should
install a VPN plugin in order to be able to configure VPN connections.

This is a simple and self-contained change.

Comment 8 errata-xmlrpc 2012-06-20 13:42:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0832.html


Note You need to log in before you can comment on or make changes to this bug.