Bug 499026 - Keyboard layout is ignored after log-in
Keyboard layout is ignored after log-in
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 499051 499501 (view as bug list)
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-05-04 16:35 EDT by Lauri Nurmi
Modified: 2015-01-14 18:22 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 20:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lauri Nurmi 2009-05-04 16:35:40 EDT
Description of problem:
The keyboard layout that is selected during installation is ignored after logging in to the installed system.

Version-Release number of selected component (if applicable):
Fedora-11-Preview-x86_64-DVD.iso

How reproducible:
100% with two attempts.

Steps to Reproduce:
1. Begin installation
2. Choose Finnish keyboard layout
3. Finish installation; log in to the system
  
Actual results:
Keyboard layout is US.  GDM correctly indicates the layout is Finland, but after log-in it is US, and the only layout listed in Gnome's keyboard settings (by default) is USA.

Expected results:
Keyboard layout should be Finnish.

Additional info:
I only tried with Finnish layout, but I don't see why this would be a Finnish-specific problem.
Comment 1 Peter Hutterer 2009-05-05 18:49:33 EDT
*** Bug 499051 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Clasen 2009-05-06 12:33:30 EDT
Can you try updating to gdm-2.26.1-7.fc11, 
gnome-settings-daemon-2.26.1-4.fc11 and 
control-center-2.26.0-6.fc11, and see if the problem goes away ?
Comment 3 Dick Franks 2009-05-06 18:14:18 EDT
(In reply to comment #2)
> Can you try updating to gdm-2.26.1-7.fc11, 
> gnome-settings-daemon-2.26.1-4.fc11 and 
> control-center-2.26.0-6.fc11, and see if the problem goes away ?  

Thanks Matthias

Works for me.
Comment 4 Matthias Clasen 2009-05-06 20:05:31 EDT
Thanks for testing
Comment 5 Matthias Clasen 2009-05-06 20:10:39 EDT
*** Bug 499501 has been marked as a duplicate of this bug. ***
Comment 6 malak 2010-08-02 21:16:10 EDT
I know that this is "an old bug" but this problem persists on all my Fedora 12 systems.

I use the "Canada French (legacy)" layout.  When I shut down my machines (every once in a while for my desktop and server, and regularly for my laptop) after a new power-up, the US keyboard shows up as an optional keyboard layout, although the Canada French (legacy) layout is marked as the default; however, the US keyboard layout is the layout; to get the correct layout, in the system/keyboards/layouts screen I must select the US layout and click on "remove".

The above-mentioned packages, corresponding to F12, are all up to date.

Note You need to log in before you can comment on or make changes to this bug.