Bug 499331 - update to qt-4.5.0 broke pasting in Jabbim
update to qt-4.5.0 broke pasting in Jabbim
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On: Qt451
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 03:45 EDT by Michal Schmidt
Modified: 2009-06-15 21:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.2.3-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 21:30:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2009-05-06 03:45:24 EDT
Description of problem:
After the update from qt-4.4.<something> to qt-4.5.0 pasting with mouse middle click in Jabbim started to act erratically.

Version-Release number of selected component (if applicable):
qt-4.5.0-14.fc10.x86_64
jabbim-0.4.3-3.fc10.noarch

How reproducible:
always

Steps to Reproduce:
1. Run Jabbim, login, open a conversation or MUC window.
2. Select a text in another application (gnome-terminal or gedit).
3. Middle click in Jabbim into the window where you usually type your messages.
4. Notice the text is pasted correctly. Good.
5. Now select some text in Jabbim itself (either from the conversation box or from the compose box).
6. Select a text in another application (like in step 2).
7. Middle click in Jabbim (like in step 3).
  
Actual results:
Jabbim's own text (the one you selected in step 5) is pasted. Not the one you want. Since step 5 it does not matter what you select in any other application, Jabbim will now only paste texts it selected itself.

Expected results:
The text from the other application (the one from step 6) should be pasted.

Additional info:
Updating to current qt-4.5.1 from Koji fixes the problem. Please provide an update for F-10 soon.
Comment 1 Kevin Kofler 2009-05-06 04:02:29 EDT
Tracking as fixed in 4.5.1 (depends on Qt451).

The problem is that 4.5.1 breaks other things, see bug 497659 and bug 498603.
Comment 2 Fedora Update System 2009-05-11 13:49:09 EDT
qt-4.5.1-10.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qt-4.5.1-10.fc11
Comment 3 Fedora Update System 2009-05-11 13:50:58 EDT
qt-4.5.1-10.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/qt-4.5.1-10.fc10
Comment 4 Fedora Update System 2009-05-12 00:07:26 EDT
qt-4.5.1-10.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4813
Comment 5 Fedora Update System 2009-05-12 00:11:28 EDT
qt-4.5.1-10.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4844
Comment 6 Fedora Update System 2009-05-20 19:53:11 EDT
qt-4.5.1-10.fc11, kdelibs-4.2.3-3.fc11, kdeplasma-addons-4.2.3-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt kdelibs kdeplasma-addons'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4813
Comment 7 Fedora Update System 2009-05-20 20:02:43 EDT
qt-4.5.1-10.fc10, kdelibs-4.2.3-3.fc10, kdeplasma-addons-4.2.3-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt kdelibs kdeplasma-addons'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4844
Comment 8 Fedora Update System 2009-05-25 17:17:39 EDT
kdelibs-4.2.3-3.fc11, kdeplasma-addons-4.2.3-2.fc11, qt-4.5.1-11.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdelibs kdeplasma-addons qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4813
Comment 9 Fedora Update System 2009-05-25 17:20:25 EDT
kdelibs-4.2.3-3.fc10, kdeplasma-addons-4.2.3-2.fc10, qt-4.5.1-11.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdelibs kdeplasma-addons qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4844
Comment 10 Fedora Update System 2009-06-02 10:37:30 EDT
kdelibs-4.2.3-3.fc11, kdeplasma-addons-4.2.3-2.fc11, qt-4.5.1-13.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdelibs kdeplasma-addons qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4813
Comment 11 Fedora Update System 2009-06-15 21:30:38 EDT
kdelibs-4.2.3-3.fc10, kdeplasma-addons-4.2.3-2.fc10, qt-4.5.1-13.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-06-15 21:35:32 EDT
kdelibs-4.2.3-3.fc11, kdeplasma-addons-4.2.3-2.fc11, qt-4.5.1-13.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.