Bug 499513 - SELinux is preventing fprintd (fprintd_t) "getattr" var_lib_t.
SELinux is preventing fprintd (fprintd_t) "getattr" var_lib_t.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fprintd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 499797 499852 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 18:09 EDT by Ruben Kerkhof
Modified: 2009-05-08 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 10:39:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruben Kerkhof 2009-05-06 18:09:22 EDT
Summary:

SELinux is preventing fprintd (fprintd_t) "getattr" var_lib_t.

Detailed Description:

[SELinux is in permissive mode, the operation would have been denied but was
permitted due to permissive mode.]

SELinux denied access requested by fprintd. It is not expected that this access
is required by fprintd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:fprintd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_lib_t:s0
Target Objects                /var/lib/fprint/ruben/0001/00000000/7 [ file ]
Source                        fprintd
Source Path                   /usr/libexec/fprintd
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           fprintd-0.1-8.git04fd09cfa.fc11
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.12-28.fc11
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain
                              2.6.29.1-102.fc11.x86_64 #1 SMP Mon Apr 20
                              15:33:38 EDT 2009 x86_64 x86_64
Alert Count                   2
First Seen                    Wed 06 May 2009 10:48:13 PM CEST
Last Seen                     Thu 07 May 2009 12:08:00 AM CEST
Local ID                      a01b2b54-91af-43d9-bb29-bd4b798413e7
Line Numbers                  

Raw Audit Messages            

node=localhost.localdomain type=AVC msg=audit(1241647680.185:102): avc:  denied  { getattr } for  pid=3293 comm="fprintd" path="/var/lib/fprint/ruben/0001/00000000/7" dev=dm-1 ino=1001769 scontext=system_u:system_r:fprintd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_lib_t:s0 tclass=file

node=localhost.localdomain type=SYSCALL msg=audit(1241647680.185:102): arch=c000003e syscall=5 success=no exit=1347313624 a0=a a1=7fff863f72c0 a2=7fff863f72c0 a3=30303030302f3130 items=0 ppid=1 pid=3293 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="fprintd" exe="/usr/libexec/fprintd" subj=system_u:system_r:fprintd_t:s0-s0:c0.c1023 key=(null)
Comment 1 Daniel Walsh 2009-05-07 10:12:35 EDT
Fixed in selinux-policy-3.6.12-31.fc11.noarch
Comment 2 Daniel Walsh 2009-05-07 10:13:48 EDT
But /var/lib/fprint should be added to fprintd rpm spec file.

This will make sure the directory gets created with the correct context.
Comment 3 Bastien Nocera 2009-05-07 10:39:08 EDT
Built in fprintd-0.1-9.git04fd09cfa.fc11, and tagging requested.
Comment 4 Bastien Nocera 2009-05-08 07:44:30 EDT
*** Bug 499797 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Walsh 2009-05-08 11:37:46 EDT
*** Bug 499852 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.