Bug 500032 - anaconda 11.5.0.51-1.fc11 (i586) in rescue mode not bind /dev to /mnt/sysimage/dev
anaconda 11.5.0.51-1.fc11 (i586) in rescue mode not bind /dev to /mnt/sysimag...
Status: CLOSED DUPLICATE of bug 499742
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-10 06:06 EDT by Frantisek Hanzlik
Modified: 2009-05-11 10:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 09:52:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frantisek Hanzlik 2009-05-10 06:06:29 EDT
Description of problem:
When boot in rescue mode, all seems mounted OK under /mnt/sysimage with exception bad mounted "/dev". Thus under /mnt/sysimage/dev aren't any device and work under chrooted /mnt/sysimage is problematic.

# ls /mnt/sysimage/dev
pts
shm

# mount
rootfs on / type rootfs (rw,relatime)
/proc on /proc type proc (rw,relatime)
/dev on /dev type tmpfs (rw,relatime)
/dev/pts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
/sys on /sys type sysfs (rw,relatime)
none on /tmp type ramfs (rw,relatime)
/dev/loop0 on /mnt/runtime type squashfs (ro,relatime)
/selinux on /selinux type selinuxfs (rw,relatime)
/dev/md0 on /mnt/sysimage type ext3 (rw,relatime,errors=continue,data=ordered)
/dev/md0 on /mnt/sysimage/dev type ext3 (rw,relatime,errors=continue,data=ordered)
/dev/devpts on /mnt/sysimage/dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
/dev/tmpfs on /mnt/sysimage/dev/shm type tmpfs (rw,relatime)
/dev/md1 on /mnt/sysimage/home type ext3 (rw,relatime,errors=continue,data=ordered)
/dev/md2 on /mnt/sysimage/mnt/zalohy type ext3 (rw,relatime,errors=continue,data=ordered)
/dev/proc on /mnt/sysimage/proc type proc (rw,relatime)
/dev/sysfs on /mnt/sysimage/sys type sysfs (rw,relatime)
/selinux on /mnt/sysimage/selinux type selinuxfs (rw,relatime)

Version-Release number of selected component (if applicable):
anaconda-11.5.0.51-1.fc11.i586 on boot.iso from 8-May-2009

How reproducible:
Tested on system on single SATA drive (/dev/sda) and on system with two SATA drives with 3 SW RAID1 partitions where rootfs is on /dev/md0.
Both systems have this problem.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

in place of:
/dev/md0 on /mnt/sysimage/dev type ext3
perhaps would be better:
/dev on /mnt/sysimage/dev type tmpfs
Comment 1 Chris Lumens 2009-05-11 09:52:33 EDT

*** This bug has been marked as a duplicate of bug 499724 ***
Comment 2 Jakub Jelinek 2009-05-11 09:57:50 EDT
Seems to be a bug number typo, #499724 doesn't seem to have anything to do with this.
Comment 3 Chris Lumens 2009-05-11 10:04:29 EDT
Yep - typo in the changelog.  Sorry for the noise.

*** This bug has been marked as a duplicate of bug 499742 ***

Note You need to log in before you can comment on or make changes to this bug.