Bug 499985 - grub doesn't draw the splash image when the timeout is non-zero
grub doesn't draw the splash image when the timeout is non-zero
Status: CLOSED DUPLICATE of bug 473319
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-09 16:29 EDT by Nicholas Miell
Modified: 2009-05-31 06:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-31 06:14:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
broken behavior (4.43 KB, image/png)
2009-05-09 16:29 EDT, Nicholas Miell
no flags Details
correct behavior (92.92 KB, image/png)
2009-05-09 16:30 EDT, Nicholas Miell
no flags Details
drop in replacement for the existing grub-keystatus.patch (17.24 KB, patch)
2009-05-09 16:33 EDT, Nicholas Miell
no flags Details | Diff

  None (edit)
Description Nicholas Miell 2009-05-09 16:29:59 EDT
Created attachment 343232 [details]
broken behavior

Description of problem:

The grub keystatus patch in rawhide/F11 broke the background drawing in the non-zero timeout case, leading to ugliness.

Version-Release number of selected component (if applicable):
grub-0.97-50.fc11.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Set a non-zero boot timeout
  
Actual results:
see attachment

Expected results:
see the other attachment
Comment 1 Nicholas Miell 2009-05-09 16:30:21 EDT
Created attachment 343233 [details]
correct behavior
Comment 2 Nicholas Miell 2009-05-09 16:33:09 EDT
Created attachment 343234 [details]
drop in replacement for the existing grub-keystatus.patch

This drop-in replacement for the existing grub-keystatus.patch file fixes the problem.
Comment 3 Nicholas Miell 2009-05-09 16:34:12 EDT
The interdiff between grub-keystatus.patch and grub-keystatus-fixed.patch is:

diff -u b/stage2/stage2.c b/stage2/stage2.c
--- b/stage2/stage2.c
+++ b/stage2/stage2.c
@@ -235,7 +235,7 @@
   char *cur_entry = 0;
   struct term_entry *prev_term = NULL;
 
-  if (grub_verbose || grub_timeout != 0)
+  if (grub_verbose)
     cls();
 
   /*
Comment 4 Kyle 2009-05-22 11:38:27 EDT
This appears to be a duplicate of Bug 473319.
Comment 5 Eelko Berkenpies 2009-05-31 06:14:50 EDT

*** This bug has been marked as a duplicate of bug 473319 ***

Note You need to log in before you can comment on or make changes to this bug.