This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 500132 - swap format error
swap format error
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
anaconda_trace_hash:112fbdc80f3f4ab32...
:
: 501340 503435 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-11 06:51 EDT by Frank Murphy
Modified: 2009-09-09 17:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 17:25:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (372.98 KB, text/plain)
2009-05-11 06:52 EDT, Frank Murphy
no flags Details
lshw of system (55.87 KB, application/octet-stream)
2009-05-13 04:01 EDT, Frank Murphy
no flags Details

  None (edit)
Description Frank Murphy 2009-05-11 06:51:43 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/swap.py", line 126, in teardown
    raise SwapSpaceError("format has not been created")
  File "/usr/lib/anaconda/storage/devices.py", line 1479, in destroy
    self.format.teardown()
  File "/usr/lib/anaconda/storage/deviceaction.py", line 218, in execute
    self.device.destroy()
  File "/usr/lib/anaconda/storage/devicetree.py", line 659, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 234, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
SwapSpaceError: format has not been created
Comment 1 Frank Murphy 2009-05-11 06:52:11 EDT
Created attachment 343426 [details]
Attached traceback automatically from anaconda.
Comment 2 David Cantrell 2009-05-12 20:30:18 EDT
Can you describe your system (disks, memory, cpu) and how you performed the installation?
Comment 3 Frank Murphy 2009-05-13 04:01:55 EDT
Created attachment 343718 [details]
lshw of system

System was F10, with 
/dev/sda1 as ext3 (boot)
/dev/sda2 lvm (ext4 root, swap)
/dev/sdb1 ext3
/dev/sdc1 swap (usb)

Installed from rawhide boot.iso
formatted /dev/sda, /dev/sdc
Comment 4 Chris Lumens 2009-05-29 11:26:16 EDT
Is this reproducable with F11 RC?  No one here has seen this bug in significant amounts of testing.  If you are able to reproduce, can you please give us thorough instructions on what you did with the partitioning UI so we can try to follow along?  Thanks.
Comment 5 Chris Lumens 2009-05-29 11:31:23 EDT
*** Bug 501340 has been marked as a duplicate of this bug. ***
Comment 6 Frank Murphy 2009-05-29 11:57:32 EDT
Sorry, Never got around to do an RC test. Sidetracked.
I think, I did the partitioning, and just before the "write to disk" step.
I may have clicked back to verify ext4 selection.
Comment 7 Andy Lindeberg 2009-06-01 11:17:45 EDT
*** Bug 503435 has been marked as a duplicate of this bug. ***
Comment 8 Bill McGonigle 2009-06-01 12:51:35 EDT
Mine was the bug just duplicated against this one.  RC2 Live CD.

Swap was:
  format enabled on:
  LUKS encrypted volume on:
  RAID 1 on:
  /dev/sda2 (primary) /dev/sdb2 (primary) on:
  Seagate 1TB SATA disks connected to:
  Asus P5Q Pro mobo

I tried so many combinations yesterday this particular anaconda could have been either encrypted or not encrypted, as I attempted the latter when the former failed.  Anaconda's ability to raise a DHCP addr was hit or miss.
Comment 9 Bug Zapper 2009-06-09 11:37:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 David Cantrell 2009-09-09 17:25:17 EDT
Can't reproduce this problem on the latest rawhide tree.

Note You need to log in before you can comment on or make changes to this bug.