Bug 501140 - No image on laptop display with KMS and ATI M22 / Radeon X300
No image on laptop display with KMS and ATI M22 / Radeon X300
Status: CLOSED DUPLICATE of bug 521161
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 513462 F11Target
  Show dependency treegraph
 
Reported: 2009-05-16 19:29 EDT by Mads Kiilerich
Modified: 2009-10-14 06:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 06:58:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages from boot (and reboot) without usable display (45.21 KB, text/plain)
2009-05-16 19:30 EDT, Mads Kiilerich
no flags Details
dmesg - with drm.debug (37.50 KB, text/plain)
2009-06-25 19:25 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2009-05-16 19:29:24 EDT
Description of problem:

Booting Dell Latitude D610 with KMS gives no image on laptop display, just analog fading psycedelic colors.

Without KMS it works OK. (Except for resume after suspend, different story.)

It looks similar to bug 496333 and is on the same machine, but this is with KMS only and thus not X related.


Version-Release number of selected component (if applicable):

kernel-PAE-2.6.29.3-140.fc11.i686
Kernel command line: ro root=/dev/VolGroup00/LogVol00 quiet rhgb drm.debug=1 3

http://www.smolts.org/client/show/pub_39aac23f-48cc-4fae-98a8-70f2aa0fb15e
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon
X300]


In my opinion this is F11 target. Feel free to disagree and remove the tag.
Comment 1 Mads Kiilerich 2009-05-16 19:30:53 EDT
Created attachment 344301 [details]
/var/log/messages from boot (and reboot) without usable display
Comment 2 Bug Zapper 2009-06-09 11:57:59 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Mads Kiilerich 2009-06-25 19:24:56 EDT
Same with kernel-PAE-2.6.29.5-198.fc11.i686

KMS is the default and the future, and the only workaround seems to be to disable it.

This is with a standard machine from a major brand, so I think it deserves some attention.
Comment 4 Mads Kiilerich 2009-06-25 19:25:51 EDT
Created attachment 349487 [details]
dmesg - with drm.debug
Comment 5 Jerome Glisse 2009-10-14 06:38:01 EDT
Can you test with fedora 12 livecd and report if it works with it, if it doesn't work try to get dmesg of the livecd.
Comment 6 Mads Kiilerich 2009-10-14 06:58:38 EDT
I have ugpraded the machine to Fedora 12 - and that is even worse. See bug 521161. I can/will no longer test Fedora 11, so I will just mark this as a duplicate.

Please let me know if there is anything particular you would like to have tested.

*** This bug has been marked as a duplicate of bug 521161 ***

Note You need to log in before you can comment on or make changes to this bug.