Bug 501787 - server side support for KVM client registrations with smbios info
server side support for KVM client registrations with smbios info
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
530
All Linux
high Severity urgent
: ---
: ---
Assigned To: Pradeep Kilambi
Sayli Karmarkar
: FutureFeature
Depends On:
Blocks: 495615 507280
  Show dependency treegraph
 
Reported: 2009-05-20 13:37 EDT by Pradeep Kilambi
Modified: 2009-09-10 14:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:29:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 wes hayutin 2009-06-29 15:08:17 EDT
failing right now.. we need the qemu package

n</params>\n</methodCall>\n", 'version': 2, 'id': 4314}
D: handle_action actionid = 4314, version = 2
D: do_call kickstart_guest.initiate ('grandprix.rhndev.redhat.com', 'sat-blade-6.idm.lab.bos.redhat.com:82:weskvm01', 'qemu', 764, 'weskvm01', 512, 1, 3, 'xenbr0', '/var/lib/xen/weskvm01', ' ksdevice=eth0 ')
- looking for Cobbler at http://grandprix.rhndev.redhat.com/cobbler_api
- reading URL: http://grandprix.rhndev.redhat.com/cblr/svc/op/ks/system/sat-blade-6.idm.lab.bos.redhat.com:82:weskvm01
install_tree: http://grandprix.rhndev.redhat.com/ty/QIErkPSJ
qemu package needs to be installed
D: Sending back response (1, 'Virtual kickstart failed. Koan error.', {'koan': 'qemu package needs to be installed'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
Comment 5 wes hayutin 2009-06-29 15:11:24 EDT
opening a new bug for the above issue.. please disregard..
Comment 7 Sayli Karmarkar 2009-07-03 19:08:42 EDT
Most of the scenarios described in comment#6 are tested. I have created bz# 509602 and bz# 509595. Once they are fixed, I will be able to move it to verified.
Comment 8 Sayli Karmarkar 2009-07-06 16:00:56 EDT
Prad,

Need to move it back to assigned. In the latest iso, I am not able to see kvm guests in virtualization tab after rhn-profile-sync.  

After registering the guest, it is seen in the systems tab but not in host's virtualization tab. If I see in guest system details, I can see it identified correctly as fully virtualized guest. 

I have seen it working in main org in last iso (sat rlx-3-24). Not sure what has changed in the latest one. If you want to try it out you can use (test02-vmx and rlx-2-08 (latest iso)).
Comment 13 Brandon Perkins 2009-09-10 14:29:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.