This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 50225 - installer crashes - perhaps because of USB [ALi lockup]
installer crashes - perhaps because of USB [ALi lockup]
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
: 75122 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-28 13:17 EDT by Alon Rubinstein
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-27 14:00:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Candidate fix (917 bytes, patch)
2002-10-23 17:24 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Alon Rubinstein 2001-07-28 13:17:39 EDT
Description of Problem:
While installing  RedHat 7.1 on a IBM notebook 93G I series, the installer crashes and hangs the 
computer in the " /sbin/installer" stage


How Reproducible:
Always

Steps to Reproduce:
1. insert CD and boot off it
2. chose ANY option in the install ( including ide=nodma)
3. 

Actual Results:
a complete hang with no response to any keys whatsoever forcing a cold reset

Expected Results:


Additional Information:
	
A second before the hang I went to vt3 and vt4 : the hang happenend write after the usb modules 
loading.
Comment 1 Brent Fox 2001-07-28 22:02:43 EDT
Do you have any USB devices that you need to use during the install?
Comment 2 Alon Rubinstein 2001-07-29 15:55:20 EDT
No I do not need to use any USB devices during the install. I will need to set a Serial adapter - but 
that could be a post install procedure. The installer crashed both with the adapter connected and 
disconnected...
Comment 3 Alon Rubinstein 2001-07-30 17:17:13 EDT
RH6.2 installs without any problems...
Comment 4 Matt Wilson 2001-08-02 14:20:55 EDT
try booting with "linux nousb" at the boot: prompt
Comment 5 Brent Fox 2001-08-13 23:10:44 EDT
alon, any more info here?
Comment 6 Alon Rubinstein 2001-08-14 05:54:57 EDT
ok.. installing with the nousb did enable finishing the installation. However
teh hang now happens with normal boot too. I can boot with "linux nousb" and it
does not hang. however I have no usb support. I tried to add the module manually
after the boot has finished and it hangs immediately. I am talking about the
ohci module (usb-ohci). this is also the case after a kernel update to 2.4.7 -
exact same hang.

Alon
Comment 7 Brent Fox 2001-08-14 11:08:05 EDT
Ok.  The problem seems to be with the USB handling, not the installer.  Changing
component.
Comment 8 Pete Zaitcev 2001-08-20 04:01:24 EDT
See also Bug 51063. Symptoms are similar.

Not marking as duplicate just yet because:
1. A different host controller is used.
2. No USB devices are attached to the laptop.
Comment 9 Pete Zaitcev 2001-09-21 19:35:11 EDT
It is established that 51083 is not a dup, which is good.

Requestor, please attach output from lspci -v.I am afraid it may be ALi OHCI
there (phear!).

Comment 10 Alon Rubinstein 2001-09-25 08:55:03 EDT
output of lspci -v is:

00:00.0 Host bridge: Acer Laboratories Inc. [ALi] M1621 (rev 01)
	Flags: bus master, slow devsel, latency 0
	Memory at e0000000 (32-bit, prefetchable) [size=64M]
	Capabilities: [b0] AGP version 1.0
	Capabilities: [a4] Power Management version 1

00:01.0 PCI bridge: Acer Laboratories Inc. [ALi] M5247 (rev 01) (prog-if 00 
[Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	Memory behind bridge: 80500000-818fffff

00:06.0 Multimedia audio controller: Acer Laboratories Inc. [ALi]: Unknown 
device 5451 (rev 01)
	Subsystem: IBM: Unknown device 020f
	Flags: medium devsel, IRQ 11
	I/O ports at 9000 [size=256]
	Memory at 81a00000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: [dc] Power Management version 2

00:07.0 ISA bridge: Acer Laboratories Inc. [ALi] M1533 PCI to ISA Bridge 
[Aladdin IV]
	Flags: bus master, medium devsel, latency 0
	Capabilities: [a0] Power Management version 1

00:10.0 IDE interface: Acer Laboratories Inc. [ALi] M5229 IDE (rev c3) (prog-if 
fa)
	Flags: bus master, medium devsel, latency 32, IRQ 15
	I/O ports at 7050 [size=16]
	Capabilities: [60] Power Management version 2

00:11.0 Bridge: Acer Laboratories Inc. [ALi] M7101 PMU
	Flags: medium devsel

00:13.0 CardBus bridge: O2 Micro, Inc. OZ6812 Cardbus Controller (rev 05)
	Subsystem: IBM: Unknown device 01a3
	Flags: bus master, stepping, slow devsel, latency 168, IRQ 10
	Memory at 10000000 (32-bit, non-prefetchable) [size=4K]
	Bus: primary=00, secondary=02, subordinate=05, sec-latency=176
	Memory window 0: 10400000-107ff000 (prefetchable)
	Memory window 1: 10800000-10bff000
	I/O window 0: 00000000-00000003
	I/O window 1: 00000000-00000003
	16-bit legacy interface ports at 0001

00:14.0 USB Controller: Acer Laboratories Inc. [ALi] M5237 USB (rev 03) (prog-
if 10 [OHCI])
	Flags: bus master, medium devsel, latency 32, IRQ 10
	Memory at 81c00000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: [60] Power Management version 2

01:00.0 VGA compatible controller: Trident Microsystems: Unknown device 8620 
(rev 5d) (prog-if 00 [VGA])
	Subsystem: IBM: Unknown device 0213
	Flags: 66Mhz, medium devsel, IRQ 10
	Memory at 80800000 (32-bit, non-prefetchable) [size=8M]
	Memory at 80500000 (32-bit, non-prefetchable) [size=128K]
	Memory at 81000000 (32-bit, non-prefetchable) [size=8M]
	Expansion ROM at 80520000 [disabled] [size=64K]
	Capabilities: [80] AGP version 1.0
	Capabilities: [90] Power Management version 1



Is that what you feared?

Alon
Comment 11 Pete Zaitcev 2001-09-25 12:24:18 EDT
From: Taral <taral@taral.net>
Newsgroups: linux-kernel
Subject: USB lockup on Thinkpad i1300
Date: Sat, 22 Sep 2001 04:45:27 -0500
To: linux-kernel@vger.kernel.org

My thinkpad happily locks up with both 2.4.9 and 2.4.10-pre14 when I
load usb-ohci. Tracing with kdb shows that the system locks up right
after executing this: (usb-ohci.c:2137)

        /* HC Reset requires max 10 ms delay */
        writel (OHCI_HCR,  &ohci->regs->cmdstatus);

Anyone have any idea? The processor apparently never gets to the next
instruction.

[Cc: me please, I'm not on this list.]

P.S. System chipset is ALi:

00:14.0 USB Controller: Acer Laboratories Inc. [ALi] M5237 USB (rev 03)
(prog-if+10 [OHCI])
        Flags: bus master, medium devsel, latency 32, IRQ 10
        Memory at 82400000 (32-bit, non-prefetchable) [size=4K]

Shares IRQ with cardbus bridge and lcd controller.

--
Taral <taral@taral.net>
Comment 12 Pete Zaitcev 2001-10-02 18:18:50 EDT
Is running self-compiled kernels with patches feasible
on the target machine?
Comment 13 Alon Rubinstein 2001-10-10 16:22:12 EDT
Yes, of course!!

all kernels I run are compiled by me..


Alon
Comment 14 David Rasmussen 2001-10-16 15:34:58 EDT
Has any progress been made with this problem? I have the same problem on an IBM 
Thinkpad i1300.
Comment 15 David Rasmussen 2001-10-16 15:53:25 EDT
I forgot to add: I will help with debugging too, if I can be of any help. I am
running Mandrake 8.1 though.
Comment 16 Robert J Birkett 2002-05-29 13:51:14 EDT
This problem has been around for a long time.  On IBM and Compaq laptops of 
varying types, USB support is not working, most likely because of a bug in the 
USB_OHCI drivers.  I have tried many different settings to resolve this issue 
but to no avail.  The most annoying piece of the puzzle is that all the 
hardware is correctly identified and the system ONLY locks up when loading the 
USB drivers of any type (ohci or other).  There is definitely a driver problem 
here that affects a huge number of machines using this specific chipset.  I'm 
almost at the point of buying a new laptop since this problem is unlikely to be 
resolved anytime soon.  I did manage to get RHL 7.3 installed afer a lot of 
searching since the nousb option does not work during install (oops!) and you 
have to disable pcmcia at startup to avoid consecutive lockups.  The i1300 
series has no serial port so it's USB or PS2 port only.  I wish this could be 
fixed.
Comment 17 Need Real Name 2002-07-22 08:24:09 EDT
I had the same problem on a TP i1200 and this is only workaround I found. On
starting the install, type "linux pci=conf2" or "linux pci=off" as the
bootloader options. This will suppress the lockup on detection of USB devices on
the computers that have the defective USB. If you want to have the full text go to :

http://www.eecs.umich.edu/~chhabra/linuxonTPi1300.html

Hope this helps !
Comment 18 Pete Zaitcev 2002-10-04 13:45:40 EDT
*** Bug 75122 has been marked as a duplicate of this bug. ***
Comment 19 Pete Zaitcev 2002-10-04 13:49:22 EDT
The "nousb" option is fixed in RH8.0, so there's no need for gymnastics
with PCI detection.

This bug is stalled, basically. Someone has to poke IBM and ALi and
get specs and errata, but I really do not have the time.
Comment 20 Pete Zaitcev 2002-10-23 17:24:55 EDT
Created attachment 81784 [details]
Candidate fix
Comment 21 Pete Zaitcev 2002-10-31 20:23:19 EST
CVS HEAD >2.4.19-0.2
Comment 22 Pete Zaitcev 2003-02-27 14:00:05 EST
The -ac has a simplified version.

Note You need to log in before you can comment on or make changes to this bug.