Bug 502310 - Editing partitions without providing a passphrase for previously encrypted partitions fails - IndexError: list index out of range
Editing partitions without providing a passphrase for previously encrypted pa...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:b49eee0d359963993...
: CommonBugs
: 505136 505870 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-23 11:41 EDT by cornel panceac
Modified: 2009-10-01 14:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-01 14:38:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (118.89 KB, text/plain)
2009-05-23 11:42 EDT, cornel panceac
no flags Details
Attached traceback automatically from anaconda. (98.72 KB, text/plain)
2009-06-20 14:08 EDT, Simon
no flags Details

  None (edit)
Description cornel panceac 2009-05-23 11:41:56 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.54 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_dialog_gui.py", line 218, in run
    usedev = self.storage.devicetree.getChildren(request)[0]
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1119, in editPartition
    actions = parteditor.run()
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1080, in editCB
    self.editPartition(device)
IndexError: list index out of range
Comment 1 cornel panceac 2009-05-23 11:42:03 EDT
Created attachment 345199 [details]
Attached traceback automatically from anaconda.
Comment 2 cornel panceac 2009-05-23 11:45:50 EDT
i was trying custom partitioning with all partitions encrypted. (except /boot)

luks partitions were already there, i canceled all attempts to decrypt them.
Comment 3 cornel panceac 2009-05-23 12:26:05 EDT
even if i let it replace existing system install, it still crashes.
Comment 4 cornel panceac 2009-05-23 13:03:36 EDT
even if i let it replace existing system install, it still crashes.
Comment 5 cornel panceac 2009-05-23 13:08:18 EDT
custom partitioning with f11 boot.iso from 22nd of may 2k9 doesn't like custom partitioning even if i started the install with an empty partition table. it enters a dropping master / setting master loop (as i see on c-a-f5).

on c-a-f3 a see a INFO about formatting sda5, wich reminds me of an older bug from previous versions of fedora (10,9,8,...)

however, the installer from the official f11 preview i386 gnome live cd worked on first attempt.
Comment 6 cornel panceac 2009-05-23 13:10:29 EDT
(In reply to comment #5)
> custom partitioning with f11 boot.iso from 22nd of may 2k9 doesn't like custom
> partitioning even if i started the install with an empty partition table. it
> enters a dropping master / setting master loop (as i see on c-a-f5).
> 
> on c-a-f3 a see a INFO about formatting sda5, 

it's actually "create format luks on /dev/sda5"

wich reminds me of an older bug
> from previous versions of fedora (10,9,8,...)
> 
> however, the installer from the official f11 preview i386 gnome live cd worked
> on first attempt.  

worth noting that form previous failed install attempt, the /home partition was not created before installing with the live cd.
Comment 7 cornel panceac 2009-05-23 13:12:48 EDT
_maybe_ f11preview live cd was able to install because of this bug?

https://bugzilla.redhat.com/show_bug.cgi?id=501620

hmm, i was still asked to enter the password for existing luks partitions ....

so maybe there's another reason
Comment 8 cornel panceac 2009-05-23 13:22:17 EDT
also, maybe some info here is related to other bugs, since it was collected during different install attempts.
Comment 9 James Laska 2009-05-26 11:39:05 EDT
Reproduced using the procedure described in comment#2

= Steps to reproduce =
1) Complete an install with encrypted partitions
2) Initiate an install again on this system
3) When prompted for passphrase to unlock existing encrypted volumes, click cancel
4) Select "Custom Partitioning"
5) Select a previous LVM PV and click "Edit"
6) Select 'format' and 'encrypt' and choose 'LVM' as the partition type, click "OK"

This error does *not* occur if you either:
 * Enter the passphrase for the previous LUKS devices in step#3
 * Or, if you remove the LVM PV and create a new LVM PV (instead of editing an existing)
 * Or, if you delete the volume group before editing the LVM PV

This issue does not affect the default installation path and has a reasonable workaround.  I'd like to propose removing this from the F11AnacondaBlocker list with a note on the Common_F11_bugs page detailing the workarounds.
Comment 10 James Laska 2009-05-26 14:50:29 EDT
This defect was discussed during the Fedora 11 Blocker bug review meeting.  THe plan proposed in comment#9 was accepted.  This issue will be documented in the F11 Common Bugs page and removed from the F11AnacondaBLocker list.
Comment 11 James Laska 2009-05-27 10:38:28 EDT
This defect has been added to the Common_F11_Bugs page.  Please note here if the wording or proposed workaround needs any updates. 

https://fedoraproject.org/wiki/Common_F11_bugs#502310

Thanks,
James
Comment 12 Bug Zapper 2009-06-09 12:26:38 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Chris Lumens 2009-06-10 15:27:29 EDT
*** Bug 505136 has been marked as a duplicate of this bug. ***
Comment 14 Simon 2009-06-20 14:08:20 EDT
Created attachment 348749 [details]
Attached traceback automatically from anaconda.
Comment 15 David Lehman 2009-08-14 12:20:39 EDT
*** Bug 505870 has been marked as a duplicate of this bug. ***
Comment 16 David Lehman 2009-08-28 12:02:59 EDT
Fixed in anaconda-12.18-1.
Comment 17 joshua 2009-08-28 13:40:03 EDT
anaconda-12.18-1 will show up where... F12 and RHEL6?

Joshua
Comment 18 David Lehman 2009-08-28 14:02:52 EDT
It will show up in rawhide within the next week, likewise in the F12 beta. Both F12 and RHEL6 will have a later version of anaconda.
Comment 19 joshua 2009-08-28 14:19:19 EDT
as long as it makes it into those releases, I'm happy!
Comment 20 James Laska 2009-10-01 14:38:52 EDT
Retested on anaconda-12.32 (rawhide-20091001) using the procedure noted in comment#9.  No longer seeing this failure.

Moving to -> CLOSED RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.