This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 502698 - kernel errors on snd-emu10k1 supported soundcards (both S/PDIF and analog)
kernel errors on snd-emu10k1 supported soundcards (both S/PDIF and analog)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 504956 505935 (view as bug list)
Depends On:
Blocks: 513462
  Show dependency treegraph
 
Reported: 2009-05-26 20:49 EDT by rookcifer
Modified: 2010-06-02 19:28 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-04 15:02:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description rookcifer 2009-05-26 20:49:54 EDT
Description of problem:

Pulseaudio in F11 breaks Soundblaster Live! soundcards (emu10k1 driver) when using digital output.  I must use digital output on my card because of the speakers I have.

Anyway, when using this card with digital output, there are incessant kerneloopses with the following debug output:

Kernel failure message 1:
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
__ratelimit: 21 callbacks suppressed
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
nepomukservices[2559]: segfault at 7f005f09e32c ip 00007f8a61afa434 sp
00007fff6a0f7080 error 6 in libQtCore.so.4.5.0[7f8a61aa5000+22c000]



Kernel failure message 2:
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
__ratelimit: 21 callbacks suppressed
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000



Kernel failure message 3:
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
__ratelimit: 21 callbacks suppressed
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size =
0x2000, period size = 0x2000  


Version-Release number of selected component (if applicable):

Whatever version of Pulseaudio and ALSA are in F11 Preview.


How reproducible: 

ALWAYS


Steps to Reproduce:

1. If you have a Soundblaster Live! soundcard, enter the F11 preview livecd
2. Or, if you prefer, you can install F11 and get the same results.
3. Kerneloops happens on livecd or on fresh install.  Usually they happen when any sound event is being processed.  And they happen no matter what order I list sound devices.

Actual results:

Kernel failures, every time.

Expected results:

No kernel failures

Additional info:

I am using the KDE version of Fedora 11 (if it makes any difference).

There was already a bug filed about PA defaulting to "digital output" which causes this exact failure with those people using analog speakers and emu10k1. Merely changing the output to analog fixes the problem for them, but it obviously DOES NOT fix the underlying problem for those of us who have to use digital output.

Also, here is my lspci -vv

01:07.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
        Subsystem: Creative Labs SBLive! 5.1 Digital Model SB0220           
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-                                               
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-                                           
        Latency: 32 (500ns min, 5000ns max)                                     
        Interrupt: pin A routed to IRQ 19                                       
        Region 0: I/O ports at 8000 [size=32]                                   
        Capabilities: [dc] Power Management version 1                           
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)                                                 
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-                     
        Kernel driver in use: EMU10K1_Audigy                                    
        Kernel modules: snd-emu10k1                                             

01:07.1 Input device controller: Creative Labs SB Live! Game Port (rev 0a)
        Subsystem: Creative Labs Gameport Joystick                        
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-                                               
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-                                           
        Latency: 32                                                             
        Region 0: I/O ports at 8400 [size=8]                                    
        Capabilities: [dc] Power Management version 1                           
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)                                                 
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-                     
        Kernel driver in use: Emu10k1_gameport                                  
        Kernel modules: emu10k1-gp
Comment 1 Lennart Poettering 2009-05-29 05:42:25 EDT
Kernel oopses are kernel bugs. Reassigning.
Comment 2 Bruce Brackbill 2009-05-30 20:46:19 EDT
This bug is very similar to my bug #502265

Kernel oops and all but a different card:

00:04.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
	Subsystem: Sony Corporation Device 8158
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR+ <PERR+ INTx-
	Latency: 64 (500ns min, 6000ns max)
	Interrupt: pin A routed to IRQ 11
	Region 0: I/O ports at 8800 [size=256]
	Region 1: Memory at c0401000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: [dc] Power Management version 2
		Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2+,D3hot+,D3cold+)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Kernel driver in use: ALI 5451
	Kernel modules: snd-ali5451
Comment 3 Bug Zapper 2009-06-09 12:37:08 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jaroslav Kysela 2009-06-10 09:08:37 EDT
*** Bug 504956 has been marked as a duplicate of this bug. ***
Comment 5 Brian J. Atkisson 2009-06-10 19:58:21 EDT
I have the same problem when just using the analog outputs on a Creative Labs SB Live! EMU10k1:

Jun 10 19:55:30 aleph kernel: ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
Jun 10 19:55:30 aleph kernel: ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
Jun 10 19:55:31 aleph kernel: ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
Jun 10 19:55:31 aleph kernel: ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
Jun 10 19:55:31 aleph kernel: ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000

05:01.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
        Subsystem: Creative Labs Device 8069
        Flags: bus master, medium devsel, latency 64, IRQ 22
        I/O ports at e880 [size=32]
        Capabilities: [dc] Power Management version 1
        Kernel driver in use: EMU10K1_Audigy
        Kernel modules: snd-emu10k1
Comment 6 Adam Williamson 2009-06-10 20:47:12 EDT
That would make this a rather high priority bug, then :\ seems at least two (possibly three) people already are having this problem with analog as well as digital output. Which is very bad.

jaroslav, will you be able to tackle this one as a high priority?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Marc 2009-06-11 04:00:01 EDT
My problems are also with a Soundblaster Live 5.1 soundcard (on an Abit 333 motherboard) (previously reported under duplicate bug 504956 above).  Kerneloops pop-ups keep coming up each time the sound fails at present.

However, I did install F11 on an Intel 875 motherboard as well, which has a built-in soundcard and the sound works fine with this set-up.
Comment 8 Kevin 2009-06-11 19:10:56 EDT
I am having the same problem and I did what the Fedora Common Bugs notes said to do ('Output Analog Stereo + Input Analog Mono') and no sound with my SBlive.


Kernel failure message 1:
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2001, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2001, buffer size = 0x2000, period size = 0x2000
fuse init (API version 7.11)


Kernel failure message 2:
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2001, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2001, buffer size = 0x2000, period size = 0x2000
Comment 9 Adam Williamson 2009-06-11 20:09:55 EDT
i've amended the Common Bugs entry to note that in many cases both analog and digital seem to be broken.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Don Bower 2009-06-12 02:17:45 EDT
I too have no sound with F11 and SB0220 card.
I have modified the PulseAudio to select Stereo Analog output and Mono Analog Input, but even though I can see a VU bar moving in pavcontrol, nothing from the speakers.
I have uploded the alsa-info.sh output to:
http://www.alsa-project.org/db/?f=0a94604e973829a8ee860ba7b9a7381cddea280c
Comment 11 Michael Lausch 2009-06-12 02:57:12 EDT
I have a SB Live! 5.1 soundcard and an onboard soundchip. I hasd the same problem, but after i conficugred pulseaudio to use analog 5.1 output for the SB cards and i muted the emu10k1 "Analog/Digitaml output jack" sound was fine. 
Input was either stereo(music) or AC3 (video via xine and mplayer). Both worked.
Comment 12 Nuno Dias 2009-06-14 17:40:25 EDT
*** Bug 505935 has been marked as a duplicate of this bug. ***
Comment 13 Don Bower 2009-06-14 19:37:45 EDT
After another scratch reload, and modify output via pavucontrol to Analog, i now have sound!
Comment 14 Leo Canale 2009-06-15 18:07:39 EDT
(In reply to comment #11)
> I have a SB Live! 5.1 soundcard and an onboard soundchip. I hasd the same
> problem, but after i conficugred pulseaudio to use analog 5.1 output for the SB
> cards and i muted the emu10k1 "Analog/Digitaml output jack" sound was fine. 
> Input was either stereo(music) or AC3 (video via xine and mplayer). Both
> worked. 
I do not have a AB live! 5.1, Bu I had to choose from pavucontrol.
Any configuration that started "Output Analog Surround xx + Input xxxx Stereo"
 
I have the following:
02:09.0 Multimedia audio controller: Creative Labs [SB Live! Value] EMU10k1X
	Subsystem: Creative Labs Device 1003
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (500ns min, 5000ns max)
	Interrupt: pin A routed to IRQ 18
	Region 0: I/O ports at ec40 [size=32]
	Capabilities: [dc] Power Management version 2
		Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Kernel driver in use: EMU10K1X
	Kernel modules: snd-emu10k1x

02:09.1 Input device controller: Creative Labs [SB Live! Value] Input device controller
	Subsystem: Creative Labs Device 1003
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64
	Region 0: I/O ports at ec68 [size=8]
	Capabilities: [dc] Power Management version 2
		Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Kernel driver in use: Emu10k1_gameport
	Kernel modules: emu10k1-gp
Comment 15 Leo Canale 2009-06-20 18:19:55 EDT
(In reply to comment #14)
> (In reply to comment #11)
> > I have a SB Live! 5.1 soundcard and an onboard soundchip. I hasd the same
> > problem, but after i conficugred pulseaudio to use analog 5.1 output for the SB
> > cards and i muted the emu10k1 "Analog/Digitaml output jack" sound was fine. 
> > Input was either stereo(music) or AC3 (video via xine and mplayer). Both
> > worked. 
> I do not have a AB live! 5.1, Bu I had to choose from pavucontrol.
> Any configuration that started "Output Analog Surround xx + Input xxxx Stereo"
> 
> I have the following:
> 02:09.0 Multimedia audio controller: Creative Labs [SB Live! Value] EMU10k1X
>  Subsystem: Creative Labs Device 1003
>  Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping-
> SERR+ FastB2B- DisINTx-
>  Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort-
> <MAbort- >SERR- <PERR- INTx-
>  Latency: 64 (500ns min, 5000ns max)
>  Interrupt: pin A routed to IRQ 18
>  Region 0: I/O ports at ec40 [size=32]
>  Capabilities: [dc] Power Management version 2
>   Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
>   Status: D0 PME-Enable- DSel=0 DScale=0 PME-
>  Kernel driver in use: EMU10K1X
>  Kernel modules: snd-emu10k1x
> 
> 02:09.1 Input device controller: Creative Labs [SB Live! Value] Input device
> controller
>  Subsystem: Creative Labs Device 1003
>  Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping-
> SERR+ FastB2B- DisINTx-
>  Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort-
> <MAbort- >SERR- <PERR- INTx-
>  Latency: 64
>  Region 0: I/O ports at ec68 [size=8]
>  Capabilities: [dc] Power Management version 2
>   Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
>   Status: D0 PME-Enable- DSel=0 DScale=0 PME-
>  Kernel driver in use: Emu10k1_gameport
>  Kernel modules: emu10k1-gp  

After June 19th update now I cannot get sound to work.
Comment 16 Rick Richardson 2009-06-24 15:54:13 EDT
Ditto for me on a 4 year old Dell, which is my wife's computer!  Worked fine on F10 (and earlier).
Comment 17 Rick Richardson 2009-06-24 16:01:08 EDT
$ pavucontrol 
5271a7c1-528a-5afc-3fc6dc4b-242b0da8 is dumped

No Dice!  Dumps immediately after starting.
Comment 18 jesus 2009-06-25 16:10:26 EDT
Still happening on 2.6.29.5-191.fc11.x86_64 with audigy. No sound at all.
messages:Jun 25 21:32:57 boy kernel: EMU10K1_Audigy 0000:10:09.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
messages:Jun 25 21:32:57 boy kernel: ALSA sound/pci/emu10k1/emufx.c:1546: Installing spdif_bug patch: SB Audigy 2 ZS [SB0350]
Comment 19 Leo Canale 2009-07-16 17:08:43 EDT
I did a fresh install last night and had sound working, until I did an update. There were a couple hundred updates as there should be. Anyways I was playing  music while the update was taking place then sound stopped. Posted is the log around when it stopped. Anything else I could give you to help resolve this?
Jul 15 17:31:20 freshy-desktop avahi-daemon[1197]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.4.110.
Jul 15 17:31:20 freshy-desktop avahi-daemon[1197]: New relevant interface eth0.IPv4 for mDNS.
Jul 15 17:31:20 freshy-desktop avahi-daemon[1197]: Registering new address record for 192.168.4.110 on eth0.IPv4.
Jul 15 17:31:20 freshy-desktop dhclient: bound to 192.168.4.110 -- renewal in 37983 seconds.
Jul 15 17:31:21 freshy-desktop NetworkManager: <info>  (eth0): device state change: 7 -> 8
Jul 15 17:31:21 freshy-desktop NetworkManager: <info>  Policy set 'System eth0' (eth0) as default for routing and DNS.
Jul 15 17:31:21 freshy-desktop NetworkManager: <info>  Activation (eth0) successful, device activated.
Jul 15 17:31:21 freshy-desktop NetworkManager: <info>  Activation (eth0) Stage 5 of 5 (IP Configure Commit) complete.
Jul 15 17:31:21 freshy-desktop ntpd[1452]: Listening on interface #5 eth0, 192.168.4.110#123 Enabled
Jul 15 17:31:23 freshy-desktop avahi-daemon[1197]: Registering new address record for 2002:459e:3280:0:207:e9ff:fecf:c3de on eth0.*.
Jul 15 17:31:23 freshy-desktop avahi-daemon[1197]: Withdrawing address record for fe80::207:e9ff:fecf:c3de on eth0.
Jul 15 17:31:23 freshy-desktop kernel: audit(1247693483.777:25766): auid=4294967295 ses=4294967295 subj=system_u:system_r:readahead_t:s0 op=remove rule key=(null) list=2 res=1
Jul 15 17:31:23 freshy-desktop kernel: audit(1247693483.777:25767): audit_enabled=0 old=1 auid=4294967295 ses=4294967295 subj=system_u:system_r:readahead_t:s0 res=1
Jul 15 17:31:25 freshy-desktop ntpd[1452]: Listening on interface #6 eth0, 2002:459e:3280:0:207:e9ff:fecf:c3de#123 Enabled
Jul 15 17:31:27 freshy-desktop auditd[1773]: Started dispatcher: /sbin/audispd pid: 1775
Jul 15 17:31:27 freshy-desktop audispd: af_unix plugin initialized
Jul 15 17:31:27 freshy-desktop audispd: audispd initialized with q_depth=80 and 2 active plugins
Jul 15 17:31:27 freshy-desktop auditd[1773]: Init complete, auditd 1.7.13 listening for events (startup state enable)
Jul 15 17:31:31 freshy-desktop dbus: Rejected send message, 2 matched rules; type="method_call", sender=":1.31" (uid=42 pid=1810 comm="/usr/bin/pulseaudio --start --log-target=syslog ") interface="org.bluez.Manager" member="ListAdapters" error name="(unset)" requested_reply=0 destination="org.bluez" (uid=0 pid=1409 comm="/usr/sbin/bluetoothd "))
Jul 15 17:31:31 freshy-desktop pulseaudio[1810]: bluetooth-util.c: Error from ListAdapters reply: org.freedesktop.DBus.Error.AccessDenied
Jul 15 17:31:39 freshy-desktop kernel: fuse init (API version 7.11)
Jul 15 17:31:40 freshy-desktop pulseaudio[2085]: pid.c: Daemon already running.
Jul 15 17:31:59 freshy-desktop pulseaudio[2028]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294906060 bytes (7456434 ms).
Jul 15 17:31:59 freshy-desktop pulseaudio[2028]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_emu10k1x'. Please report this issue to the ALSA developers.
Jul 15 17:31:59 freshy-desktop pulseaudio[2028]: alsa-util.c: snd_pcm_dump():
Jul 15 17:31:59 freshy-desktop pulseaudio[2028]: alsa-util.c: Plug PCM: Copy conversion PCM
Jul 15 17:31:59 freshy-desktop pulseaudio[2028]: alsa-util.c: Its setup is:
Jul 15 17:31:59 freshy-desktop pulseaudio[2028]: alsa-util.c:   stream       : PLAYBACK
Jul 15 17:31:59 freshy-desktop pulseaudio[2028]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 15 17:31:59 freshy-desktop pulseaudio[2028]: alsa-util.c:   format       : S16_LE
Jul 15 17:31:59 freshy-desktop pulseaudio[2028]: alsa-util.c:   subformat    : STD
Jul 15 17:31:59 freshy-desktop pulseaudio[2028]: alsa-util.c:   channels     : 6
Jul 15 17:31:59 freshy-desktop pulseaudio[2028]: alsa-util.c:   rate         : 48000
Jul 15 17:31:59 freshy-desktop pulseaudio[2028]: alsa-util.c:   exact rate   : 48000 (48000/1)
etc.....
Comment 20 Claudio Viano 2009-07-31 04:08:48 EDT
I have an old SB audigy player in my desktop PC, with F11 it was playing sound but it skipped to the point of being unusable, even the login sound was played in three chunks with a couple seconds silence in between.

After discovering that atrpms have an updated alsa kernel module (1.0.20 as opposed to 1.0.18a in Fedora), I tried it and things went better, but not completely smooth; I googled further and found advice to add myself to the pulse-rt group and it's perfect now, as in pre-pulse times. Maybe you people want to try that module as well.

Atrpms alsa module also saved my hda-intel laptop, for the record.

Fedora supply alsa 1.0.20 user space packages but a cat /proc/asound/version reveals that the alsa in-kernel driver is actually 1.0.18a.
Comment 21 Adam Williamson 2009-07-31 10:51:01 EDT
Audigy is emu10k2, not emu10k1.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 22 Kevin R. Page 2009-07-31 11:35:03 EDT
(In reply to comment #21)
> Audigy is emu10k2, not emu10k1.

But still uses the snd_emu10k1 module, AFAIK.

http://alsa.opensrc.org/index.php/Emu10k1
Comment 23 Claudio Viano 2009-07-31 12:37:18 EDT
Yes, it uses the emu10k1 module, also commenter #18 has an Audigy. I believe an emu10k2 module doesn't even exist.
Comment 24 Adam Williamson 2009-07-31 13:24:45 EDT
yeah, sorry, I had a morning head at that point. :) still not sure that's the same problem, though. trying a later version of ALSA can't hurt, but if it fixes things, all it tells us is that this was fixed somewhere between ALSA 1.0.18 and 1.0.20, which isn't _terribly_ helpful in itself :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 jesus 2009-09-12 03:15:34 EDT
As of 2.6.29.6-217.2.16.fc11.x86_64 the bug seems to be solved:

EMU10K1_Audigy 0000:10:09.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
ALSA sound/pci/emu10k1/emufx.c:1546: Installing spdif_bug patch: SB Audigy 2 ZS [SB0350]
Comment 26 Adam Williamson 2009-09-14 16:10:20 EDT
is anyone still seeing this with current f11 / rawhide kernels (i.e. 2.6.30 at least)?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 27 Leo Canale 2009-10-01 12:03:23 EDT
(In reply to comment #26)
> is anyone still seeing this with current f11 / rawhide kernels (i.e. 2.6.30 at
> least)?
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers  

Adam
Sorry for the delay. Yes I was still seeing it with the latest updates. I cannot give any more info because F11 was the only time that Fedora was a bit of a pain for me. I have abandon F11 and I am now running F12 alpha. After getting around the initial install issue of the Kernel panic issues mine had to do with vfs not able to load. I had to chroot /mnt/sysimage (in rescue mode) and do an update. I find everything is now  working fine in F12 alfa so far and it is also snappier with my configurations. I will keep my fingers crossed going forward and hope F12 is a better update for me.
Comment 28 Adam Williamson 2009-10-01 15:05:40 EDT
so you don't have this problem in Rawhide?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 29 Leo Canale 2009-10-01 15:44:54 EDT
(In reply to comment #28)
> so you don't have this problem in Rawhide?
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers  

Correct! Not an issue with F12 Rawhide.
Comment 30 Adam Williamson 2009-10-01 16:00:03 EDT
but you were still having issues with F11 after the 2.6.30 update? hum.

can any other reporters confirm whether or not the latest F11 kernels display this bug?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 31 jesus 2009-10-02 03:48:50 EDT
I am using 2.6.30.8-64.fc11.x86_64 and I am not having any issue.
Comment 32 Claudio Viano 2009-10-04 07:05:55 EDT
I'm not having any problem anymore with 2.6.30.
Comment 33 Michael Lausch 2009-10-04 07:28:06 EDT
No problems any more.
Comment 34 Adam Williamson 2009-10-04 15:02:05 EDT
I think we can safely close this, then.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 35 jesus 2010-01-07 16:43:50 EST
I'm having no sound at all from any output (SPDIF or Analog). Currently running 2.6.31.9-174.fc12.x86_64

Alas, no error logged in /var/log/messages.
Could it be Bug 502698 coming back to fc12?
My configuration: 
http://www.alsa-project.org/db/?f=b5b38a404ea562f4f6a74b62f15eccb8f42f029f
Comment 36 jesus 2010-06-02 19:20:59 EDT
(In reply to comment #34)
> I think we can safely close this, then.
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers    

I'm having no sound at all from any output (SPDIF or Analog). Currently running 2.6.33.5-112.fc13.x86_64 installed from scratch.

My configuration:
http://www.alsa-project.org/db/?f=485a33dc882b6d16c568b9e945cb270fb24be067
Comment 37 Adam Williamson 2010-06-02 19:28:09 EDT
Do you have the same error messages? If not, it's a different bug. It probably is anyway, unless everyone else who had problems is suddenly having them again.

Note You need to log in before you can comment on or make changes to this bug.