Bug 50317 - lat2-16 font does not work
lat2-16 font does not work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
: 51303 (view as bug list)
Depends On: 50316
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-30 08:42 EDT by Milan Kerslager
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 04:26:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2001-07-30 08:42:04 EDT
Anaconda fill up lat2-16 console font in /etc/sysconfig/i18n file for 
Czech language but this font does not work (latin2 characters are not 
displayed). Choosing lat2u-16 solves the problem.

How Reproducible:
Use fresh intal and Czech language as default language for system or
set some of cz-* keymap in kbdconfig and then reboot the system and test 
non-latin2 characters (for example press right alt and when right alt is 
still pressed pres keys 1234567890 on normal keyboart [not on numeric 
one], you have to see various alphabetic chars with accents (ie 
+escrzyaie)).

The easiest way to solve this problem is to fill up lat2u-16 font as 
default for every languages with lat2-16 font in Anaconda language & fonts 
table.

I don't know if other maps than lat2-16 works bad too.

You can see to #50316 bugreport too (console-tools package).
Comment 1 Glen Foster 2001-07-30 15:45:59 EDT
This defect is considered SHOULD-FIX for Fairfax
Comment 2 Matt Wilson 2001-08-01 16:58:06 EDT
fixed in CVS, reverting to the sun16 fonts which have linedrawing chars
Comment 3 Milan Kerslager 2001-08-09 04:26:05 EDT
Anaconda still fill lat2-16 font instead of lat2-sun16 (GUI mode tested) so the
font does not work in Beta3.

Also there is bad keyboard map for text console filled by GUI Anaconda ("us"
instead of "cz" or "cz-lat2"). cz-lat2 is previsous used default for our
language for /etc/sysconfig/i18n file
This broke our localization work :-(
Comment 4 Milan Kerslager 2001-08-09 04:26:34 EDT
*** Bug 51303 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2001-08-09 21:11:05 EDT
Just did an install with our current tree and it's exactly as you described it
should be.
Comment 6 Matt Wilson 2001-08-09 21:12:49 EDT
(note I fixed this the day after beta3 went out...)

Note You need to log in before you can comment on or make changes to this bug.