Bug 503773 - lp related kernel warning, warn_slowpath, when adding printer with system-config-printer
lp related kernel warning, warn_slowpath, when adding printer with system-con...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 497753 505721 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 12:08 EDT by erikj
Modified: 2009-06-24 15:23 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.6.29.5-191.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:23:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description erikj 2009-06-02 12:08:29 EDT
Description of problem:

On a fedora11 preview system, with printers never before defined...
If I start system-config-printer and add a printer, a kernel WARNING spews
fourth.  This warning happens right as the system-config-printer 'Select
Device' screen comes up.

I was notified of the warning by a gnome popup window that said
'Your system had a kernel failure'.

Version-Release number of selected component (if applicable):

This is fedora11 preview, but with yum update run a couple times.  Therefore,
it's using newer packages than were on the preview dvd.

Running kernel: 2.6.29.4-167.fc11.x86_64
kernel rpm: kernel-2.6.29.4-167.fc11.x86_64
system-config-printer: system-config-printer-1.1.7-4.fc11.x86_64

/etc/fedora-release:
Fedora release 11 (Leonidas)

How reproducible:
100%
It happens each time I start system-config-printer.  You don't need to
reboot between attempts.

Steps to Reproduce:
1. start system-config-printer
2. click 'New'
3. At this point, the traceback/kernel warning happens.
  
Actual results:

This traceback

Jun  2 11:04:44 hoot dbus-daemon: Rejected send message, 2 matched rules; type="method_call", sender=":1.501" (uid=4 pid=23786 comm="bluetooth ") interface="org.bluez.Manager" member="DefaultAdapter" error name="(unset)" requested_reply=0 destination="org.bluez" (uid=0 pid=1819 comm="/usr/sbin/bluetoothd "))
Jun  2 11:04:45 hoot hp: io/hpmud/pp.c 627: unable to read device-id ret=-1
Jun  2 11:04:45 hoot python: io/hpmud/pp.c 627: unable to read device-id ret=-1
Jun  2 11:04:45 hoot kernel: ------------[ cut here ]------------
Jun  2 11:04:45 hoot kernel: WARNING: at kernel/sysctl.c:2058 unregister_sysctl_table+0xc7/0xfc() (Tainted: G        W )
Jun  2 11:04:45 hoot kernel: Hardware name: OptiPlex 745                 
Jun  2 11:04:45 hoot kernel: Modules linked in: lp nfs lockd nfs_acl auth_rpcgss fuse ipt_MASQUERADE iptable_nat nf_nat bnep sco l2cap bluetooth autofs4 sunrpc bridge stp llc ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath kvm_intel kvm uinput snd_hda_codec_analog snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_timer ppdev snd parport_pc tg3 i2c_i801 soundcore iTCO_wdt parport snd_page_alloc iTCO_vendor_support pcspkr joydev serio_raw dcdbas ata_generic pata_acpi i915 drm i2c_algo_bit i2c_core video output [last unloaded: microcode]
Jun  2 11:04:45 hoot kernel: Pid: 23789, comm: python Tainted: G        W  2.6.29.4-167.fc11.x86_64 #1
Jun  2 11:04:45 hoot kernel: Call Trace:
Jun  2 11:04:45 hoot kernel: [<ffffffff810489bf>] warn_slowpath+0xbc/0xf0
Jun  2 11:04:45 hoot kernel: [<ffffffff8130267a>] ? sock_sendmsg+0xcc/0xe5
Jun  2 11:04:45 hoot kernel: [<ffffffff8105ca4b>] ? autoremove_wake_function+0x0/0x39
Jun  2 11:04:45 hoot kernel: [<ffffffff810e9f94>] ? mntput_no_expire+0x36/0x150
Jun  2 11:04:45 hoot kernel: [<ffffffffa00b43af>] ? parport_release+0xaa/0x164 [parport]
Jun  2 11:04:45 hoot kernel: [<ffffffff8104ffe6>] unregister_sysctl_table+0xc7/0xfc
Jun  2 11:04:45 hoot kernel: [<ffffffff8103a269>] ? __dequeue_entity+0x33/0x38
Jun  2 11:04:45 hoot kernel: [<ffffffffa00b68ad>] parport_device_proc_unregister+0x2d/0x3b [parport]
Jun  2 11:04:45 hoot kernel: [<ffffffffa00b4ad0>] parport_unregister_device+0x14/0x131 [parport]
Jun  2 11:04:45 hoot kernel: [<ffffffffa009d1b1>] pp_release+0x11c/0x14e [ppdev]
Jun  2 11:04:45 hoot kernel: [<ffffffff810d61c4>] __fput+0xf9/0x1a0
Jun  2 11:04:45 hoot kernel: [<ffffffff810d6285>] fput+0x1a/0x1c
Jun  2 11:04:45 hoot kernel: [<ffffffff810d35c5>] filp_close+0x68/0x72
Jun  2 11:04:45 hoot kernel: [<ffffffff810d367b>] sys_close+0xac/0xea
Jun  2 11:04:45 hoot kernel: [<ffffffff8101133a>] system_call_fastpath+0x16/0x1b
Jun  2 11:04:45 hoot kernel: ---[ end trace 40f0281f9ea9607c ]---


Expected results:

Well, not that :)

Additional info:

System is a Dell Optiplex 745

lspci output:

00:00.0 Host bridge: Intel Corporation 82Q963/Q965 Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HB/HR (ICH8/R) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801H (ICH8 Family) 2 port SATA IDE Controller (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5754 Gigabit Ethernet PCI Express (rev 02)
Comment 1 Chuck Ebbert 2009-06-04 01:48:21 EDT
Looks like this is finally fixed upstream, even if the fix is not the best:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff_plain;h=05ad709d04799125ed85dd816fdb558258102172
Comment 2 Chuck Ebbert 2009-06-09 01:03:16 EDT
*** Bug 497753 has been marked as a duplicate of this bug. ***
Comment 3 Bug Zapper 2009-06-09 12:59:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Chuck Ebbert 2009-06-15 19:25:55 EDT
*** Bug 505721 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2009-06-17 07:53:17 EDT
kernel-2.6.29.5-191.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kernel-2.6.29.5-191.fc11
Comment 6 Fedora Update System 2009-06-19 09:43:52 EDT
kernel-2.6.29.5-191.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6768
Comment 7 Fedora Update System 2009-06-24 15:22:26 EDT
kernel-2.6.29.5-191.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.