Bug 503901 - digest-uri omits the serv-name part causing authentication failure when host != serv-name
digest-uri omits the serv-name part causing authentication failure when host ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: loudmouth (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
: 504668 (view as bug list)
Depends On:
Blocks: 494985
  Show dependency treegraph
 
Reported: 2009-06-03 05:50 EDT by Matěj Cepl
Modified: 2009-07-03 15:47 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.4.3-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-14 17:58:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
upstream patch (794 bytes, patch)
2009-06-03 05:52 EDT, Matěj Cepl
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 20158 None None None Never

  None (edit)
Description Matěj Cepl 2009-06-03 05:50:32 EDT
Description of problem:
Just to reflect upstream bug which is present in Fedora.

Version-Release number of selected component (if applicable):
loudmouth-1.4.3-4.fc11.x86_64

How reproducible:
100%

Steps to Reproduce:
1.see upstream bug
2.
3.
Comment 2 Matěj Cepl 2009-06-03 10:20:32 EDT
Except it doesn't work. When patching the tarball (checked against Debian package, the resulting file is the same) I still cannot connect neither to my own Jabber server, nor to jabber.cz.
Comment 3 Matěj Cepl 2009-06-04 10:22:05 EDT
Giving up on this ... it is fully reproducible with our packages, but I have no clue how to fix it.
Comment 4 Matthias Clasen 2009-06-08 14:39:03 EDT
*** Bug 504668 has been marked as a duplicate of this bug. ***
Comment 5 Bug Zapper 2009-06-09 13:01:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Brian Pepple 2009-06-13 17:33:28 EDT
(In reply to comment #2)
> Except it doesn't work. When patching the tarball (checked against Debian
> package, the resulting file is the same) I still cannot connect neither to my
> own Jabber server, nor to jabber.cz.  

Metej, could you try this and see if this fixes the bug? (I don't have access to a jabber server to reproduce this bug myself):

F11 scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=1410609
F12 Build:         http://koji.fedoraproject.org/koji/taskinfo?taskID=1410635
Comment 7 Matěj Cepl 2009-06-14 17:25:00 EDT
(In reply to comment #6)
> Matej, could you try this and see if this fixes the bug? (I don't have access
> to a jabber server to reproduce this bug myself):

Sure will do, but I have to note that jabber.cz (or jabbim.cz, or some other aliases) is a public jabber server, so you could make your own account, if it helped. Of course, you don't have to and I will gladly try it.
Comment 8 Matěj Cepl 2009-06-14 17:58:52 EDT
I had hard time to persuade empathy to change configuration values (I had to restart both empathy and telepathy-* couple of time), but otherwise I can confirm that I can connect (even with secure connection required) with loudmouth-1.4.3-5.fc11.x86_64 to both jabber.cz and ceplovi.cz (even with a secure connection required), so this bug may be closed.

I will probably many many more bug reports now, when I can actually connects to my accounts, but this bug looks OK.

Thanks a lot.
Comment 9 Fedora Update System 2009-06-14 18:21:48 EDT
loudmouth-1.4.3-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/loudmouth-1.4.3-5.fc11
Comment 10 Fedora Update System 2009-07-03 15:47:24 EDT
loudmouth-1.4.3-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.