This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 504034 - [QLOGIC 5.4] Include qlge anaconda strings
[QLOGIC 5.4] Include qlge anaconda strings
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.4
All Linux
high Severity high
: rc
: 5.4
Assigned To: Joel Andres Granados
Release Test Team
: OtherQA
Depends On: 479288
Blocks: 460170 504035
  Show dependency treegraph
 
Reported: 2009-06-03 17:31 EDT by Andrius Benokraitis
Modified: 2015-07-14 00:27 EDT (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 479288
: 504035 (view as bug list)
Environment:
Last Closed: 2009-09-02 05:53:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrius Benokraitis 2009-06-03 17:31:25 EDT
+++ This bug was initially created as a clone of Bug #479288 +++

The new FCoE CNA's ( Converged Network Adapters ) support an ethernet function too which requires it's own driver. This driver, QLGE, is upstream in 2.6.28.

After speaking with Denise, although the qla2xxx strings are in RHEL 5, it's probably safe to add qlge as well in case this is used as a standalone NIC (for some reason).
Comment 1 Andrius Benokraitis 2009-06-03 17:44:45 EDT
Qlogic: do you have anaconda strings for qlge available to be added?
Comment 3 Marcus Barrow 2009-06-04 11:27:31 EDT

Hoe about "QLogic 8xxx Ethernet".
Comment 4 Andrius Benokraitis 2009-06-04 16:35:39 EDT
Marcus - this could have marketing/trademark implications - can you verify with Sameer?
Comment 5 Marcus Barrow 2009-06-04 23:48:24 EDT
OK. It seems to match other QLogic boards and spells our name with the capitol L. I don't see entries for the 8 Gb board, QLA25xx...
Comment 6 Marcus Barrow 2009-06-04 23:49:01 EDT
Or the FCoE part of the 8xxx board....
Comment 7 Andrius Benokraitis 2009-07-09 10:32:55 EDT
Marcus - can you verify if this still needs addressing? Does the Beta have everything needed?
Comment 9 Joel Andres Granados 2009-07-13 08:39:10 EDT
Given that we are so late in the rhel5 cycle, I would like to propose this for rhel5.5
Comment 10 Marcus Barrow 2009-07-13 12:24:26 EDT
This will be important for RHEL installations on blade servers, they will have no other interface available. We believe this is correct, but it needs to be checked for both Ethernet and FC on these boards. I have given a board to the Anaconda group to verify correct operation.

There will be thousands of these blade servers coming on line during the 5.4 time frame, 5.5 will be too late for them.
Comment 11 Andrius Benokraitis 2009-07-13 12:36:36 EDT
I'm going to have to agree with Marcus - the amount of work QLogic and RH have already done getting the kernel pieces in 5.4 should depend on all anaconda and hwdata additions.
Comment 13 Andrius Benokraitis 2009-07-13 14:21:04 EDT
The question I have for the anaconda team is if *not* having the anaconda strings would be an inconvenience (so there is no pretty text in the installer) or if the strings are required in order for driver to function properly. Anyone know this answer? Thanks!
Comment 14 Marcus Barrow 2009-07-13 14:33:44 EDT
We went thru this awile back. What happens is the correct modules will also not be on the boot ISO or disk. So we were forced to release this on our website (QLogic/IBM). Which is nasty.

I will check with the Anaconda folks tomorrow - Tuesday July 14th to see if we can confirm this stuff.
Comment 15 Andrius Benokraitis 2009-07-13 16:14:28 EDT
Marcus - so can you confirm the following is what you need?

module qlge
   QLogic 8xxx Ethernet
Comment 16 Marcus Barrow 2009-07-13 16:44:55 EDT
That text is correct. We also need to make sure that the FC, which is the second PCI function on both ports of the board is also recognized correctly.

And secondly that the qla25xx, our 8 Gb HBA, is also recognized. I think that the PCI id's are somehow matched up with the strings and it all has to be correct...
Comment 17 Joel Andres Granados 2009-07-13 16:47:29 EDT
Anaconda needs the driver name and a small description.  It is necessary to put
in
http://git.fedorahosted.org/git/anaconda.git?p=anaconda.git;a=blob;f=loader2/module-info;h=7e810cda7e33a30cfc7e746bf33a3654bca3c480;hb=refs/heads/rhel5-branch.

The description on comment #15 is what I need.

This will be present in the next version of anaconda (11.1.2.187)
Comment 21 Ameet Paranjape 2009-07-17 09:27:28 EDT
Joel,

Do your Anaconda edits address the concerns brought up in comment #16?  The card needs to be recognized as Ethernet and FC(qla2xxx) and there is separate concern about qla25xx.
Comment 22 Richard A Lary 2009-07-17 10:05:00 EDT
The PCIid's for the FC function and the NIC function on this dual function card are different.  Support for the FC function and it's PCIID's is already in anaconda in RHEL5.4.  I have verified this by performing SAN installation/boots.

Does this response resolve the concerns or there additional information needed?
Comment 23 Ameet Paranjape 2009-07-17 10:30:02 EDT
>Does this response resolve the concerns or there additional information needed?
Yes, it does.  Thanks Richard.
Comment 24 Andrius Benokraitis 2009-07-17 10:49:48 EDT
What Richard said in Comment #22. We had per plan included the FCoE anaconda strings, but neglected to include the ethernet-only anaconda strings if this was going to be performed. Hope this helps!

Richard - so I'm assuming this has been successfully tested (the NIC function)?
Comment 25 Richard A Lary 2009-07-17 11:18:34 EDT
I am not sure if NIC function has been fixed.  Can you tell me if anaconda (11.1.2.187) is in snap3.  If so, I will make sure NIC function is tested here at IBM.
Comment 26 Richard A Lary 2009-07-17 11:34:50 EDT
I have requested this bugzilla be reverse mirrored to IBM LTC bugzilla, I will add our NIC driver developer to that mirror to follow up on status of testing NIC function.
Comment 27 IBM Bug Proxy 2009-07-17 11:51:53 EDT
------- Comment From rlary@us.ibm.com 2009-07-17 11:42 EDT-------
*** Bug 53850 has been marked as a duplicate of this bug. ***
Comment 28 IBM Bug Proxy 2009-07-23 12:30:26 EDT
------- Comment From leitao@linux.vnet.ibm.com 2009-07-23 12:25 EDT-------
I just tested RHEL54 snap3 and the qlge NIC interfaces appears in the anaconda to be used as a interface to install the System.

Closing this bug.
Comment 31 errata-xmlrpc 2009-09-02 05:53:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1306.html

Note You need to log in before you can comment on or make changes to this bug.