Bug 505028 - Anaconda Crashed at Boot Loader Options
Summary: Anaconda Crashed at Boot Loader Options
Keywords:
Status: CLOSED DUPLICATE of bug 504969
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 505809 520308 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-06-10 12:37 UTC by Phil Smith
Modified: 2009-09-16 13:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 13:26:37 UTC
Type: ---


Attachments (Terms of Use)
Anaconda dump for exception (552.33 KB, text/plain)
2009-07-13 12:22 UTC, Phil Smith
no flags Details

Description Phil Smith 2009-06-10 12:37:54 UTC
Description of problem:
Anaconda crash during install of Fedora 11 after changing the "title" from "Fedora" to "Fedora 11"


Version-Release number of selected component (if applicable):


How reproducible:
Once

Steps to Reproduce:
0. start with Fedora 10 on /dev/sda and with /dev/sdb partitioned with Scientific Linux
1. boot from Fedora 11 final install DVD
2. start installation as normal, partitioning and formatting /dev/sdb with an extra /home and mounting 2 old LVs from /dev/sda on /oldroot and /oldhome
3. at "Boot Loader Options menu page" choose to boot from /dev/sda
4. add OS on /dev/sda as a boot option and name it "Fedora 10"
5. click on /dev/sdb "Fedora" (which is the default boot option)
6. edit the new-to-be-installed-Fedora grub title to be "Fedora 11" instead of "Fedora"
7. click to accept the change
8. immediate installer crash (installer suggests reboot)
  
Actual results:
Crash when changing title from "Fedora" to "Fedora 11"

Expected results:
Change title in grub.conf from "Fedora" to "Fedora 11"

Additional info:
I repeated without the partitioning and formatting (done already) of step 2 (but I did choose where to mount each partition the same as before) and without step 6 and it worked.

So it looks like renaming the default install from Fedora to "Fedora 11" (step 6) possibly after adding another OS boot choice or renaming the "title" of that second OS may be the cause.

Didn't seem to be a timing or hardware issue but as a direct result of changing the title.

Comment 1 Andy Lindeberg 2009-06-10 13:58:08 UTC
I tried to reproduce this bug and wasn't able to - could you provide attach the traceback or error message you're getting?

Comment 2 Andy Lindeberg 2009-06-15 14:41:22 UTC
*** Bug 505809 has been marked as a duplicate of this bug. ***

Comment 3 Phil Smith 2009-07-13 12:13:32 UTC
I recreated the problem with a different hard drive on the same system.
Here are more detailed instructions to recreate (most of which probably don't matter) and a dump will follow soon after.

1. Boot from normal Fedora 11 64 bit install DVD
2. 1st option for normal install
3. English
4. UK keyboard
5. Choose to Install
6. localhost... (the default)
7. Choose London or New York as timezone
8. Sys clock uses UTC (default)
9. enter password
10. Replace existing Linux system
11. Choose not to use (format) /dev/sda only /dev/sdb
12. Review and modify partitioning layout
12. Install boot loader on /dev/sda
13. NO boot loader password
14. Click on Fedora and Edit
15. Change from Fedora to Fedora 11
16. Exception
Exception occurred
An unhandled exception has accurred.  This is most likely ...

Comment 4 Phil Smith 2009-07-13 12:22:04 UTC
Created attachment 351468 [details]
Anaconda dump for exception

This is the Anaconda dump of my first successful attempt to recreate the exception.
I'll leave the installation in the debugger Pdb just in case you respond quickly today. Otherwise tell me if I can help you.

Comment 5 Chris Lumens 2009-08-18 19:58:16 UTC
Unfortunately, I am still unable to reproduce following those detailed instructions.

Comment 6 Chris Lumens 2009-08-30 14:26:59 UTC
*** Bug 520308 has been marked as a duplicate of this bug. ***

Comment 7 Chris Lumens 2009-08-30 14:27:45 UTC
Can anyone reproduce this against rawhide or F12 Alpha?

Comment 8 Chris Lumens 2009-09-16 13:26:37 UTC

*** This bug has been marked as a duplicate of bug 504969 ***


Note You need to log in before you can comment on or make changes to this bug.