Bug 505438 - "error opening ATTR{/sys/devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.0/power/level}"
"error opening ATTR{/sys/devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.0/pow...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libfprint (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
: Triaged
: 539808 547618 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 17:52 EDT by Tom London
Modified: 2013-01-10 04:52 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 14:56:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "grep -r 'level' /lib/udev/rules.d /etc/udev/rules.d/" (1.91 KB, text/plain)
2009-06-12 09:28 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2009-06-11 17:52:21 EDT
Description of problem:
See this in /var/log/boot.log:

udevd-event[225]: error opening ATTR{/sys/devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.0/power/level} for writing: No such file or directory

A bit more context:
Welcome to ^[[0;34mFedora^[[0;39m
                Press 'I' to enter interactive startup.
Starting udev: udevd-event[225]: error opening ATTR{/sys/devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.0/power/level} for writing: No such file or directory
^M
^[%G^[[60G[^[[0;32m  OK  ^[[0;39m]^M
Setting hostname tlondon.innopath.com:  ^[[60G[^[[0;32m  OK  ^[[0;39m]^M

[root@tlondon devices]# find . -name level -print
./system/cpu/cpu0/cache/index0/level
./system/cpu/cpu0/cache/index1/level
./system/cpu/cpu0/cache/index2/level
./system/cpu/cpu1/cache/index0/level
./system/cpu/cpu1/cache/index1/level
./system/cpu/cpu1/cache/index2/level
./pci0000:00/0000:00:1a.0/usb3/power/level
./pci0000:00/0000:00:1a.1/usb4/power/level
./pci0000:00/0000:00:1a.1/usb4/4-1/power/level
./pci0000:00/0000:00:1a.2/usb5/power/level
./pci0000:00/0000:00:1a.7/usb1/power/level
./pci0000:00/0000:00:1a.7/usb1/1-5/power/level
./pci0000:00/0000:00:1a.7/usb1/1-5/1-5.4/power/level
./pci0000:00/0000:00:1a.7/usb1/1-5/1-5.4/1-5.4.1/power/level
./pci0000:00/0000:00:1a.7/usb1/1-5/1-5.4/1-5.4.2/power/level
./pci0000:00/0000:00:1a.7/usb1/1-5/1-5.4/1-5.4.4/power/level
./pci0000:00/0000:00:1c.1/0000:03:00.0/net/wlan0/wireless/level
./pci0000:00/0000:00:1d.0/usb6/power/level
./pci0000:00/0000:00:1d.1/usb7/power/level
./pci0000:00/0000:00:1d.2/usb8/power/level
./pci0000:00/0000:00:1d.7/usb2/power/level
./pci0000:00/0000:00:1d.7/usb2/2-6/power/level
[root@tlondon devices]# 

This part of "USB autosuspend"?

Version-Release number of selected component (if applicable):
udev-142-4.fc12.x86_64

How reproducible:
Every boot


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Harald Hoyer 2009-06-12 05:45:26 EDT
what is the output of:

# grep -r 'level' /lib/udev/rules.d /etc/udev/rules.d/
Comment 2 Tom London 2009-06-12 09:28:11 EDT
Created attachment 347566 [details]
output of "grep -r 'level' /lib/udev/rules.d /etc/udev/rules.d/"

[Pasted and attached, in case formatting would ease the examination....]

[root@tlondon ~]# grep -r 'level' /lib/udev/rules.d /etc/udev/rules.d/
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="2016", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="08ff", ATTRS{idProduct}=="5501", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="08ff", ATTRS{idProduct}=="2500", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="08ff", ATTRS{idProduct}=="2580", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="045e", ATTRS{idProduct}=="00bb", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="045e", ATTRS{idProduct}=="00bc", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="045e", ATTRS{idProduct}=="00bd", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="045e", ATTRS{idProduct}=="00ca", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="05ba", ATTRS{idProduct}=="0007", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="05ba", ATTRS{idProduct}=="0008", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="05ba", ATTRS{idProduct}=="000a", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="061a", ATTRS{idProduct}=="0110", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="147e", ATTRS{idProduct}=="2016", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="08ff", ATTRS{idProduct}=="2810", ATTR{power/level}="auto"
[root@tlondon ~]#
Comment 3 Tom London 2009-06-12 09:29:50 EDT
"lspci -n", just in case....

[root@tlondon ~]# lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
00:03.0 Communication controller [0780]: Intel Corporation Mobile 4 Series Chipset MEI Controller [8086:2a44] (rev 07)
00:19.0 Ethernet controller [0200]: Intel Corporation 82567LM Gigabit Network Connection [8086:10f5] (rev 03)
00:1a.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
00:1a.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 [8086:2946] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M-E LPC Interface Controller [8086:2917] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation ICH9M/M-E SATA AHCI Controller [8086:2929] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection [8086:4237]
[root@tlondon ~]#
Comment 4 Harald Hoyer 2009-06-12 09:36:40 EDT
Now the output of 

# rpm -qf /etc/udev/rules.d/60-fprint-autosuspend.rules
Comment 5 Tom London 2009-06-12 09:53:34 EDT
[root@tlondon ~]# rpm -qf /etc/udev/rules.d/60-fprint-autosuspend.rules
libfprint-0.1.0-7.pre1.fc12.x86_64
[root@tlondon ~]#
Comment 6 Harald Hoyer 2009-06-12 10:47:15 EDT
reassigning to package libfprint
Comment 7 Bastien Nocera 2009-06-12 11:19:24 EDT
Matthew, typo?
Comment 8 Matthew Garrett 2009-06-12 20:11:10 EDT
No, the udev rule is running for the interface endpoints as well as the device itself. It's cosmetic but irritating - I'll figure out how to fix up the udev rule.
Comment 9 Matthias Clasen 2009-08-29 13:54:05 EDT
Should this be assigned to Matthew then ?
Comment 10 Matthias Clasen 2009-09-29 00:36:57 EDT
Matthew, any update on this ?
Comment 11 Bug Zapper 2009-11-16 05:04:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Harald Hoyer 2010-01-27 09:55:32 EST
*** Bug 547618 has been marked as a duplicate of this bug. ***
Comment 13 Rafael Levi 2010-02-24 00:00:23 EST
Have the same with F 12 :

rpm -qf /etc/udev/rules.d/60-fprint-autosuspend.rules
libfprint-0.1.0-14.pre2.fc12.i686
Comment 14 Giuseppe Castagna 2010-04-08 08:19:49 EDT
Same here for an X301 with Intel Core 2 Duo SU9600 1.60GHz / 4GB ram / 128GB SSD.

Starting udev: udevd-work[679]: error opening ATTR{/sys/devices/pci0000:00/0000:
00:1a.0/usb3/3-2/3-2:1.0/power/level} for writing: No such file or directory

Please notice that I also owe an X300 with Intel Core 2 Duo, 1.2 GHz, 2Gb ram/ 64 GB SSD also under fedora 12 and the boot time is **considerably faster** than on my X301 (about twice faster). The reason is that the "Welcome to Fedora" message is much delayed on the X301, and the only reason I can imagine it is because of that error message (no other error messages appear in the boot.log). I may be wrong, but if I am not this error is far from being "cosmetic" because it then doubles my boot time.
Comment 15 Giuseppe Castagna 2010-04-08 08:26:01 EDT
A small addition. Apparently the problem comes from the Authentec fingerprint reader that is not supported under linux.

Bus 003 Device 003: ID 08ff:2810 AuthenTec, Inc. 

Is there a way to blacklist it?
Comment 16 Anthony Penniston 2010-04-16 22:39:52 EDT
I do believe it is from the fingerprint scanner. I own a UPEK Fingerprint Scanner and have noticed this exact warning string at the beginning of boot up. Under the same hardware I never noticed this in F10 or F11, it's unpleasant to say the least.
Comment 17 Matthew Garrett 2010-06-30 14:56:13 EDT
Fixed in rawhide, I'll try to backport for 12 and 13.
Comment 18 Bastien Nocera 2010-08-17 10:50:36 EDT
*** Bug 539808 has been marked as a duplicate of this bug. ***
Comment 19 Eddie Lania 2010-10-03 11:30:39 EDT
When will this be backported?
Comment 20 deflexor 2010-11-08 09:34:50 EST
Getting this error on Fedora 14, system not boot. Any suggestion how to fix ?
Comment 21 Bastien Nocera 2010-11-08 09:57:54 EST
(In reply to comment #20)
> Getting this error on Fedora 14, system not boot. Any suggestion how to fix ?

This error has nothing to do with your system not booting.
Comment 22 Istvan Cebrian 2010-11-13 15:06:22 EST
Also getting same error on F14, brightness controls don't seem to work, don't know if it is related.

http://fpaste.org/gW4x/

http://fpaste.org/CgjH/

System fully updated and is a bse system, no extra repositories or packages.
Comment 23 DenisFerraz 2010-11-13 19:55:05 EST
I am Brazilian and I'm using google translator to send the message below:

Good Night All!

When I turn Computator, the boot delay to start after the completion of the countdown of 05 seconds from Grub. Until you get the information Welcome to Fedora, the delay comes to be up to 2-3 minutes and then after, shows the following error message:

Starting udev: udevd-work [474]: error opening ATTR {/ sys/devices/pci0000: 00/0000: 00:02.0 / usb3/3-7/3-7: 1.0/power/level} for writing: No such file or directory

As a result, the system starts normally.
Note: To speed up the startup process, without having to wait for too long, press the button <enter>.
This happened also in the DVD installation (Fedora-14-i386-DVD.iso) earlier in the boot, but the message was not visible at the facility, but at reboot. At CD Live (Fedora-14-i686-Live-KDE.iso) without installing it, the error appears, with a small difference that I highlight below:

Starting udev: udevd-work [608]: error opening ATTR {/ sys/devices/pci0000: 00/0000: 00:02.0 / usb3/3-7/3-7: 1.0/power/level} for writing: No such file or directory

The system installed on my laptop and Fedora 14 Linux 32-bit. Below, some relevant informções about the hardware of my machine:

[Root @ localhost ~] # lspci
00:00.0 RAM memory: nVidia Corporation MCP67 Memory Controller (rev a2)
00:01.0 ISA bridge: nVidia Corporation MCP67 ISA Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP67 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP67 Memory Controller (rev a2)
00:01.3 Co-processor: nVidia Corporation MCP67 Co-processor (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
00:04.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
00:04.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP67 IDE Controller (rev a1)
00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP67 PCI Bridge (rev a2)
00:09.0 IDE interface: nVidia Corporation MCP67 AHCI Controller (rev a2)
00:0 A.0 Ethernet controller: nVidia Corporation MCP67 Ethernet (rev a2)
00:0 c.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
00:0 D.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
00:12.0 VGA compatible controller: nVidia Corporation C67 [GeForce 7150M / nForce 630M] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:05.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
02:05.1 SD Host controller: Ricoh Co Ltd R5C822 SD / SDIO / MMC / MS / MSPro Host Adapter (rev 22)
02:05.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
02:05.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
03:00.0 Network controller: Broadcom Corporation BCM4312 802.11a/b/g (rev 02)
[Root @ localhost ~] #

Stay with God and thank you all.
Comment 24 Korijander Uvek 2011-08-26 18:29:25 EDT
Again, issues:

ThinkPad t410s

Fedora 15

2.6.40.3-0.fc15.x86_64


$  rpm -qf $(fgrep -lr 'power/level' /etc/udev/rules.d)
libfprint-0.3.0-2.fc15.x86_64


[    5.008281] mtp-probe[604]: checking bus 2, device 3: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4"
[    5.039725] mtp-probe[539]: bus: 1, device: 3 was not an MTP device
[    5.042127] udevd-work[451]: error opening ATTR{/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0/power/level} for writing: No such file or directory
[    5.042192] udevd-work[451]: error opening ATTR{/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0/power/level} for writing: No such file or directory
[    5.043215] mtp-probe[604]: bus: 2, device: 3 was not an MTP device

Note You need to log in before you can comment on or make changes to this bug.