Bug 539808 - udevd-work tries to set non-existent power level attribute for fingerprint scanner
udevd-work tries to set non-existent power level attribute for fingerprint sc...
Status: CLOSED DUPLICATE of bug 505438
Product: Fedora
Classification: Fedora
Component: libfprint (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: 551968 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2009-11-21 00:40 EST by Bradley
Modified: 2013-01-10 03:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-08-17 10:50:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bradley 2009-11-21 00:40:35 EST
Description of problem:

On bootup, I get the following message printed to the screen:

Starting udev: udevd-work[404]: error opening ATTR{/sys/devices/pci0000:00/0000:00:1d.1/usb6/6-1:1.0/power/level} for writing: No such file or directory

That device is a fingerprint sensor on my laptop:

Bus 006 Device 002: ID 08ff:2580 AuthenTec, Inc. AES2501 Fingerprint Sensor

The power directory has a 'wakeup' file, but not a 'level' one. There isn't a kernel driver; its all handled in userspace through fprint (although I don't actually use it)

The message isn't logged anywhere; I took a photo with my phone camera to be able to copy it down exactly

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot computer
Actual results:

See error message

Expected results:

Don't see error message

Additional info:

If you know how I /can/ adjust the power level, that'd be good - powertop complains about it, but obviously can't do anything about it.
Comment 1 Bradley 2010-01-03 09:00:32 EST
*** Bug 551968 has been marked as a duplicate of this bug. ***
Comment 2 Harald Hoyer 2010-01-26 06:12:35 EST
/lib/udev/rules.d/65-libsane.rules:ENV{libsane_matched}=="yes", RUN+="/bin/sh -c 'test -e /sys/$env{DEVPATH}/power/level && echo on > /sys/$env{DEVPATH}/power/level'"

$ rpm  -qf /lib/udev/rules.d/65-libsane.rules
Comment 3 Harald Hoyer 2010-01-26 07:52:59 EST
can you please give me the output of:

# grep -r level /{etc,lib}/udev/rules.d
Comment 4 Bradley 2010-01-26 08:03:58 EST
[root@plum ~]# grep -r level /{etc,lib}/udev/rules.d
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="08ff", ATTRS{idProduct}=="5501", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="08ff", ATTRS{idProduct}=="2500", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="08ff", ATTRS{idProduct}=="2580", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="045e", ATTRS{idProduct}=="00bb", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="045e", ATTRS{idProduct}=="00bc", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="045e", ATTRS{idProduct}=="00bd", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="045e", ATTRS{idProduct}=="00ca", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="05ba", ATTRS{idProduct}=="0007", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="05ba", ATTRS{idProduct}=="0008", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="05ba", ATTRS{idProduct}=="000a", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="061a", ATTRS{idProduct}=="0110", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="147e", ATTRS{idProduct}=="2016", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="08ff", ATTRS{idProduct}=="1600", ATTR{power/level}="auto"
/etc/udev/rules.d/60-fprint-autosuspend.rules:SUBSYSTEM=="usb", ATTRS{idVendor}=="08ff", ATTRS{idProduct}=="2810", ATTR{power/level}="auto"
/lib/udev/rules.d/70-printers.rules:# Low-level USB device add trigger
/lib/udev/rules.d/70-printers.rules:# Low-level USB device remove trigger
/lib/udev/rules.d/65-libsane.rules:ENV{libsane_matched}=="yes", RUN+="/bin/sh -c 'test -e /sys/$env{DEVPATH}/power/level && echo on > /sys/$env{DEVPATH}/power/level'"
/lib/udev/rules.d/70-acl.rules:# HPLIP devices (necessary for ink level check and HP tool maintenance)
Comment 5 Harald Hoyer 2010-01-26 09:04:34 EST
$ rpm -qf /etc/udev/rules.d/60-fprint-autosuspend.rules

Comment 6 Bastien Nocera 2010-01-26 09:51:34 EST
That's Matthew's work.
Comment 7 Bastien Nocera 2010-08-17 10:50:36 EDT
Matthew fixed this already.

*** This bug has been marked as a duplicate of bug 505438 ***

Note You need to log in before you can comment on or make changes to this bug.