This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 507310 - No Zend_tool (zf.sh) for fedora 10
No Zend_tool (zf.sh) for fedora 10
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-ZendFramework (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Kahl
Fedora Extras Quality Assurance
:
: 467599 507516 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 05:50 EDT by Mario Santagiuliana
Modified: 2009-08-04 20:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.8.4-2.PL1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-04 20:36:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Santagiuliana 2009-06-22 05:50:02 EDT
Description of problem:
There is not Zend_tools in php-ZendFramework package for fedora 10

Version-Release number of selected component (if applicable):
php-ZendFramework-1.7.7-2.fc10.noarch

How reproducible:
Install or update ZendFramework to the last stable relase from updates repository.

 
Actual results:
There is no zend tools like zf.sh

Expected results:
Expected to find zh.sh like on fedora 11.
Or previous version:
# yum provides *zf.sh
Plugin caricati:dellsysidplugin, dellsysidplugin2
php-ZendFramework-1.6.0-1.fc10.noarch : Leading open-source PHP framework
Repo        : fedora
Corrispondenza trovata in:
Filename    : /usr/share/php/ZendL/zf.sh
Comment 1 Mario Santagiuliana 2009-06-22 19:27:31 EDT
I try to install php-ZendFramework-1.6.0-1.fc10.noarch package but I obtain this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=467599

Same thing with php-ZendFramework-1.7.7-2.fc11.noarch.rpm after enabled rawhide repo but I obtain this error:

$ zf create project test
Could not open input file: ../share/php/Zend/zf.php
Comment 2 Alexander Kahl 2009-06-29 04:36:15 EDT
I can confirm this bug and will look into it.
Comment 3 Alexander Kahl 2009-06-29 04:37:27 EDT
*** Bug 507516 has been marked as a duplicate of this bug. ***
Comment 4 Renich Bon Ciric 2009-06-29 16:26:01 EDT
I could fix this. The problem lies in the use of symlinks!
Comment 5 Alexander Kahl 2009-06-30 04:00:11 EDT
Bon: I know that. See ChangeLog:
* Sat Sep 13 2008 Alexander Kahl <akahl@iconmobile.com> - 1.6.0-1
[...]
- BuildRequire symlinks to sanitize zf -> zf.sh symlink

The real problem lies in the fact zf.sh is too dumb to read relative symlinks but rpmlint warns about absolute ones. The package guidelines (just looked up) however seem to have been updated saying both are allowed now, great.

Bon, are you interested in co-maintainership? We've missed some versions anyway and this package is big and important enough to earn more passion and helping hands I've been able to provide lately.
Comment 6 Renich Bon Ciric 2009-06-30 14:04:26 EDT
Yeah sure! I'd love to maintain ZendFramework with you... as soon as I learn how. How about if we switch to emails?
Comment 7 Fedora Update System 2009-07-17 07:39:41 EDT
php-ZendFramework-1.8.4-1.PL1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/php-ZendFramework-1.8.4-1.PL1.fc11
Comment 8 Fedora Update System 2009-07-17 07:54:40 EDT
php-ZendFramework-1.8.4-1.PL1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/php-ZendFramework-1.8.4-1.PL1.fc10
Comment 9 Fedora Update System 2009-07-22 17:43:36 EDT
php-ZendFramework-1.8.4-2.PL1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-ZendFramework'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7816
Comment 10 Alexander Kahl 2009-07-27 02:57:39 EDT
*** Bug 467599 has been marked as a duplicate of this bug. ***
Comment 11 Alexander Kahl 2009-07-27 03:00:50 EDT
Ping. Need your karma in Bodhi.
Comment 12 Mario Santagiuliana 2009-08-01 06:05:23 EDT
With the new package in updates-testing repo for fedora 10, Zend_tool work fine.
Comment 13 Alexander Kahl 2009-08-03 03:00:46 EDT
Renich? You karma is also welcome ;)
Comment 14 Renich Bon Ciric 2009-08-03 14:33:47 EDT
;=) You alrady got it, my friend!
Comment 15 Fedora Update System 2009-08-04 20:29:56 EDT
php-ZendFramework-1.8.4-2.PL1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2009-08-04 20:36:46 EDT
php-ZendFramework-1.8.4-2.PL1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.