Bug 50741 - mailman & postfix rpms don't mix
Summary: mailman & postfix rpms don't mix
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: mailman   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
: 62356 (view as bug list)
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2001-08-02 19:08 UTC by Need Real Name
Modified: 2014-01-21 22:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-01 03:18:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-08-02 19:08:29 UTC
Description of Problem:

mailman doesn't like postfix, because postfix doesn't use
the gid 12 (mail), it seems postfix use 99 (nobody) as gid

every time a mail is sended to mailman it produces the following 
message:
This is the Postfix program at host safari.ksb-arg.com.

I'm sorry to have to inform you 
[snip]
The Postfix program

<emailarchives@ksb-arg.com>: Command died with status 2:
    "/var/mailman/mail/wrapper post emailarchives". Command output: 
Failure to
    exec script. WANTED gid 12, GOT gid 99.  (Reconfigure to take 99?)


the correct fix is to make postfix run as gid mail ?


How Reproducible:

100%

Steps to Reproduce:
1. install the postfix rpm (setup it)
2. install the mailman rpm (setup it & create a list)
3. mail to the list

Actual Results:

bounced message:
<emailarchives@ksb-arg.com>: Command died with status 2:
    "/var/mailman/mail/wrapper post emailarchives". Command output: 
Failure to
    exec script. WANTED gid 12, GOT gid 99.  (Reconfigure to take 99?)


Expected Results:

message go trough...


Additional Information:
	
none I can think off...

Comment 1 Jeff Johnson 2001-12-09 17:51:19 UTC
*** Bug 50887 has been marked as a duplicate of this bug. ***

Comment 2 Nalin Dahyabhai 2002-04-05 22:43:05 UTC
*** Bug 62356 has been marked as a duplicate of this bug. ***

Comment 3 Nalin Dahyabhai 2002-04-10 16:49:53 UTC
Please check if mailman-2.0.9-1 (coming to Raw Hide soonish) fixes this problem.

Comment 4 Seth Vidal 2002-04-11 05:04:22 UTC
That looks like a good fix for that problem

I can test it on a box shortly.

However, I would encourage getting that patch put in upstream.
I'm sure there are others who would find it terribly useful.




Comment 5 Chris Ricker 2002-08-30 13:02:01 UTC
Closing this -- it works for me now


Note You need to log in before you can comment on or make changes to this bug.