Bug 510710 - Exception while checking package dependencies on install
Exception while checking package dependencies on install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:8e05b462f537cca40...
:
: 524084 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 07:42 EDT by Gregory Van Vooren
Modified: 2009-11-10 09:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 09:48:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (182.72 KB, text/plain)
2009-07-10 07:42 EDT, Gregory Van Vooren
no flags Details

  None (edit)
Description Gregory Van Vooren 2009-07-10 07:42:18 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/misc.py", line 607, in bunzipFile
    s_fn = bz2.BZ2File(source, 'r')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 174, in populate
    misc.bunzipFile(db_fn, db_un_fn)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 559, in searchFiles
    self.populate(repo, mdtype='filelists')
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 44, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 858, in _search
    for pkg in self.searchFiles(name, strict=True):
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 44, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 882, in getProvides
    return self._search("provides", name, flags, version)
  File "/usr/lib/python2.6/site-packages/yum/packageSack.py", line 497, in _computeAggregateDictResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.6/site-packages/yum/packageSack.py", line 327, in getProvides
    return self._computeAggregateDictResult("getProvides", name, flags, version)
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 424, in getNewProvides
    for pkg, hits in self.pkgSack.getProvides(name, flag, version).iteritems():
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 442, in getProvides
    result.update(self.getNewProvides(name, flag, version))
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 856, in _checkInstall
    provs = self.tsInfo.getProvides(*req)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 784, in _resolveRequires
    thisneeds = self._checkInstall(txmbr)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 699, in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 717, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/anaconda/yuminstall.py", line 1311, in doPostSelection
    (code, msgs) = self.ayum.buildTransaction()
  File "/usr/lib/anaconda/backend.py", line 279, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
IOError: [Errno 2] No such file or directory: '/mnt/sysimage/var/cache/yum/anaconda-InstallationRepo-200906021801.i386/1a4ff989da85c4924d96e3b3c8d7a2ba9a6a74670e2671679ebad5566b2ca4cc-filelists.sqlite.bz2'
Comment 1 Gregory Van Vooren 2009-07-10 07:42:29 EDT
Created attachment 351248 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-07-17 15:55:10 EDT
Is this issue reproducable?
Comment 3 Gregory Van Vooren 2009-07-17 16:17:42 EDT
I ran the installer several times (3 if I recall correctly) and it occurred every single time
Comment 4 Joel Andres Granados 2009-09-03 09:03:02 EDT
I saw this in your log:
"""
ERROR: This software has detected that the disk has at least 1 bad sector.
****************************************************************************
* WARNING: The disk has bad sector. This means physical damage on the disk *
* surface caused by deterioration, manufacturing faults or other reason.   *
* The reliability of the disk may stay stable or degrade fast. We suggest  *
* making a full backup urgently by running 'ntfsclone --rescue ...' then   *
* run 'chkdsk /f /r' on Windows and rebooot it TWICE! Then you can resize  *
* NTFS safely by additionally using the --bad-sectors option of ntfsresize.*
****************************************************************************
"""

No sure if its relevant to your issue.  But given that you are the only person that sees this bug, could you test with another HD and see if you can successfully install?
Comment 5 Chris Lumens 2009-09-17 15:49:33 EDT
*** Bug 524084 has been marked as a duplicate of this bug. ***
Comment 6 Gregory Van Vooren 2009-09-18 10:32:27 EDT
Unfortunately I don't have another HD available. The installation was attempted on an old computer no longer worth investing hardware in.
Thanks for having looked into it.

Note You need to log in before you can comment on or make changes to this bug.