Bug 510898 - Mirrors don't have all the packages/out of sync despite being returned by mirrormanager
Mirrors don't have all the packages/out of sync despite being returned by mir...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
: 510959 510963 510986 510992 512018 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-12 04:48 EDT by Johannes Goller
Modified: 2014-01-21 18:10 EST (History)
28 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-13 10:04:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johannes Goller 2009-07-12 04:48:53 EDT
Description of problem:
When running

yum install gdb

on an almost fresh F11, the following kind of error message is displayed for every available mirror:

Error Downloading Packages:
  gdb-6.8.50.20090302-33.fc11.i586: failure: gdb-6.8.50.20090302-33.fc11.i586.rpm from updates: (256, 'No more mirrors to try.')

And indeed, it turns out that only
gdb-6.8.50.20090302-32  (note the final digit)

is available on the repository.

Similar problems occur with many (perhaps all) other "updates" packages.

Version-Release number of selected component (if applicable):
"uname -a" returns
Linux localhost.localdomain 2.6.29.5-191.fc11.i586 #1 SMP Tue Jun 16 23:11:39 EDT 2009 i686 i686 i386 GNU/Linux

The yum version is 3.2.23

How reproducible:
I believe it should be reproducible immediately on any installation of F11 by trying to install "gdb".

Actual results:
The error message above is is displayed and no package is installed.

Expected results:
The "gdb" package should be installed.
Comment 1 Steve Bryant 2009-07-12 06:14:33 EDT
When I tried to update my F11 system, the first six updates (alphabetically) could not be found or were truncated - 

# ls -l /var/cache/yum/updates/packages/
total 344
-rw-r--r--. 1 root root   9606 2009-07-12 10:41 alsa-plugins-pulseaudio-1.0.20-2.fc11.i586.rpm
-rw-r--r--. 1 root root   9606 2009-07-12 10:42 dhclient-4.1.0-22.fc11.i586.rpm
-rw-r--r--. 1 root root   9606 2009-07-12 10:43 farsight2-0.0.12-1.fc11.i586.rpm
-rw-r--r--. 1 root root   9606 2009-07-12 10:45 gdb-6.8.50.20090302-33.fc11.i586.rpm
-rw-r--r--. 1 root root   9606 2009-07-12 10:46 grubby-6.0.87-1.fc11.i586.rpm
-rw-r--r--. 1 root root   9606 2009-07-12 10:47 gstreamer-plugins-good-0.10.15-3.fc11.i586.rpm
( . . . )
Comment 2 Jack Perdue 2009-07-12 14:56:36 EDT
FWIW/FYI,

Using the info from this post:

 http://forums.fedoraforum.org/showpost.php?p=1240617&postcount=57

I was able to do a partial upgrade just now with:

 sudo yum --exclude=[a-h]\* update --skip-broken
Comment 3 Johannes Goller 2009-07-12 20:58:25 EDT
From the above, as well as some further attempts to install other modules, it seems that the correct versions of at least the following modules are missing from the updates repository:

alsa-plugins-pulseaudio-1.0.20-2.fc11.i586.rpm
dhclient-4.1.0-22.fc11.i586.rpm
elfutils-libs-0.141-1.fc11.i586
farsight2-0.0.12-1.fc11.i586.rpm
gdb-6.8.50.20090302-33.fc11.i586.rpm
grubby-6.0.87-1.fc11.i586.rpm
gstreamer-plugins-good-0.10.15-3.fc11.i586.rpm
hugs98-2006.09-6.fc11.i586.rpm
rpm-build-4.7.0-2.fc11.i586
Comment 4 Matt Hirsch 2009-07-12 22:03:30 EDT
Error Downloading Packages:
  grubby-6.0.87-1.fc11.i586: failure: grubby-6.0.87-1.fc11.i586.rpm from updates: [Errno 256] No more mirrors to try.
  12:dhcp-4.1.0-22.fc11.i586: failure: dhcp-4.1.0-22.fc11.i586.rpm from updates: [Errno 256] No more mirrors to try.
  farsight2-0.0.12-1.fc11.i586: failure: farsight2-0.0.12-1.fc11.i586.rpm from updates: [Errno 256] No more mirrors to try.
  12:dhclient-4.1.0-22.fc11.i586: failure: dhclient-4.1.0-22.fc11.i586.rpm from updates: [Errno 256] No more mirrors to try.
  alsa-plugins-pulseaudio-1.0.20-2.fc11.i586: failure: alsa-plugins-pulseaudio-1.0.20-2.fc11.i586.rpm from updates: [Errno 256] No more mirrors to try.
  gstreamer-plugins-good-0.10.15-3.fc11.i586: failure: gstreamer-plugins-good-0.10.15-3.fc11.i586.rpm from updates: [Errno 256] No more mirrors to try.
  gdb-6.8.50.20090302-33.fc11.i586: failure: gdb-6.8.50.20090302-33.fc11.i586.rpm from updates: [Errno 256] No more mirrors to try.

The versions I'm having problems with can all be found in updates-testing, not updates.
Comment 5 Johannes Goller 2009-07-13 06:55:27 EDT
gdb and alsa-plugins-pulseaudio as well as all packages that were needed when I ran "yum update" on my installation seem to be available now and yum performs the installation/update as expected.

As far as I am concerned the problem has been solved.
Comment 6 seth vidal 2009-07-13 10:04:12 EDT
This appears to be caused by a problem in our mirror manager infrastructure this weekend. It had lost its geolocation database and was giving out incorrect responses.
Comment 7 seth vidal 2009-07-13 10:04:20 EDT
*** Bug 510959 has been marked as a duplicate of this bug. ***
Comment 8 seth vidal 2009-07-13 10:05:26 EDT
*** Bug 510986 has been marked as a duplicate of this bug. ***
Comment 9 seth vidal 2009-07-13 10:26:13 EDT
*** Bug 510992 has been marked as a duplicate of this bug. ***
Comment 10 Dennis Schafroth 2009-07-13 11:29:29 EDT
I am stil seeing this issue. What to do? Wait for mirrors to get back in sync? Use a specific one? clean yum cache (already tried)?
Comment 11 seth vidal 2009-07-13 11:33:14 EDT
*** Bug 510963 has been marked as a duplicate of this bug. ***
Comment 12 seth vidal 2009-07-13 11:43:37 EDT
In answer to comment #10 - just wait - the mirror/infrastructure team is trying to sort out what went wrong.
Comment 13 Dennis Schafroth 2009-07-13 11:57:38 EDT
Thx. I got all updates downloaded now, even though some mirrors reported 404 on alsa-plugins-pulseaudio.
Comment 14 Bruce Brackbill 2009-07-13 15:23:55 EDT
This is closed?

Still fails for me:
---> Package alsa-plugins-jack.i586 0:1.0.20-2.fc11 set to be updated
---> Package alsa-plugins-pulseaudio.i586 0:1.0.20-2.fc11 set to be updated
---> Package gdb.i586 0:6.8.50.20090302-33.fc11 set to be updated
<snip>
Trying other mirror.
Some  Mirror [mErrno 14] HTTP Error 404: Not Found
Trying other mirror.
Another Mirror [mErrno 14] HTTP Error 404: Not Found
<snip>

Also, I "manually" looked for these packages at http://mirrors.fedoraproject.org/publiclist/Fedora/11/ and could not find any mirrors that have them.

Do these packages actually exist on a mirror somewhere? If so, maybe someone could post a link.
Comment 15 seth vidal 2009-07-13 15:29:07 EDT
It's closed as a yum bug - It's still ongoing as a mirror issue.
Comment 16 Matt Hirsch 2009-07-13 15:29:57 EDT
Check the testing repos for those files.
Comment 17 Rahul Sundaram 2009-07-13 19:48:58 EDT
Just as a clarification, this is NOT a yum issue. It is a infrastructure problem that the team is working on. More details at

https://www.redhat.com/archives/fedora-announce-list/2009-July/msg00006.html

Everyone be patient.
Comment 18 Alexei Podtelezhnikov 2009-07-13 23:03:52 EDT
This is high time to reconsider wasteful policy of carrying on with two active streams of updates. If people want to see 250 Mb of KDE 4.3 in the near future, they should move their butts to Fedora 11 instead of suckling on Fedora 10.

This is not user's fault actually, but some developers just waste Redhat's bandwidth and do busy work updating older distros. I mean I don't mind security updates, which are far and few in between (historically 5-7%), but KDE 4.3.0...1...2...3...4... there goes 2 Gb in one release cycle. You can get Fedora 11 in the first place for less money. Sorry KDE, but same goes for openoffice.org and many other not so security critical apps. 

Freeze Fedora 10 Already!!!!!!
Packagers should try to start developing in the freed time.

I would even block bug reports against old stuff.
Comment 19 Ian Laurie 2009-07-15 22:11:56 EDT
A 6 month support cycle would render fedora non-viable for a great many users, including me. The extended support cycle widens fedora's relevance within the user base.  I migrate systems as soon as I can, but I am still running 10 on a number of systems and will continue to do so for several months.  Nothing I can do about it.  I would NOT be able to use fedora at all if the support period were just 6 months, and I know a lot of people are in the same boat.
Comment 20 James Antill 2009-07-16 00:22:37 EDT
*** Bug 512018 has been marked as a duplicate of this bug. ***
Comment 21 Alexei Podtelezhnikov 2009-07-17 00:55:15 EDT
I did not suggest to drop Fedora 10 on the floor and step over it.
Exploitable security issues should be fixed for as long as possible.
Like I said, this only accounts for 5-7% of updates.

It sound like you want new features and minor fixes delivered to you.
Current Fedora would do it for you too. RHEL would do it for
you for a few years.

Old Fedora feels the niche of lazy and cheap users. The value they
provide back to Red Hat is almost zero, but they cost same money.   

The worst part actually comes at release +/- 1-month, when 4 (FOUR!) simultaneous builds of the same package occur! That's is a stress.

FYI, the infrastructure issue is not sorted out yet, almost one week later.
Comment 22 Ricky Zhou 2009-07-20 10:40:36 EDT
Sorry, I thought this link was posted here, but apparently not.

The issue is currently being tracked in the Infrastructure trac at https://fedorahosted.org/fedora-infrastructure/ticket/1531 - that's where all the latest updates are.
Comment 23 Nivag 2009-07-22 21:15:44 EDT
Alexei 'we' are losing people to Ubuntu - because people are pressured to upgrade Fedora too often.  I got an email from a friend about a Linux installfest locally (Wellington, New Zealand), and Fedora is off the menu for newbies because it does not have a long germ stable version.  Also since I am working from home now, and have a minimalist budget, I may have to switch myself.
Comment 24 Mike McGrath 2009-07-22 22:03:18 EDT
People that go from Fedora -> Ubuntu and not from Fedora -> RHEL/CentOS aren't leaving because of the upgrade cycle.

Note You need to log in before you can comment on or make changes to this bug.