Bug 512034 - mnemonic mishap
mnemonic mishap
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
: EasyFix, Patch, Reopened
: 515500 516141 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-15 20:46 EDT by Matthias Clasen
Modified: 2009-08-08 15:28 EDT (History)
6 users (show)

See Also:
Fixed In Version: 2.8.6-11.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-08 15:28:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (580 bytes, patch)
2009-07-15 20:46 EDT, Matthias Clasen
no flags Details | Diff
Patch using gtk_button_set_use_underline (574 bytes, patch)
2009-07-18 07:42 EDT, Edward Sheldrake
no flags Details | Diff

  None (edit)
Description Matthias Clasen 2009-07-15 20:46:42 EDT
Created attachment 353926 [details]
patch

Xchats network dialog has a C_onnect button. This happens new because we fixed a bug in GTK+ where it whould apply mnemonics even though it was not supposed to.

The attached patch should fix this (untested)
Comment 1 Kevin Kofler 2009-07-16 15:07:36 EDT
OK, I'm applying this trivial fix in Fedora, but this needs to be fixed upstream too. CCing upstream.
Comment 2 Kevin Kofler 2009-07-16 18:23:22 EDT
Should be fixed in 2.8.6-9.fc12 which is now building.
Comment 3 Edward Sheldrake 2009-07-18 07:42:30 EDT
Created attachment 354251 [details]
Patch using gtk_button_set_use_underline

I was seeing this issue on Fedora 11 with the latest testing gtk2 (2.16.4, 2.16.5), rebuilding 2.8.6-9.fc12 on Fedora 11 did not fix it, it just gives:

(xchat:27688): Gtk-CRITICAL **: gtk_label_set_use_underline: assertion `GTK_IS_LABEL (label)' failed

A working patch uses gtk_button_set_use_underline instead.
Comment 4 Kevin Kofler 2009-07-18 16:16:26 EDT
Thanks for the fixed patch, should be fixed in 2.8.6-10.fc12 which is now building.

(<rant>This bug (the incorrect patch) would not have happened if an actual object-oriented language like C++ had been used instead of abusing C for OOP. Neither Qt nor GTK-- allow this class of bugs to happen.</rant>)
Comment 5 Matthias Clasen 2009-07-18 16:19:25 EDT
Sorry about that. The corrected patch is obviously correct.
Comment 6 Kevin Kofler 2009-07-18 17:12:43 EDT
Build completed, should be fixed for good now, please reopen if the problem persists.
Comment 7 Kevin Kofler 2009-08-04 11:06:43 EDT
*** Bug 515500 has been marked as a duplicate of this bug. ***
Comment 8 Kevin Kofler 2009-08-07 08:37:02 EDT
Reopening, needs fixing in F11 too.
Comment 9 Kevin Kofler 2009-08-07 08:38:47 EDT
*** Bug 516141 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2009-08-07 09:05:23 EDT
xchat-2.8.6-11.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xchat-2.8.6-11.fc11
Comment 11 Fedora Update System 2009-08-08 15:28:23 EDT
xchat-2.8.6-11.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.