Bug 513016 - bind-libs yum update problem at cleanup stage
bind-libs yum update problem at cleanup stage
Status: CLOSED DUPLICATE of bug 520385
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-07-21 12:50 EDT by Nicolas Mailhot
Modified: 2013-04-30 19:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-29 10:23:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-07-21 12:50:02 EDT
Description of problem

bind-libs yum update problem at cleanup stage

  Nettoyage      : 32:bind-libs-9.6.1-3.fc12.x86_64                                                                                                             39/44 
/sbin/ldconfig: chemin relatif `1' utilisé pour construire le cache
Non-fatal POSTUN scriptlet failure in rpm package b
Comment 1 Valdis Kletnieks 2009-07-23 18:35:04 EDT
Seeing it here too, in English:

  Cleanup        : 32:bind-libs-9.6.1-3.fc12.x86_64                                                                                                 31/34 
/sbin/ldconfig: relative path `1' used to build cache
Non-fatal POSTUN scriptlet failure in rpm package b
warning: %postun(bind-libs-32:9.6.1-3.fc12.x86_64) scriptlet failed, exit status 1

Possibly due to this:

%  rpm -q --scripts bind-libs
postinstall program: /sbin/ldconfig
postuninstall scriptlet (using /sbin/ldconfig):

# bind-libs between 32:9.6.1-0.1.b1 and 32:9.6.1-0.4.rc1 have bigger SOnames
# than current bind - https://bugzilla.redhat.com/show_bug.cgi?id=509635.
# Remove this trigger when SOnames get bigger.


The scriptlet gets run by /sbin/ldconfig, not /bin/bash?  That's... unusual.  I would have expected it to
be run using /bin/bash and included /sbin/ldconfig as a command inside the scriptlet.
Comment 2 Adam Tkac 2009-07-29 10:23:06 EDT
Fixed in bind-9.6.1-6.P1.fc12 (hopefully). If problem still exists please reopen.
Comment 3 Adam Tkac 2009-09-01 05:15:42 EDT

*** This bug has been marked as a duplicate of bug 520385 ***

Note You need to log in before you can comment on or make changes to this bug.