Bug 520385 - warning: %postun(bind-libs-32:9.6.1-7.P1.fc12.x86_64) scriptlet failed, exit status 1
warning: %postun(bind-libs-32:9.6.1-7.P1.fc12.x86_64) scriptlet failed, exit ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 513016 521330 (view as bug list)
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-08-31 05:40 EDT by Andreas Schwab
Modified: 2013-04-30 19:44 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-01 06:30:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andreas Schwab 2009-08-31 05:40:59 EDT
bind-libs %postun is trying to use /lib/ldconfig as a "shell".

  Cleanup        : 32:bind-libs-9.6.1-7.P1.fc12.x86_64                  149/222
/sbin/ldconfig: relative path `1' used to build cache
Non-fatal POSTUN scriptlet failure in rpm package b
warning: %postun(bind-libs-32:9.6.1-7.P1.fc12.x86_64) scriptlet failed, exit status 1

$ rpm -q bind-libs --scripts
postinstall program: /sbin/ldconfig
postuninstall scriptlet (using /sbin/ldconfig):

# bind-libs between 32:9.6.1-0.1.b1 and 32:9.6.1-0.4.rc1 have bigger SOnames
# than current bind - https://bugzilla.redhat.com/show_bug.cgi?id=509635.
# Remove this trigger when SOnames get bigger.
Comment 1 Adam Tkac 2009-09-01 05:15:42 EDT
*** Bug 513016 has been marked as a duplicate of this bug. ***
Comment 2 Adam Tkac 2009-09-01 05:19:07 EDT
Chm, it seems the first attempt to fix this issue was not successful (bug #513016).
Comment 3 Andreas Schwab 2009-09-01 05:50:34 EDT
The problem is that the specfile "language" does not have the concept of comments.  The body of the %postun script extends into the start of the next section (%triggerpostun in this case).  Your last attempt didn't change anything after all.
Comment 4 Adam Tkac 2009-09-01 06:30:21 EDT
Yes, it seems the specfile grammar doesn't include comments despite all docs say that comments start with '#'. I improved the postun scripplet so bind-9.6.1-9.P1.fc12 should be fine.
Comment 5 Adam Tkac 2009-09-07 04:35:42 EDT
*** Bug 521330 has been marked as a duplicate of this bug. ***
Comment 6 Cristian Ciupitu 2009-09-25 06:29:36 EDT
I'm having the same problem on *Fedora 11* when upgrading from bind-libs-9.6.1-4.P1.fc11.x86_64 (to bind-libs-9.6.1-6.P1.fc11.x86_64.rpm). Should I report another bug for Fedora 11?
Comment 7 Adam Tkac 2009-09-25 07:53:20 EDT
(In reply to comment #6)
> I'm having the same problem on *Fedora 11* when upgrading from
> bind-libs-9.6.1-4.P1.fc11.x86_64 (to bind-libs-9.6.1-6.P1.fc11.x86_64.rpm).
> Should I report another bug for Fedora 11?  

No. This bug was in postun script which means it is present even when you update to fixed 9.6.1-6.P1.fc11. This bug won't be present when you update from 9.6.1-6.P1.fc11 to newer version.
Comment 8 Cristian Ciupitu 2009-09-25 08:03:27 EDT
(In reply to comment #7)
> No. This bug was in postun script which means it is present even when you
> update to fixed 9.6.1-6.P1.fc11. This bug won't be present when you update from
> 9.6.1-6.P1.fc11 to newer version.  

Ok. I wanted to be sure that it's fixed in Fedora 11, too.

Note You need to log in before you can comment on or make changes to this bug.