Bug 514204 - Can't upgrade to newer rpm
Can't upgrade to newer rpm
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: 513937 514273 516075 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2009-07-28 06:53 EDT by Bastien Nocera
Modified: 2014-03-16 23:19 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-08-03 13:02:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
eric: fedora_requires_release_note?

Attachments (Terms of Use)
yum-upgrade-failure.txt (6.53 KB, text/plain)
2009-07-28 06:53 EDT, Bastien Nocera
no flags Details

  None (edit)
Description Bastien Nocera 2009-07-28 06:53:27 EDT
Created attachment 355393 [details]


On a Fedora 11 machine, trying to update to a newer rpm that would support the LZMA payload.

$ sudo yum --enablerepo=rawhide update rpm
ERROR with rpm_check_debug vs depsolve:
rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-headers-2.10.90-9.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-2.10.90-9.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-common-2.10.90-9.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-devel-2.10.90-9.i686
(1, [u'Please report this error in http://yum.baseurl.org/report'])

See attached log
Comment 1 Bill Nottingham 2009-07-28 10:36:02 EDT
*** Bug 513937 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2009-07-28 10:38:05 EDT
Either grab the RPM package from f11-updates-testing, or wait until tomorrow's rawhide, when an appropriate rpm package should be available in rawhide.
Comment 3 seth vidal 2009-07-28 14:54:36 EDT
*** Bug 514273 has been marked as a duplicate of this bug. ***
Comment 4 Pete Zaitcev 2009-07-29 03:15:10 EDT
I downloaded packages from Koji, ran this:

rpm -U rpm-4.7.0-9.fc12.x86_64.rpm rpm-build-4.7.0-9.fc12.x86_64.rpm rpm-devel-4.7.0-9.fc12.x86_64.rpm rpm-libs-4.7.0-9.fc12.i686.rpm rpm-libs-4.7.0-9.fc12.x86_64.rpm rpm-python-4.7.0-9.fc12.x86_64.rpm xz-devel-4.999.8-0.7.beta.fc12.x86_64.rpm xz-libs-4.999.8-0.7.beta.fc12.i586.rpm

Problem is gone now.
Comment 5 Pete Zaitcev 2009-07-31 14:22:08 EDT
I think we can close this now. I have a Rawhide system that was not
forced like in comment #4, and it went to new rpm after the yesterday's
mass rebuild smoothly. Bastien?
Comment 6 Bastien Nocera 2009-07-31 14:42:26 EDT
Fine after updating to the rpm in F11, but the original bug in yum persists (I would think). It didn't try to download the new rpm that provides support for the xz payload...
Comment 7 seth vidal 2009-07-31 14:47:04 EDT
Yum really can't download that ver of rpm. More importantly it would have to stop the current process. install the new rpm, close the rpmdb, reload the rpm module (and I'm not sure that can happen in a single python instance) and restart the original yum session to make that happen.
Comment 8 Bastien Nocera 2009-07-31 14:56:27 EDT
Right, feel free to close as WONTFIX then, so people aren't under the impression that yum was fixed (or worked-around) that case.
Comment 9 seth vidal 2009-07-31 15:02:19 EDT
I'm not closing this one b/c it is not a yum bug, imo. Hence why it is assigned to distribution.
Comment 10 Jesse Keating 2009-08-03 13:02:43 EDT
Not much we can do in this situation on rawhide other than to tell people to grab rpm during a certain period.  When coming from F11 we can tell people to update to the latest rpm in updates(-testing), and then jump to rawhide.
Comment 11 seth vidal 2009-08-06 11:55:17 EDT
*** Bug 516075 has been marked as a duplicate of this bug. ***
Comment 12 Shawn 2009-08-24 18:23:51 EDT
So for people that have been upgrading their system we are in a situation where the majority of our system is F12  packages and we can not upgrade any farther due to the broken RPM packages. In order to "upgrade" my F12 system to the F11 packages means either trying to force a down grade of at least 100 packages in order to meet the dependencies for the F11 RPM packages, (can't imagine what could go wrong there) or wipe my system and reinstall 11 and then pray that an upgrade to 12 will work.

Now I realise that life is hard in the rawhide branch but that seems pretty harsh even for rawhide. 

Is there no way that a set of RPM rpms could be built using the non XZ rpm build system that would deliver the new and upgraded XZ enabled RPM packages? 

I have tried to rebuild the F11 packages on my box in the state it is in but there are some packages that I need to add before I do that and I can't get those from F12 and again I would have to down grade or wipe my system to get them from 11 due to dependencies.

For people that "yum upgrade" from release to release rather than installing from disks this smells like a train wreck that has just been pushed off to the future.
Comment 13 Jesse Keating 2009-08-25 01:35:59 EDT
Problem is that the new rpm, even if it were built without XZ, would require the new glibc, which is build with xz, and so on and so forth.  Why can't the F11 packages be installed directly without rebuilding?  Is there now a dep issue that won't allow them in?
Comment 14 Shawn 2009-08-25 03:08:40 EDT
>Is there now a dep issue that won't allow them in?

Ya, almost 300 lines of dependencies which probably boils down to about 30 packaes and they are all inconsequential ones like glibc, gcc, python etc. By the time I try to get those in I would have another couple of hundred dependencies that broke. Most of my system is F12 packages now including my RPM packages.

I guess any one upgrading from 11 to 12 now will just flat out fail. I will only be people like me that upgraded to F12 before RPM and glibc were moved to the latest version that are hosed. Any idea how the "Upgrade" option on the install disks for the release are going to handle this? I can build a boot disk with the latest packages but I am not sure how to use the RPM install on a boot disk to upgrade RPM and it's dependencies onto the hard drive. chroot won't help in this case.
Comment 15 Panu Matilainen 2009-08-25 05:49:35 EDT
Eh, the latest rpm update to F11 from some weeks ago supports XZ so there's no problem going F11 -> F12.
Comment 16 Jesse Keating 2009-08-25 09:14:34 EDT
An anaconda based upgrade from whatever you have to the Alpha or rawhide should work fine.  It uses the rpm in the installer environment to do the upgrading, not your host rpm.
Comment 17 zeb 2009-08-29 05:33:27 EDT
"I guess any one upgrading from 11 to 12 now will just flat out fail."

Yup. I just did a fresh install of Fedora 11 on a test box and decided to upgrade it to rawhide. Fail. Then I tried to update just rpm and yum. nope. 

Found this thread and realizing what the issue was I changed back to the F11 repos and updates testing, upgraded yum and rpm and now the upgrade to rawhide  seem to be working. 

I realize this bug is already closed and there are limitations to what can be done about to fix it. Most of us wanting to run rawhide know our way around or at least know how to troubleshoot and at last resort google. I just hope it doesn't resurface when F12 comes out.
Comment 18 tytower 2009-11-08 18:48:41 EST
I Installed f11 and wanted to update a package for the codecs to play music and videos. This error comes up everytime I try. 

So what do you suggest I do to get my players playing .
I dont have the capability to download much anyway I'm limited to 500Megs per month , an extra 500 would cost me $50 so there you are , I'm stuck between there and a hard rock. Not very good service Fedora ! and here I was applauding your excellent system over Mandriva
Comment 19 tytower 2009-11-08 19:04:25 EST
In case anyone follows me here

This was my mistake I think
I went back and unchecked the fusion repositories , just leaving the F11 ones
Then I went to play a movie and when it offered to search this time it was able to install what it needed without problem .

I think I must have been trying to install the package from F12

Note You need to log in before you can comment on or make changes to this bug.