Bug 51498 - unresolved dependencies screen showing invalid options
unresolved dependencies screen showing invalid options
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 20:08 EDT by Peter Bowen
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-13 11:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bowen 2001-08-10 20:08:59 EDT
I am opening this bug to seperate one of the issues out of bug #50899.

Prior relevant text:
------- Additional comments from pzb@scyld.com 2001-08-05 11:46:53 -------
This also showed up on my laptop during the upgrade from Zoot to Roswell.  The
unresolved deps screen was caused by foreign (non-Red Hat provided) packages
being installed on my system.  

All the packages listed had 'no suggestion' listed under 'Requirement'.  Even
though there were not any packages to potentially install, there was still an
option to 'Install packages to satisfy dependencies'.  Choosing this option has
the same result as choosing 'Ignore package dependencies': unsatisified deps on
the machine post-install.  Additionally, the option 'Do not install packages
that have dependencies' does not make sense, as the listed packages are already
installed on the system.

I realize that this screen has existed as long as anaconda has existed, but it
could be confusing to users who are not familiar with RPM dependencies.  This
screen seems unnecessary unless the user has selected 'Customize packages to be
 upgraded' or 'Select individual packages' as there is never an option for the
end user -- if they want a functional system, the dependencies must be
resolved.
 The only time it seems reasonable to show the screen is when the user has
chosen to select individual packages.

Could anaconda not show the 'Unresolved Dependencies' screen unless the
user has
manually selected packages?  Otherwise it would just automatically choose
'Install packages to satisfy dependencies' and skip the screen.


------- Additional comments from bfox@redhat.com 2001-08-10 18:24:06 -------
Ok, we're talking about a few different issues here. One is that the package
dependency screen needs some work. That can't be done in the current release
time frame, but perhaps in the future.
Comment 1 Peter Bowen 2001-08-10 20:11:21 EDT
To be clear, I do not expect this to be resolved during the Fairfax development
cycle.  It will require anaconda work too significant to be done this late in
the game.
Comment 2 Matt Wilson 2001-08-11 14:31:50 EDT

*** This bug has been marked as a duplicate of 46322 ***
Comment 3 Peter Bowen 2001-08-11 14:46:35 EDT
I wasn't trying to seperate out the choosing which ones to deal with.

My bug is that if all packages have 'No Suggestion', then 'Install packages to
satisfy dependencies' should not be an option.

I don't think Bug #46322 covers this bug.
Comment 4 Matt Wilson 2001-09-05 20:31:45 EDT
I've fixed this in cvs.

Note You need to log in before you can comment on or make changes to this bug.