Bug 515671 - 'groupadd -r' allocates gids upwards
'groupadd -r' allocates gids upwards
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
11
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtBlocker
  Show dependency treegraph
 
Reported: 2009-08-05 06:28 EDT by Mark McLoughlin
Modified: 2009-08-12 16:52 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.1.4.1-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-06 12:43:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-08-05 06:28:23 EDT
On F-11:

  $> rpm -q shadow-utils
  shadow-utils-4.1.2-13.fc11.i586
  $> groupadd -r foo
  $> getent group foo 
  foo:x:482:

with rawhide or F-11 updates-testing:

  $> rpm -q shadow-utils
  shadow-utils-4.1.4.1-5.fc12.x86_64
  $> groupadd -r foo
  $> getent group foo
  foo:x:106:

This is a serious problem because by allocating upwards, we're allocating in the 100-200 range which is now used by system accounts like qemu(107). See also bug #515667

The "allocate upwards" behaviour is long-standing, but it seems a recent shadow-utils re-base has broken it
Comment 1 Fedora Update System 2009-08-05 10:17:54 EDT
shadow-utils-4.1.4.1-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/shadow-utils-4.1.4.1-5.fc11
Comment 2 Mark McLoughlin 2009-08-05 13:34:35 EDT
Removing from F12VirtBlocker; using bug #515779 for F-12 tracking
Comment 3 Mark McLoughlin 2009-08-06 12:43:28 EDT
Fixed in rawhide, f12-alpha tag request here:

  https://fedorahosted.org/rel-eng/ticket/2053
Comment 4 Fedora Update System 2009-08-12 16:52:36 EDT
shadow-utils-4.1.4.1-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.