Bug 515997 - install-info error warnings installing gettext with --excludedocs
install-info error warnings installing gettext with --excludedocs
Status: CLOSED DUPLICATE of bug 516757
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
: 515916 515918 515931 515937 515945 515949 515951 515952 515954 515955 515956 515964 515967 515968 515969 515972 515973 515974 515976 515978 515979 515980 515981 515982 515983 515984 515985 515986 515988 515989 515990 515991 515992 515993 515994 515996 516003 516004 516007 516009 (view as bug list)
Depends On:
Blocks: 516757
  Show dependency treegraph
 
Reported: 2009-08-06 07:33 EDT by Alexander Todorov
Modified: 2009-10-27 21:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 21:48:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2009-08-06 07:33:31 EDT
Description of problem:
When installing with --excludedocs there are errors caused by missing files.

Version:
gettext-0.17-10.fc11.i586

How reproducible:
Always

Steps to reproduce:
1) rpm -ihv --excludedocs gettext-0.17-10.fc11.i586  

or:
- use %packages --excludedocs in kickstart
- enable %_excludedocs macro in RPM

Expected results:
Package is installed without errors

Actual results:
Error(s): Installing gettext-0.17-10.fc11.i586
install-info: No such file or directory for /usr/share/info/gettext.info.gz

Additional info:
This bug is automatically filed with python-bugzilla and component assignment may be incorrect.
Comment 1 Jens Petersen 2009-08-31 05:19:07 EDT
*** Bug 516003 has been marked as a duplicate of this bug. ***
Comment 2 Jens Petersen 2009-09-01 00:45:23 EDT
The install-info invocations are already protected by " || :".

So these are actually only rpm warning messages.

Is there anything to do here?
Comment 3 Alexander Todorov 2009-09-07 05:04:16 EDT
This is not critical error but just warning message and there are lots of them. This can generate lots of unnecessary support calls especially for RHEL products. My proposal to fix this is (in order of preference):

1) Check if the file exists and then call install-info
2) Redirect all output to /dev/null
Comment 4 Jens Petersen 2009-09-07 05:41:30 EDT
Okay fair enough though it is a fairly minor case -
don't know how many customers even know about --excludedocs.

Have you presented the idea to Fedora Packaging Committee?
gettext is just using standard install scripts for install-info.
IMHO it should be revised first in our packaging standards
before we go to change all the current packages in the current
distro.
Comment 6 Mamoru TASAKA 2009-09-07 08:18:44 EDT
Again Alexander, why don't you post to fedora-packaging
mailing list why you want to get this changed and abou your idea
about how to change this?

As you can see currently on fedora-packaging list the discussion
about this stopped. This usually means fedora-packaging member
have little interest on this, and I guess unless you comment
on fedora-packaging list this discussion won't restart again.
Comment 7 Jens Petersen 2009-09-07 20:24:45 EDT
Alexander, if you can propose a workable change to the current
recommended install-info packaging scripts and get it
approved by FPC that would be good. :)

IMHO it should really be done with macros - so that we have
consistency across packages and a rebuild ensures that
the latest recommended scripts are in use.
Comment 8 dongjibing 2009-10-26 03:45:29 EDT
*** Bug 515955 has been marked as a duplicate of this bug. ***
Comment 9 dongjibing 2009-10-26 03:47:07 EDT
*** Bug 515964 has been marked as a duplicate of this bug. ***
Comment 10 dongjibing 2009-10-26 03:50:25 EDT
*** Bug 515986 has been marked as a duplicate of this bug. ***
Comment 11 dongjibing 2009-10-26 03:52:16 EDT
*** Bug 515949 has been marked as a duplicate of this bug. ***
Comment 12 dongjibing 2009-10-26 03:53:57 EDT
*** Bug 515981 has been marked as a duplicate of this bug. ***
Comment 13 dongjibing 2009-10-26 03:54:33 EDT
*** Bug 515945 has been marked as a duplicate of this bug. ***
Comment 14 dongjibing 2009-10-26 03:57:01 EDT
*** Bug 515967 has been marked as a duplicate of this bug. ***
Comment 15 dongjibing 2009-10-26 03:57:35 EDT
*** Bug 515974 has been marked as a duplicate of this bug. ***
Comment 16 dongjibing 2009-10-26 03:58:04 EDT
*** Bug 515980 has been marked as a duplicate of this bug. ***
Comment 17 dongjibing 2009-10-26 03:58:34 EDT
*** Bug 516007 has been marked as a duplicate of this bug. ***
Comment 18 dongjibing 2009-10-26 03:59:06 EDT
*** Bug 515916 has been marked as a duplicate of this bug. ***
Comment 19 dongjibing 2009-10-26 03:59:40 EDT
*** Bug 515937 has been marked as a duplicate of this bug. ***
Comment 20 dongjibing 2009-10-26 04:00:09 EDT
*** Bug 515968 has been marked as a duplicate of this bug. ***
Comment 21 dongjibing 2009-10-26 04:00:38 EDT
*** Bug 515969 has been marked as a duplicate of this bug. ***
Comment 22 dongjibing 2009-10-26 04:01:12 EDT
*** Bug 515972 has been marked as a duplicate of this bug. ***
Comment 23 dongjibing 2009-10-26 04:01:41 EDT
*** Bug 515978 has been marked as a duplicate of this bug. ***
Comment 24 dongjibing 2009-10-26 04:02:11 EDT
*** Bug 515989 has been marked as a duplicate of this bug. ***
Comment 25 dongjibing 2009-10-26 04:02:45 EDT
*** Bug 515991 has been marked as a duplicate of this bug. ***
Comment 26 dongjibing 2009-10-26 04:03:12 EDT
*** Bug 515992 has been marked as a duplicate of this bug. ***
Comment 27 dongjibing 2009-10-26 04:03:41 EDT
*** Bug 515993 has been marked as a duplicate of this bug. ***
Comment 28 dongjibing 2009-10-26 04:04:07 EDT
*** Bug 515994 has been marked as a duplicate of this bug. ***
Comment 29 dongjibing 2009-10-26 04:04:45 EDT
*** Bug 515973 has been marked as a duplicate of this bug. ***
Comment 30 dongjibing 2009-10-26 04:05:18 EDT
*** Bug 515988 has been marked as a duplicate of this bug. ***
Comment 31 dongjibing 2009-10-26 04:05:54 EDT
*** Bug 515979 has been marked as a duplicate of this bug. ***
Comment 32 dongjibing 2009-10-26 04:06:38 EDT
*** Bug 515982 has been marked as a duplicate of this bug. ***
Comment 33 dongjibing 2009-10-26 04:07:10 EDT
*** Bug 515985 has been marked as a duplicate of this bug. ***
Comment 34 dongjibing 2009-10-26 04:07:40 EDT
*** Bug 515922 has been marked as a duplicate of this bug. ***
Comment 35 dongjibing 2009-10-26 04:08:07 EDT
*** Bug 515952 has been marked as a duplicate of this bug. ***
Comment 36 dongjibing 2009-10-26 04:08:50 EDT
*** Bug 515990 has been marked as a duplicate of this bug. ***
Comment 37 dongjibing 2009-10-26 04:09:25 EDT
*** Bug 515956 has been marked as a duplicate of this bug. ***
Comment 38 dongjibing 2009-10-26 04:09:56 EDT
*** Bug 515984 has been marked as a duplicate of this bug. ***
Comment 39 dongjibing 2009-10-26 04:10:26 EDT
*** Bug 515951 has been marked as a duplicate of this bug. ***
Comment 40 dongjibing 2009-10-26 04:10:58 EDT
*** Bug 515983 has been marked as a duplicate of this bug. ***
Comment 41 dongjibing 2009-10-26 04:11:27 EDT
*** Bug 515996 has been marked as a duplicate of this bug. ***
Comment 42 dongjibing 2009-10-26 04:12:02 EDT
*** Bug 515954 has been marked as a duplicate of this bug. ***
Comment 43 dongjibing 2009-10-26 04:12:42 EDT
*** Bug 515976 has been marked as a duplicate of this bug. ***
Comment 44 dongjibing 2009-10-26 04:13:43 EDT
*** Bug 515918 has been marked as a duplicate of this bug. ***
Comment 45 dongjibing 2009-10-26 04:14:09 EDT
*** Bug 516009 has been marked as a duplicate of this bug. ***
Comment 46 dongjibing 2009-10-26 04:14:39 EDT
*** Bug 516004 has been marked as a duplicate of this bug. ***
Comment 47 dongjibing 2009-10-26 04:15:14 EDT
*** Bug 515931 has been marked as a duplicate of this bug. ***
Comment 48 Jens Petersen 2009-10-27 21:48:26 EDT

*** This bug has been marked as a duplicate of bug 516757 ***

Note You need to log in before you can comment on or make changes to this bug.