Bug 516536 - Review Request: globus-gram-job-manager - Globus Toolkit - GRAM Jobmanager
Summary: Review Request: globus-gram-job-manager - Globus Toolkit - GRAM Jobmanager
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Traylen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 516518 516529 516531 516532 516533 516534 516535 563820
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-10 11:03 UTC by Mattias Ellert
Modified: 2010-04-15 15:47 UTC (History)
3 users (show)

Fixed In Version: globus-gram-job-manager-10.17-1.el4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-03 04:38:23 UTC
steve.traylen: fedora-review+
kevin: fedora-cvs+


Attachments (Terms of Use)

Description Mattias Ellert 2009-08-10 11:03:35 UTC
Spec URL: http://www.grid.tsl.uu.se/review/globus-gram-job-manager.spec
SRPM URL: http://www.grid.tsl.uu.se/review/globus-gram-job-manager-8.15-1.fc11.src.rpm

Description:
The Globus Toolkit is an open source software toolkit used for building Grid
systems and applications. It is being developed by the Globus Alliance and
many others all over the world. A growing number of projects and companies are
using the Globus Toolkit to unlock the potential of grids for their cause.

The globus-gram-job-manager package contains:
GRAM Jobmanager
GRAM Job Manager Setup

Globus Toolkit Packaging Guidelines:
https://fedoraproject.org/wiki/Packaging:Globus

Comment 2 Steve Traylen 2010-03-21 13:08:02 UTC
Bit confused by this, using the repo as below then I can't seem to satisfy.

globus-duct-control-devel(x86-64) >= 2 is needed by globus-gram-job-manager-8.15-1.fc14.x86_64
globus-nexus-devel(x86-64) >= 6 is needed by globus-gram-job-manager-8.15-1.fc14.x86_64

but they certainly were released.

Repo-id      : rawhide
Repo-name    : Fedora - Rawhide - Developmental packages for the next Fedora release
Repo-revision: 1266344766
Repo-tags    : binary-x86_64
Repo-distro-tags: [cpe:/o:fedoraproject:fedora:13]: rawhide
Repo-updated : Tue Feb 16 20:09:21 2010
Repo-pkgs    : 20,191
Repo-size    : 19 G
Repo-baseurl : http://download.fedoraproject.org/pub/fedora/linux/development/x86_64/os/
Repo-expire  : 21,600 second(s) (last: Sun Mar 21 14:04:46 2010)

Comment 3 Mattias Ellert 2010-03-21 15:38:45 UTC
(In reply to comment #2)
> Bit confused by this, using the repo as below then I can't seem to satisfy.
> 
> globus-duct-control-devel(x86-64) >= 2 is needed by
> globus-gram-job-manager-8.15-1.fc14.x86_64
> globus-nexus-devel(x86-64) >= 6 is needed by
> globus-gram-job-manager-8.15-1.fc14.x86_64
> 
> but they certainly were released.

You are trying to compile the globus 4 version (8.15) from the original submission.

The current globus 5 version (10.17) as given in comment #1 does not depend on those two packages.

Those two packages (along with a few others) were dropped by Globus upstream when they released globus 5, so they have been marked as dead packages and are no longer available in rawhide.

Comment 4 Steve Traylen 2010-03-21 16:26:29 UTC
Thanks. My mistake of course.

Unfortunately it seems globus-common-doc can't be installed just now:

 yum install   globus-common-doc

Error: Package: glibc-2.11.90-12.i686 (rawhide)
           Requires: glibc-common = 2.11.90-12
           Installed: glibc-common-2.11.90-15.x86_64 (@rawhide)
           Available: glibc-common-2.11.90-12.x86_64 (rawhide)


will try again in a few days.

Steve

Comment 5 Steve Traylen 2010-03-27 20:57:36 UTC
Review: globus-gram-job-manager
Date:   Mar 27th 2010
Mock Build: Okay in F14-x86_64.

* YES: rpmlint output
$ rpmlint SPECS/globus-gram-job-manager.spec \
          SRPMS/globus-gram-job-manager-10.17-1.fc12.src.rpm \
          RPMS/x86_64/globus-gram-job-manager-10.17-1.fc12.x86_64.rpm \
          RPMS/x86_64/globus-gram-job-manager-debuginfo-10.17-1.fc12.x86_64.rpm  \
          RPMS/noarch/globus-gram-job-manager-doc-10.17-1.fc12.noarch.rpm  
SPECS/globus-gram-job-manager.spec: W: invalid-url Source1: globus_gram_job_manager_setup-4.3.tar.gz
SPECS/globus-gram-job-manager.spec: W: invalid-url Source0: globus_gram_job_manager-10.17.tar.gz
globus-gram-job-manager.src: W: invalid-url Source1: globus_gram_job_manager_setup-4.3.tar.gz
globus-gram-job-manager.src: W: invalid-url Source0: globus_gram_job_manager-10.17.tar.gz

which is all to be expected.

* YES: Named according to the Package Naming Guidelines.
globus guidelines.
* YES: spec file name same as  base package %{name}.
globus guidelines.
* YES: Packaging Guidelines.
globus guidelines.
* YES: Approved license in .spec file.
ASL2.0
* YES: License on Source code.
YES,  clear licensing.
* YES: Include LICENSE file or similar if it exist.
GLOBUS_LICENSE
* YES: Written in American English.
* YES: Spec file legible. 
* YES: Included source must match upstream source.
$ diff -r --brief   gt5.0.0-all-source-installer/source-trees/gram/jobmanager/source \
   ~/rpmbuild/SOURCES/globus_gram_job_manager-10.17
Only in /home/steve/rpmbuild/SOURCES/globus_gram_job_manager-10.17: GLOBUS_LICENSE
which is to be expected.
* YES: Build on one architecture.
* YES: Not building on an architecture must highlighted.
Not checked.
* YES: Build dependencies must be listed in BuildRequires.
* YES: Handle locales properly. 
* YES: ldconfig must be called on shared libs.
* YES: No bundled copies of system libraries.
* YES: Package must state why relocatable if relocatable.
* YES: A package must own all directories that it creates
* YES:  No duplicate files in %files listings. 
* YES:  Permissions on files must be set properly. %defattr
* YES:  %clean section contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT).
* YES:  Each package must consistently use macros.
* YES:  The package must contain code, or permissable content.
* YES:  Large documentation files must go in a -doc subpackage.  
* YES:  %doc  must not affect the runtime of the application. 
* YES:  Header files must be in a -devel package.
* YES:  Static libraries must be in a -static package.
* YES:  Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig'
* YES:  Then library files that end in .so 
         (without suffix) must go in a -devel package. 
* YES:  devel packages must require the exact base package
* YES:  No .la libtool archives
* YES:  GUI apps should have %{name}.desktop file
* YES:  No files or directories already owned by other packages. 
* YES:  %install must run rm -rf %{buildroot} (or $RPM_BUILD_ROOT).
* YES:  All filenames in rpm packages must be valid UTF-8.

APPROVED.

Comment 6 Mattias Ellert 2010-03-29 06:11:54 UTC
Many thanks for the review!

New Package CVS Request
=======================
Package Name: globus-gram-job-manager
Short Description: Globus Toolkit - GRAM Jobmanager
Owners: ellert
Branches: F-11 F-12 F-13 EL-4 EL-5
InitialCC:

Comment 7 Kevin Fenzi 2010-03-30 21:28:50 UTC
CVS done (by process-cvs-requests.py).

Comment 8 Fedora Update System 2010-03-31 15:12:51 UTC
globus-gram-job-manager-10.17-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/globus-gram-job-manager-10.17-1.fc13

Comment 9 Fedora Update System 2010-03-31 15:13:56 UTC
globus-gram-job-manager-10.17-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/globus-gram-job-manager-10.17-1.fc11

Comment 10 Fedora Update System 2010-03-31 15:14:00 UTC
globus-gram-job-manager-10.17-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/globus-gram-job-manager-10.17-1.fc12

Comment 11 Fedora Update System 2010-03-31 15:14:19 UTC
globus-gram-job-manager-10.17-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/globus-gram-job-manager-10.17-1.el5

Comment 12 Fedora Update System 2010-03-31 15:14:24 UTC
globus-gram-job-manager-10.17-1.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/globus-gram-job-manager-10.17-1.el4

Comment 13 Fedora Update System 2010-04-01 21:01:41 UTC
globus-gram-job-manager-10.17-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update globus-gram-job-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/globus-gram-job-manager-10.17-1.el5

Comment 14 Fedora Update System 2010-04-01 21:04:00 UTC
globus-gram-job-manager-10.17-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update globus-gram-job-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/globus-gram-job-manager-10.17-1.el4

Comment 15 Fedora Update System 2010-04-03 04:38:18 UTC
globus-gram-job-manager-10.17-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-04-03 04:48:43 UTC
globus-gram-job-manager-10.17-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2010-04-09 03:46:14 UTC
globus-gram-job-manager-10.17-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-04-15 15:46:38 UTC
globus-gram-job-manager-10.17-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2010-04-15 15:47:12 UTC
globus-gram-job-manager-10.17-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.