Bug 517391 - xscreensaver autostarts itself unless gnome-screensaver is installed
xscreensaver autostarts itself unless gnome-screensaver is installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-08-13 14:06 EDT by Jerry Amundson
Modified: 2010-09-30 19:56 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.10-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 19:42:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jerry Amundson 2009-08-13 14:06:12 EDT
Description of problem:
systemsettings does not change kde screensaver options. I do not select require password - it requires password (in big/ugly X prompt). I change the timeout, it never starts the screensaver at all. Etc...

Version-Release number of selected component (if applicable):
kdebase-workspace-4.3.0-4.fc12.i686

How reproducible:
often

Steps to Reproduce:
1. use screen save
2.
3.
  
Actual results:
random

Expected results:
predictable

Additional info:
Comment 1 Rex Dieter 2009-08-13 14:29:16 EDT
It works for me on F-11, lemme test my F12 live image...

You *may* be experiencing side effects of a prelink bug #515539
Comment 2 Rex Dieter 2009-08-13 14:37:05 EDT
Confirmed ok here for rawhide too.
Comment 3 Jerry Amundson 2009-08-13 15:07:34 EDT
(In reply to comment #2)
> Confirmed ok here for rawhide too.  

My guess is it's the presence of xscreensaver-base. Is that installed in your test systems?
Comment 4 Jerry Amundson 2009-08-13 15:26:27 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > Confirmed ok here for rawhide too.  
> 
> My guess is it's the presence of xscreensaver-base. 

.. and xscreensaver-* was pulled in because of kdeartwork-kxs deps, and that was needed by kdeartwork-screensavers, which only got pulled in because I did "yum groupinstall "KDE (K Desktop Environment)". Yuk.

yum -y erase xscreensaver\*
solved the problem.
Comment 5 Rex Dieter 2009-08-13 15:49:22 EDT
fair nuf, I only tested the tried-n-true "blank" screensaver.

I'll test xscreensaver-based ones too.  In particular, which ones did you try?
Comment 6 Jerry Amundson 2009-08-13 16:25:05 EDT
(In reply to comment #5)
> fair nuf, I only tested the tried-n-true "blank" screensaver.
> 
> I'll test xscreensaver-based ones too.  In particular, which ones did you try?  

I believe this machine had only been set to Random.
Comment 7 Steven M. Parrish 2009-08-26 15:16:43 EDT
Ping

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Rex Dieter 2009-08-26 15:21:15 EDT
we probably want someone (on rawhide) to test/verify this or close worksforme.
Comment 9 Jerry Amundson 2009-09-09 14:16:15 EDT
I just reproduced this on rawhide, similar to my statements above:
- take normally running KDE system, but without packages below
- yum groupinstall "KDE (K Desktop Environment)"
[for example. ymmv]
yum then installed:

polkit-gnome
kdeartwork-screensavers
xscreensaver-extras
kdeartwork-kxs
xscreensaver-base
xscreensaver-gl-base
xscreensaver-gl-extras

Voilà! Normal, no password KDE, screensaver is now partnered with X screensaver and the ugly password prompt I didn't ask for.
Comment 10 Steven M. Parrish 2009-09-26 18:43:53 EDT
Ping?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Jerry Amundson 2009-10-06 14:45:50 EDT
(In reply to comment #10)
> Ping?

Still present in the current rawhide.
Reproduced it by:
1. adding a new test user. [this seemed to be a key point]
2. login as new user.
3. in system settings - screensaver, note nothing is checked by default.
4. exit system settings and do nothing on the system
[optionally, open konsole and observe the running "xscreensaver -nosplash" process started by kdeinit4.
Comment 12 Jerry Amundson 2009-10-06 15:30:24 EDT
(In reply to comment #11)
> (In reply to comment #10)
> > Ping?
> 
> Still present in the current rawhide.
> Reproduced it by:
> 1. adding a new test user. [this seemed to be a key point]

Not needed, I just realized. Just by setting 
After: in systemsettings low enough, the xscreensaver will kick in over the KDE version.
Comment 13 Rex Dieter 2009-10-06 16:18:53 EDT
See, that's the problem.  There should be no xscreensaver running.
Comment 14 Jerry Amundson 2009-10-06 16:36:37 EDT
OK then, kdeinit4 started it, so I'm changing the component.
# ps -ewwf |  grep -E '(screen|kdeinit4 Running)'
dtilocal  7223     1  0 11:29 ?        00:00:00 kdeinit4: kdeinit4 Running...
dtilocal  7281  7223  0 11:29 ?        00:00:11 xscreensaver -nosplash
Comment 15 Rex Dieter 2009-10-06 21:03:43 EDT
I don't know how it got running for you, but I'm fairly certain nothing in kde runs xscreensaver (directly), that's the point I've been trying to make.
Comment 16 Jerry Amundson 2009-10-07 10:55:08 EDT
(In reply to comment #15)
> I don't know how it got running for you, but I'm fairly certain nothing in kde
> runs xscreensaver (directly), that's the point I've been trying to make.  

The source indicates otherwise:
$ grep -r xscreensaver rpmbuild/BUILD/kdeartwork-4.3.1/ 2> /dev/null | wc -l
257

As the sequence of this bug indicates, it's not *me* running xscreensaver. That's the point I'm trying to make. :-)
Comment 17 Rex Dieter 2009-10-07 11:02:24 EDT
Try again,

grep -r nosplash rpmbuild/BUILD/kdeartwork-4.3.1/ 2> /dev/null | wc -l

Of course, there are xscreensaver references, but kde launches them, just not via the xscreensaver binary.
Comment 18 Rex Dieter 2009-10-07 11:05:34 EDT
Arg, looks like xscreensaver is autostarting itself on F12+.  boo, bad form.

Re-assigning to xscreensaver, for comment.

methinks the autostart .desktop file best include
NotShowIn=KDE
Comment 19 Rex Dieter 2009-10-07 11:55:54 EDT
Or perhaps a
OnlyShowIn=...
so only the desktops that want/need this get it, minimizes surprises (like this one).
Comment 20 Jerry Amundson 2009-10-07 12:16:06 EDT
(In reply to comment #17)
> Try again,
> 
> grep -r nosplash rpmbuild/BUILD/kdeartwork-4.3.1/ 2> /dev/null | wc -l

Thanks for the reality check. I knew something was going on, and just threw each thing out there I could think of to find it. Looks like we're on the right path now, so I've also changed the Summary.
Comment 21 Kevin Kofler 2009-10-07 14:52:56 EDT
Well, I think that KDE is the only desktop environment which does its own xscreensaver integration. GNOME does its own thing with gnome-screensaver. Still, I guess you also don't want xscreensaver to run under GNOME by default.

I'd suggest:
NotShowIn=KDE;GNOME;
Comment 22 Kevin Kofler 2009-10-07 14:53:59 EDT
(That said, I'm not familiar with how XFCE, LXDE, Sugar etc. do things, they may want xscreensaver not to run by default either.)
Comment 23 Mamoru TASAKA 2009-10-07 15:32:10 EDT
Please don't add words such as "recklessly"......
Please be kind to everyone.
Comment 24 Jerry Amundson 2009-10-07 16:20:20 EDT
(In reply to comment #23)
> Please don't add words such as "recklessly"......
> Please be kind to everyone.  

I'm sorry, I meant no offense.
Comment 25 Mamoru TASAKA 2009-10-07 19:42:20 EDT
Should be fixed in 5.10-2.fc12 (tagged as dist-f12/f12-beta), thank you.

Added OnlyShowIn=GNOME. Note that 5.10-2.fc12 has a wrapper script
and even on GNOME session xscreensaver won't start if gnome-screensaver
is installed, which is the same behavior as F-11.
Comment 26 John Sullivan 2010-09-30 19:56:56 EDT
Hmm. While looking into something else I notice that this appears to have reverted bug 483495 without any comments here or there to that effect. Was that deliberate?

Note You need to log in before you can comment on or make changes to this bug.