Bug 517783 - [mai_IN] font-match is showing different fonts than language
Summary: [mai_IN] font-match is showing different fonts than language
Keywords:
Status: CLOSED DUPLICATE of bug 497768
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 497768
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-17 07:41 UTC by A S Alam
Modified: 2013-07-03 00:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 497768
Environment:
Last Closed: 2010-07-22 05:43:25 UTC


Attachments (Terms of Use)

Description A S Alam 2009-08-17 07:41:44 UTC
Bug Clone for Rawhide with following version:
---------
fontconfig-2.7.1-1.fc12
lohit-maithili-fonts-2.4.0-2.fc12
--------

+++ This bug was initially created as a clone of Bug #497768 +++

Description of problem:
Machine with Rawhide, having Maithili(mai_IN) language only, while checking font for language, it is showing "Lohit Hindi", while maithili fonts are installed on machine.

Version-Release number of selected component (if applicable):
fontconfig-2.6.99.behdad.20090318-1.fc11.i586
lohit-maithili-fonts-2.3.8-1.fc11.noarch

How reproducible:
Everytime

Steps to Reproduce:
1. in gnome-terminal run,
2. $fc-match
3.
  
Actual results:
[aalam@333-333 ~]$ echo $LANG
mai_IN
[aalam@333-333 ~]$ fc-match 
lohit_hi.ttf: "Lohit Hindi" "Regular"

Expected results:
"Lohit Maithili"

Additional info:

--- Additional comment from fedora-triage-list@redhat.com on 2009-06-09 10:37:57 EDT ---


This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

--- Additional comment from psatpute@redhat.com on 2009-08-16 23:42:57 EDT ---

*** Bug 517635 has been marked as a duplicate of this bug. ***

Comment 1 A S Alam 2009-11-20 04:13:06 UTC
test with latest f12 package:
fontconfig-2.7.3-1.fc12

Comment 2 Nicolas Mailhot 2009-11-20 09:29:03 UTC
You can check if the font file is not missing a few glyphs running

DEBUG=256 fc-query 

If the coverage is ok (target locale appears with a zero count in the list) then the relative priorities of those fonts need to be tweaked with  /usr/share/fontconfig/templates/l10n-font-template.* like rules

(drop a basic rule for every font that needs l10n de-ambiguation at prefix x, and a l10n rule with the correct local for prio override at prefix x+1)

Comment 3 Parag Nemade 2010-07-22 05:43:25 UTC

*** This bug has been marked as a duplicate of bug 497768 ***


Note You need to log in before you can comment on or make changes to this bug.