Bug 518239 - s-c-s crashes on startup:
Summary: s-c-s crashes on startup:
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-services
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-19 15:54 UTC by Tom London
Modified: 2009-11-05 21:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-05 21:11:34 UTC


Attachments (Terms of Use)

Description Tom London 2009-08-19 15:54:45 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2009-08-19 15:56:09 UTC
Sorry for the fat fingers.... Here is the data:

I'm seeing:

[tbl@tlondon ~]$ system-config-services
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 951, in <module>
    GUI (use_dbus = use_dbus).run ()
  File "/usr/bin/system-config-services", line 906, in __init__
    self.serviceherders.append (cls (bus = self._bus))
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 53, in __init__
    for service_name in self.list_services ():
  File "/usr/lib/python2.6/site-packages/slip/dbus/polkit.py", line 48, in enable_proxy_wrapper
    return func (*p, **k)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 66, in list_services
    return self.dbus_object.list_services (dbus_interface = "org.fedoraproject.Config.Services.ServiceHerder")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: An SELinux policy prevents this sender from sending this message to this recipient (rejected message had sender ":1.96" interface "org.freedesktop.PolicyKit" member "IsSystemBusNameAuthorized" error name "(unset)" destination ":1.97")
[tbl@tlondon ~]$ 


polkit-gnome-0.94-1.fc12.x86_64
system-config-services-docs-1.1.6-2.fc12.noarch
PolicyKit-debuginfo-0.9-6.fc11.x86_64
PolicyKit-0.9-6.fc11.x86_64
PolicyKit-gnome-libs-0.9.2-5.fc12.x86_64
PolicyKit-gnome-0.9.2-5.fc12.x86_64
polkit-debuginfo-0.93-3.fc12.x86_64
polkit-0.94-3.fc12.x86_64
system-config-services-0.99.35-1.fc12.noarch
polkit-desktop-policy-0.94-3.fc12.noarch


Happens every time.

Comment 2 Tom London 2009-08-19 16:32:25 UTC
Looks like this fails as above when running SELinux in enforcing mode.

If I put SELinux into permissive mode, s-c-s starts, but produces a difference error spew:

[tbl@tlondon ~]$ echo "setenforce 0"
setenforce 0
[tbl@tlondon ~]$ system-config-services
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 123, in notify
    self.dbus_notify (subscriber, service_name, change)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 98, in dbus_notify
    subscriber.remote_method_or_function (herder = self, change = change, *subscriber.p, **k)
  File "/usr/bin/system-config-services", line 551, in on_services_changed
    self.on_service_added (service)
  File "/usr/bin/system-config-services", line 575, in on_service_added
    self.service_painters[service].paint ()
  File "/usr/bin/system-config-services", line 367, in paint
    self.treestore.set (iter, SVC_COL_STATUS, _status_stock_id[self.service.status])
  File "/usr/lib/python2.6/site-packages/slip/dbus/polkit.py", line 48, in enable_proxy_wrapper
    return func (*p, **k)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/services.py", line 98, in status
    return self.dbus_object.get_status (dbus_interface = "org.fedoraproject.Config.Services.SysVService")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[tbl@tlondon ~]$ 

Adding Dan Walsh to this....

Comment 3 Tom London 2009-08-19 16:44:20 UTC
Looking more closely at /var/log/audit/audit.log while running s-c-s, I see:

[root@tlondon ~]# audit2allow
type=SYSCALL msg=audit(1250699292.820:48): arch=c000003e syscall=1 success=yes exit=0 a0=3 a1=7fff799c5010 a2=1 a3=7fff799c3db0 items=0 ppid=2565 pid=5730 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=1 comm="setenforce" exe="/usr/sbin/setenforce" subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)
type=USER_AVC msg=audit(1250699305.675:49): user pid=1016 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } for msgtype=method_call interface=org.freedesktop.DBus.Introspectable member=Introspect dest=:1.93 spid=5753 tpid=5757 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:system_r:policykit_t:s0-s0:c0.c1023 tclass=dbus : exe="/bin/dbus-daemon" (sauid=81, hostname=?, addr=?, terminal=?)'
type=USER_AVC msg=audit(1250699305.677:50): user pid=1016 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } for msgtype=method_return dest=:1.92 spid=5757 tpid=5753 scontext=system_u:system_r:policykit_t:s0-s0:c0.c1023 tcontext=system_u:system_r:initrc_t:s0 tclass=dbus : exe="/bin/dbus-daemon" (sauid=81, hostname=?, addr=?, terminal=?)'
type=AVC msg=audit(1250699308.854:51): avc:  denied  { setattr } for  pid=6334 comm="chown" name="named" dev=dm-0 ino=303266 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:named_zone_t:s0 tclass=dir
type=SYSCALL msg=audit(1250699308.854:51): arch=c000003e syscall=260 success=yes exit=0 a0=ffffffffffffff9c a1=6a2c80 a2=0 a3=19 items=0 ppid=6322 pid=6334 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="chown" exe="/bin/chown" subj=system_u:system_r:initrc_t:s0 key=(null)
type=USER_AVC msg=audit(1250699309.459:52): user pid=1016 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } for msgtype=method_call interface=org.freedesktop.DBus.Introspectable member=Introspect dest=:1.93 spid=5753 tpid=5757 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:system_r:policykit_t:s0-s0:c0.c1023 tclass=dbus : exe="/bin/dbus-daemon" (sauid=81, hostname=?, addr=?, terminal=?)'
type=USER_AVC msg=audit(1250699309.460:53): user pid=1016 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } for msgtype=method_return dest=:1.92 spid=5757 tpid=5753 scontext=system_u:system_r:policykit_t:s0-s0:c0.c1023 tcontext=system_u:system_r:initrc_t:s0 tclass=dbus : exe="/bin/dbus-daemon" (sauid=81, hostname=?, addr=?, terminal=?)'


#============= initrc_t ==============
allow initrc_t named_zone_t:dir setattr;
allow initrc_t policykit_t:dbus send_msg;

#============= policykit_t ==============
allow policykit_t initrc_t:dbus send_msg;
[root@tlondon ~]#

Comment 4 Daniel Walsh 2009-08-20 13:32:13 UTC
This seems to be working with selinux-policy-3.6.28-3.fc12.noarch

Comment 5 Tom London 2009-08-20 19:31:05 UTC
After applying selinux-policy-3.6.28-3.fc12, s-c-s indeed no longer crashes.

But, I do see the following spew:

[tbl@tlondon ~]$ system-config-services
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 123, in notify
    self.dbus_notify (subscriber, service_name, change)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 98, in dbus_notify
    subscriber.remote_method_or_function (herder = self, change = change, *subscriber.p, **k)
  File "/usr/bin/system-config-services", line 551, in on_services_changed
    self.on_service_added (service)
  File "/usr/bin/system-config-services", line 575, in on_service_added
    self.service_painters[service].paint ()
  File "/usr/bin/system-config-services", line 368, in paint
    if self.service.info.shortdescription:
  File "/usr/lib/python2.6/site-packages/slip/dbus/polkit.py", line 48, in enable_proxy_wrapper
    return func (*p, **k)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/servicesinfo.py", line 45, in shortdescription
    return self.dbus_object.get_shortdescription (dbus_interface = "org.fedoraproject.Config.Services.SysVService")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[tbl@tlondon ~]$ 

If I try to actually enable a service (e.g., abrt), I get no response/reaction and see this:

[tbl@tlondon ~]$ system-config-services
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 123, in notify
    self.dbus_notify (subscriber, service_name, change)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 98, in dbus_notify
    subscriber.remote_method_or_function (herder = self, change = change, *subscriber.p, **k)
  File "/usr/bin/system-config-services", line 551, in on_services_changed
    self.on_service_added (service)
  File "/usr/bin/system-config-services", line 575, in on_service_added
    self.service_painters[service].paint ()
  File "/usr/bin/system-config-services", line 366, in paint
    self.treestore.set (iter, SVC_COL_ENABLED, _enabled_stock_id[self.service.get_enabled ()])
  File "/usr/lib/python2.6/site-packages/slip/dbus/polkit.py", line 48, in enable_proxy_wrapper
    return func (*p, **k)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/services.py", line 72, in get_enabled
    return self.dbus_object.get_enabled (dbus_interface = "org.fedoraproject.Config.Services.ChkconfigService")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 801, in on_serviceEnable_activate
    service.enable ()
  File "/usr/lib/python2.6/site-packages/slip/dbus/polkit.py", line 59, in enable_proxy_wrapper
    dbus_interface = "org.freedesktop.PolicyKit.AuthenticationAgent")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "ObtainAuthorization" with signature "suu" on interface "org.freedesktop.PolicyKit.AuthenticationAgent" doesn't exist

[tbl@tlondon ~]$ 

Don't see any AVCs.

Comment 6 Daniel Walsh 2009-08-20 19:37:53 UTC
Does it work in permissive mode?

Comment 7 Tom London 2009-08-20 20:01:01 UTC
No.

In permissive mode it again displays all the services correctly (it seems), but trying to enable one produces python spew and no effect:

[tbl@tlondon ~]$ system-config-servicesTraceback (most recent call last):
  File "/usr/bin/system-config-services", line 801, in on_serviceEnable_activate
    service.enable ()
  File "/usr/lib/python2.6/site-packages/slip/dbus/polkit.py", line 59, in enable_proxy_wrapper
    dbus_interface = "org.freedesktop.PolicyKit.AuthenticationAgent")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "ObtainAuthorization" with signature "suu" on interface "org.freedesktop.PolicyKit.AuthenticationAgent" doesn't exist

ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 123, in notify
    self.dbus_notify (subscriber, service_name, change)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 98, in dbus_notify
    subscriber.remote_method_or_function (herder = self, change = change, *subscriber.p, **k)
  File "/usr/bin/system-config-services", line 561, in on_services_changed
    self.on_service_status_changed (service)
  File "/usr/bin/system-config-services", line 659, in on_service_status_changed
    GUIServicesDetailsPainter (self, service).paint_details ()
  File "/usr/bin/system-config-services", line 270, in __init__
    super (GUISysVServicesDetailsPainter, self).__init__ (serviceslist, service)
  File "/usr/bin/system-config-services", line 249, in __init__
    super (GUIServicesDetailsPainter, self).__init__ (serviceslist.xml)
  File "/usr/bin/system-config-services", line 212, in __init__
    raise KeyError (wname)
KeyError: 'sysVServiceExplanationLabel'
[tbl@tlondon ~]$

Comment 8 Nils Philippsen 2009-08-21 10:13:07 UTC
(In reply to comment #7)
> No.
> 
> In permissive mode it again displays all the services correctly (it seems), 
> but trying to enable one produces python spew and no effect:
> 
> [tbl@tlondon ~]$ system-config-servicesTraceback (most recent call last):
[...]
> dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method
> "ObtainAuthorization" with signature "suu" on interface
> "org.freedesktop.PolicyKit.AuthenticationAgent" doesn't exist

This is because I haven't finished porting my stuff over to PolicyKit1, see bug #500007.

>   File "/usr/bin/system-config-services", line 212, in __init__
>     raise KeyError (wname)
> KeyError: 'sysVServiceExplanationLabel'

I figure that's a followup error on the above (it doesn't really make sense to me, code-wise).

Comment 9 Tom London 2009-08-26 16:02:26 UTC
Updated to .  Still fails on startup (the first time):

[tbl@tlondon ~]$ system-config-services
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 951, in <module>
    GUI (use_dbus = use_dbus).run ()
  File "/usr/bin/system-config-services", line 909, in __init__
    serviceherders = self.serviceherders)
  File "/usr/bin/system-config-services", line 765, in __init__
    self.servicesList = GUIServicesList (xml = self.xml, serviceherders = serviceherders)
  File "/usr/bin/system-config-services", line 467, in __init__
    if herder.ready:
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 64, in ready
    return self.herder_interface.is_ready ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[tbl@tlondon ~]$ 


Seems to work if I run it a second time:
[tbl@tlondon ~]$ system-config-services
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 125, in notify
    self.dbus_notify (subscriber, service_name, change)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 100, in dbus_notify
    subscriber.remote_method_or_function (herder = self, change = change, *subscriber.p, **k)
  File "/usr/bin/system-config-services", line 551, in on_services_changed
    self.on_service_added (service)
  File "/usr/bin/system-config-services", line 575, in on_service_added
    self.service_painters[service].paint ()
  File "/usr/bin/system-config-services", line 366, in paint
    self.treestore.set (iter, SVC_COL_ENABLED, _enabled_stock_id[self.service.get_enabled ()])
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/services.py", line 78, in get_enabled
    return self.chkconfig_interface.get_enabled ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[tbl@tlondon ~]$

Comment 10 Nils Philippsen 2009-08-26 16:10:02 UTC
(In reply to comment #9)
> Updated to .  Still fails on startup (the first time):

With which versions of system-config-services and python-slip do you see this?

Comment 11 Tom London 2009-08-26 16:19:45 UTC
Sorry:

[root@tlondon Download]# rpm -q system-config-services python-slip
system-config-services-0.99.38-1.fc12.noarch
python-slip-0.2.1-1.fc12.noarch
[root@tlondon Download]#

Comment 12 Nils Philippsen 2009-09-02 09:45:26 UTC
I had similar problem on my Rawhide machine, which I don't see anymore with version 0.99.39 after I relabelled the machine, see bug #520583. Would you please check if relabeling helps in your case?

Comment 13 Tom London 2009-09-02 16:21:29 UTC
system-config-services-0.99.39-1.fc12.noarch and python-slip-0.2.3-1.fc12.noarch "work for me".

Don't seem to need to relabel: running selinux-policy-3.6.30-2.fc12.noarch.

Close?

Comment 14 Tom London 2009-09-02 17:53:44 UTC
I may have been premature:

[tbl@tlondon classical]$ system-config-services
Locking '/var/cache/abrt/pyhook-1251913118-5796.lock'...
UnLocking '/var/cache/abrt/pyhook-1251913118-5796.lock'...
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 950, in <module>
    GUI (use_dbus = use_dbus).run ()
  File "/usr/bin/system-config-services", line 908, in __init__
    serviceherders = self.serviceherders)
  File "/usr/bin/system-config-services", line 764, in __init__
    self.servicesList = GUIServicesList (xml = self.xml, serviceherders = serviceherders)
  File "/usr/bin/system-config-services", line 466, in __init__
    if herder.ready:
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 64, in ready
    return self.herder_interface.is_ready ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[tbl@tlondon classical]$ 

Again, seems to work the second time I run it from a terminal window....:

[tbl@tlondon classical]$ system-config-services
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 125, in notify
    self.dbus_notify (subscriber, service_name, change)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 100, in dbus_notify
    subscriber.remote_method_or_function (herder = self, change = change, *subscriber.p, **k)
  File "/usr/bin/system-config-services", line 550, in on_services_changed
    self.on_service_added (service)
  File "/usr/bin/system-config-services", line 574, in on_service_added
    self.service_painters[service].paint ()
  File "/usr/bin/system-config-services", line 367, in paint
    if self.service.info.shortdescription:
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/servicesinfo.py", line 51, in shortdescription
    return self.sysv_interface.get_shortdescription ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[tbl@tlondon classical]$ 

I'm running "restorecon -v -R -n" on  my system to see if there is anything obvious that requires relabeling....

I see this in /var/log/messages.  Not sure if it is related:

Sep  2 10:39:18 tlondon abrt: Activating plugin: KerneloopsScanner
Sep  2 10:39:18 tlondon abrt: Scanning syslog...
Sep  2 10:41:18 tlondon abrt: Activating plugin: KerneloopsScanner
Sep  2 10:41:18 tlondon abrt: Scanning syslog...
Sep  2 10:41:22 tlondon nscd: Can't send to audit system: USER_AVC avc:  received policyload notice (seqno=5)#012: exe="?" sauid=28 hostname=? addr=? terminal=?
Sep  2 10:41:22 tlondon dbus: Can't send to audit system: USER_AVC avc:  received policyload notice (seqno=5)#012: exe="?" sauid=81 hostname=? addr=? terminal=?
Sep  2 10:41:22 tlondon dbus: avc:  received policyload notice (seqno=5)
Sep  2 10:41:22 tlondon setsebool: The named_write_master_zones policy boolean was changed to 0 by root
Sep  2 10:41:22 tlondon dbus: Reloaded configuration
Sep  2 10:41:22 tlondon pidof[7153]: can't get program name from /proc/7041/stat
Sep  2 10:43:18 tlondon abrt: Activating plugin: KerneloopsScanner
Sep  2 10:43:18 tlondon abrt: Scanning syslog...

[I enabled abrt when I ran s-c-c the second time.]

Here is clipped output from running "restorecon -v -R -n /":

restorecon reset /etc/xinetd.d/rsync context system_u:object_r:etc_runtime_t:s0->system_u:object_r:etc_t:s0
restorecon reset /etc/xinetd.d/cvs context system_u:object_r:etc_runtime_t:s0->system_u:object_r:etc_t:s0
restorecon reset /root/.xauthGMlOeH context unconfined_u:object_r:admin_home_t:s0->system_u:object_r:xauth_home_t:s0
restorecon reset /usr/sbin/mcelog.old context system_u:object_r:dmesg_exec_t:s0->system_u:object_r:bin_t:s0
restorecon reset /tmp/.X11-unix context system_u:object_r:xserver_tmp_t:s0->system_u:object_r:xdm_tmp_t:s0
restorecon reset /home/tbl.install/.tomboy.log context unconfined_u:object_r:user_home_dir_t:s0->unconfined_u:object_r:user_home_t:s0
<<<<SNIP lots of /home stuff....>>>>

Comment 15 Tom London 2009-09-02 18:53:12 UTC
I turned off "assistive technologies" and got a message about libgnomebreakpad.so, and an immediate crash:

[tbl@tlondon classical]$ system-config-services
Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: cannot open shared object file: No such file or directory
Locking '/var/cache/abrt/pyhook-1251917364-7883.lock'...
UnLocking '/var/cache/abrt/pyhook-1251917364-7883.lock'...
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 950, in <module>
    GUI (use_dbus = use_dbus).run ()
  File "/usr/bin/system-config-services", line 908, in __init__
    serviceherders = self.serviceherders)
  File "/usr/bin/system-config-services", line 764, in __init__
    self.servicesList = GUIServicesList (xml = self.xml, serviceherders = serviceherders)
  File "/usr/bin/system-config-services", line 466, in __init__
    if herder.ready:
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 64, in ready
    return self.herder_interface.is_ready ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[tbl@tlondon classical]$ 

Immediately running a second time works:

[tbl@tlondon classical]$ 
[tbl@tlondon classical]$ system-config-services
Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: cannot open shared object file: No such file or directory
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 125, in notify
    self.dbus_notify (subscriber, service_name, change)
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 100, in dbus_notify
    subscriber.remote_method_or_function (herder = self, change = change, *subscriber.p, **k)
  File "/usr/bin/system-config-services", line 550, in on_services_changed
    self.on_service_added (service)
  File "/usr/bin/system-config-services", line 574, in on_service_added
    self.service_painters[service].paint ()
  File "/usr/bin/system-config-services", line 365, in paint
    self.treestore.set (iter, SVC_COL_ENABLED, _enabled_stock_id[self.service.get_enabled ()])
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/services.py", line 78, in get_enabled
    return self.chkconfig_interface.get_enabled ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[tbl@tlondon classical]$

Comment 16 Tom London 2009-11-05 21:11:34 UTC
This now "works for me" with current Rawhide:

selinux-policy-targeted-3.6.32-41.fc12.noarch
selinux-policy-3.6.32-41.fc12.noarch
python-slip-0.2.7-1.fc12.noarch
system-config-services-0.99.41-1.fc12.noarch

Closing this as "fixed in Rawhide".  Reopen as needed.


Note You need to log in before you can comment on or make changes to this bug.