Bug 62719 - mkinitrd and devfs
mkinitrd and devfs
Status: CLOSED DUPLICATE of bug 51848
Product: Red Hat Public Beta
Classification: Retired
Component: mkinitrd (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2002-04-04 16:53 EST by Tim Clymo
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-04 16:55:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
diffs against mkinitrd-3.3.6-1 to enable better handling of devfs enabled kernel (1.96 KB, patch)
2002-04-04 16:55 EST, Tim Clymo
no flags Details | Diff

  None (edit)
Description Tim Clymo 2002-04-04 16:53:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020314

Description of problem:
I already added this as a comment to bug #55540 but there seems to have been no
response, so I'll try and file as a bug in it's own right...

It would seem that an initrd image generated with mkinitrd up to and including
3.3.6-1 doesn't work quite correctly if using a devfs enabled kernel. More
specifically, the kernel boots OK but there is a non-fatal problem early on in
the init sequence when trying to unmount the initrd filesystem. This is due to
the filesystem being busy as a consequence of /dev being mounted underneath.

The attached patch is something I plagiarised from Mandrake's additions to the
original RH mkinitrd. Fundamentally, all it does is to close I/O on devfs to
allow it to be remounted under real root instead of initrd root, and thus allow
/initrd to be successfully unmounted.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Build devfs enabled kernel
2.Boot with mkinitrd generated initrd

Actual Results:  System unable to unmount /initrd

Additional info:
Comment 1 Tim Clymo 2002-04-04 16:55:39 EST
Created attachment 52264 [details]
diffs against mkinitrd-3.3.6-1 to enable better handling of devfs enabled kernel
Comment 2 Erik Troan 2002-05-21 19:14:09 EDT

*** This bug has been marked as a duplicate of 51848 ***

Note You need to log in before you can comment on or make changes to this bug.