Bug 518535 - Unable to boot from iso
Unable to boot from iso
Status: CLOSED DUPLICATE of bug 517151
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-20 15:38 EDT by Eric Paris
Modified: 2009-08-21 03:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 03:06:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2009-08-20 15:38:50 EDT
# rpm -qa \*virt\* \*kvm\* \*qemu\*
qemu-system-sparc-0.10.91-0.7.rc1.fc12.x86_64
virt-viewer-0.2.0-1.fc12.x86_64
qemu-user-0.10.91-0.7.rc1.fc12.x86_64
libvirt-python-0.7.0-6.fc12.x86_64
etherboot-zroms-kvm-5.4.4-17.fc12.noarch
etherboot-roms-kvm-5.4.4-17.fc12.noarch
virt-manager-0.8.0-2.fc12.noarch
qemu-system-cris-0.10.91-0.7.rc1.fc12.x86_64
qemu-common-0.10.91-0.7.rc1.fc12.x86_64
qemu-system-m68k-0.10.91-0.7.rc1.fc12.x86_64
qemu-0.10.91-0.7.rc1.fc12.x86_64
libvirt-client-0.7.0-6.fc12.x86_64
qemu-system-ppc-0.10.91-0.7.rc1.fc12.x86_64
qemu-kvm-tools-0.10.91-0.7.rc1.fc12.x86_64
qemu-system-x86-0.10.91-0.7.rc1.fc12.x86_64
qemu-system-mips-0.10.91-0.7.rc1.fc12.x86_64
python-virtinst-0.500.0-1.fc12.noarch
qemu-kvm-0.10.91-0.7.rc1.fc12.x86_64
gpxe-roms-qemu-0.9.7-5.fc12.noarch
qemu-img-0.10.91-0.7.rc1.fc12.x86_64
qemu-system-arm-0.10.91-0.7.rc1.fc12.x86_64
libvirt-0.7.0-6.fc12.x86_64
qemu-system-sh4-0.10.91-0.7.rc1.fc12.x86_64

Starting with virt-manager

Create a new VM
Choose to install from ISO
Point it to a Fedora 11 x86_64 livecd (have tried other F11 isos)
Choose no storage space (doesn't seem to matter)
Start the VM.

VM starts but I get this error on screen:

booting from CD-Rom...
CDROM boot failure code : 0003
Boot failed: could not read the boot disk

FATAL: No bootable device.

The entirety of the /var/log/libvirt/Fedora11-LiveCD log is:
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/qemu-kvm -S -M pc-0.11 -m 512 -smp 2 -name Fedora11-LiveCD -uuid 13dd11e1-c429-c7e6-c275-308cc3c56e16 -monitor unix:/var/run/libvirt/qemu/Fedora11-LiveCD.monitor,server,nowait -boot d -drive file=/var/lib/libvirt/images/Fedora-11-x86_64-Live.iso,if=virtio,media=cdrom,index=0,format= -net nic,macaddr=52:54:00:1c:16:fc,vlan=0,model=virtio,name=virtio.0 -net tap,fd=30,vlan=0,name=tap.0 -serial pty -parallel none -usb -usbdevice tablet -vnc 127.0.0.1:0 -k en-us -vga cirrus 
char device redirected to /dev/pts/10
Comment 1 Mark McLoughlin 2009-08-21 03:06:35 EDT
Thanks Eric, problem is virtinst creating guests with a virtio cdrom instead of an ide cdrom:

file=/var/lib/libvirt/images/Fedora-11-x86_64-Live.iso,if=virtio,media=cdrom

*** This bug has been marked as a duplicate of bug 518552 ***
Comment 2 Mark McLoughlin 2009-08-21 03:43:49 EDT

*** This bug has been marked as a duplicate of bug 517151 ***

Note You need to log in before you can comment on or make changes to this bug.