Bug 518552 - when specifying --cdrom param the cdrom device is create as virtio device instead of ide
when specifying --cdrom param the cdrom device is create as virtio device ins...
Status: CLOSED DUPLICATE of bug 517151
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-20 17:17 EDT by Perry Myers
Modified: 2009-08-21 03:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 03:02:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2009-08-20 17:17:00 EDT
Description of problem:
When running virt-install --cdrom foo.iso --os-variant=fedoraX

where X is 10 or higher, virtio devices are used for network and block.  However, they should not be used for the cdrom device as cdrom needs to continue to be IDE even if virtio is used for hard disks/network.

virtio does not emulate cdroms so cdrom access with this configuration fails

Version-Release number of selected component (if applicable):
python-virtinst-0.500.0-1.fc11.noarch

How reproducible:
every time

Steps to Reproduce:
1. virt-install --name foo --ram 512 --cdrom=foo.iso --os-variant=fedora10 --nodisks
2. virsh start foo
3. 
  
Actual results:
Machine will fail to boot from foo.iso indicating error 0003 and inability to read the cdrom

Expected results:
Machine boots from bootable foo.iso

Additional info:
Running virt-install command above with fedora10 variant produces:
    <disk type='file' device='cdrom'>
      <driver name='qemu' type=''/>
      <source file='/var/lib/libvirt/images/node7-rhev-hypervisor.iso'/>
      <target dev='vda' bus='virtio'/>
      <readonly/>
    </disk>

Running virt-install command above with fedora9 variant produces:
    <disk type='file' device='cdrom'>
      <driver name='qemu' type=''/>
      <source file='/var/lib/libvirt/images/node7-rhev-hypervisor.iso'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
    </disk>

The vda device will not boot but the IDE device will.
Comment 1 Mark McLoughlin 2009-08-21 03:02:02 EDT

*** This bug has been marked as a duplicate of bug 517151 ***
Comment 2 Mark McLoughlin 2009-08-21 03:06:35 EDT
*** Bug 518535 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.