Bug 519172 - File conflicts between PolicyKit-kde-4.2.90-1 and kdebase-workspace-4.3.0-9
Summary: File conflicts between PolicyKit-kde-4.2.90-1 and kdebase-workspace-4.3.0-9
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-25 13:58 UTC by Alexander Todorov
Modified: 2014-01-21 23:11 UTC (History)
19 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-10-13 15:12:36 UTC


Attachments (Terms of Use)
output from `yum -y -d10 update >yum_d10_update.log 2>&1` (391.42 KB, text/plain)
2009-08-26 13:53 UTC, Alexander Todorov
no flags Details
output from `rpm -qa | sort' (20.17 KB, text/plain)
2009-08-26 15:27 UTC, Alexander Todorov
no flags Details
yum -d10 -y update (402.97 KB, text/plain)
2009-09-08 08:25 UTC, Alexander Todorov
no flags Details

Description Alexander Todorov 2009-08-25 13:58:43 UTC
Description of problem:
Trying to upgrade F11 system I hit a file conflict:

Transaction Check Error:
  file /usr/bin/polkit-kde-authorization conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/lib/kde4/kcm_pkk_authorization.so conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/lib/libpolkitkdeprivate.so.4 conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-libs-4.3.0-9.fc11.i586
  file /usr/libexec/kde4/polkit-kde-manager conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authdialog_1.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authdialog_2.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authdialog_3.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authdialog_4.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authdialog_5.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authdialog_6.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authorization_1.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authorization_2.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/index.cache.bz2 conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/kde4/services/kcm_pkk_authorization.desktop conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586

Error Summary
-------------

Version-Release number of selected component (if applicable):
package kdebase-workspace is not installed
PolicyKit-kde-4.2.0-3.fc11.i586 (installed)


How reproducible:


Steps to Reproduce:
1. Install F11
2. install yum-presto
3. run yum -y update
  
Actual results:


Expected results:


Additional info:

Comment 1 Alexander Todorov 2009-08-25 14:02:34 UTC
Something is pulling kdebase-workspace as dependency but I haven't figured out what.

Comment 2 Kevin Kofler 2009-08-25 15:29:01 UTC
PolicyKit-kde has been integrated into kdebase-workspace. Normally, kdebase-workspace is supposed to obsolete PolicyKit-kde, I don't know how you end up with both.

Comment 3 Rex Dieter 2009-08-25 15:32:06 UTC
kdebase-workspace includes:
Obsoletes: PolicyKit-kde < 4.3.0-100

Not sure why rpm/yum didn't do the right thing here.

Comment 4 Rex Dieter 2009-08-25 15:40:45 UTC
rpm -q rpm yum
please.

latest are:
rpm-4.7.1-1.fc11
yum-3.2.23-3.fc11

If you don't have these, I'd suggest you update via,
yum update rpm yum
and try again.

Comment 5 Sebastian Vahl 2009-08-25 15:55:18 UTC
(In reply to comment #3)
> kdebase-workspace includes:
> Obsoletes: PolicyKit-kde < 4.3.0-100
> 
> Not sure why rpm/yum didn't do the right thing here.  

Maybe it's the same as this not working obsolete: bug #515325 ?

Comment 6 Alexander Todorov 2009-08-26 08:35:43 UTC
# rpm -q yum rpm
yum-3.2.22-4.fc11.noarch
rpm-4.7.0-1.fc11.i586

# yum update rpm yum

# rpm -q yum rpm
yum-3.2.23-3.fc11.noarch
rpm-4.7.1-1.fc11.i586


I still see the conflict.

Comment 7 Rex Dieter 2009-08-26 12:45:10 UTC
Please attach output of 
yum -d10 update

Comment 8 Alexander Todorov 2009-08-26 13:53:13 UTC
Created attachment 358717 [details]
output from `yum -y -d10 update >yum_d10_update.log  2>&1`

Comment 9 Rex Dieter 2009-08-26 14:47:17 UTC
Rats I think I found one problem, you wouldn't happen to have
rpm -q PolicyKit-kde-devel
installed?

If so, that's it, kdebase-workspace-devel is missing the proper Obsoletes for that.  The provided log doesn't say anything about PolicyKit-kde-devel.


But, I think yum is getting it just plain wrong looking for providers for libpolkitkdeprivate.so.4 :

Running compare_providers() for [<YumAvailablePackageSqlite : PolicyKit-kde-4.2.90-1.fc11.i586 (0xaf6724c)>, <YumAvailablePackageSqlite : kdebase-workspace-libs-4.3.0-9.fc11.i586 (0xb1fc0ac)>]
Best Order: [(<YumAvailablePackageSqlite : PolicyKit-kde-4.2.90-1.fc11.i586 (0xaf6724c)>, -13)]
TSINFO: Marking PolicyKit-kde-4.2.90-1.fc11.i586 as update for kdebase-workspace-4.3.0-9.fc11.i586

Comment 10 Alexander Todorov 2009-08-26 15:25:23 UTC
# rpm -q PolicyKit-kde-devel
package PolicyKit-kde-devel is not installed

Although I have other devel packages installed. Will attach rpm -qa output.

Comment 11 Alexander Todorov 2009-08-26 15:27:06 UTC
Created attachment 358734 [details]
output from `rpm -qa | sort'

Comment 12 Rex Dieter 2009-08-26 15:49:44 UTC
reassiging to yum, per comment #3 and comment #9

Comment 13 seth vidal 2009-08-26 15:58:06 UTC
fixed in yum in rawhide, I'm pretty sure.

there was an issue properly detecting < and <= obsoletes in certain cases.




at least:
http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=1261479f334019c30900573cc10f9d2c8d9031e2

and latest is better.

Comment 14 Alexander Todorov 2009-08-26 16:08:54 UTC
Re-opening. This is on F11 and is causing the update to fail. Please backport the fix from rawhide.

Comment 15 Rex Dieter 2009-08-26 16:14:47 UTC
Or if not, let us know, and I suppose we could re-work the packaging to continue to have a PolicyKit-kde subpkg to ease the upgrade path.

Comment 16 seth vidal 2009-08-26 16:19:37 UTC
I can probably backport just the patches impacting this b/c backporting all of the changes in yum in rawhide will be an adventure.

Comment 17 seth vidal 2009-09-03 13:24:52 UTC
*** Bug 520163 has been marked as a duplicate of this bug. ***

Comment 18 seth vidal 2009-09-04 22:29:07 UTC
yum 3.2.24-1.fc11 should be in updates-testing soon

https://admin.fedoraproject.org/updates/yum-3.2.24-1.fc11

Comment 19 Alexander Todorov 2009-09-08 08:25:13 UTC
Created attachment 360046 [details]
yum -d10 -y update

Still having a conflict with yum-3.2.24-1 from updates-testing. Output from yum -d10 update is attached.

Comment 20 seth vidal 2009-09-08 13:47:09 UTC
let's start over on this:

run this command:

rpm -Va --nofiles --nodigest

and report any output

then run:
yum list installed PolicyKit-\* kde-workspace\*

and report that output

Comment 21 Alexander Todorov 2009-09-08 14:54:02 UTC
rpm -Va --nofiles --nodigest - no output

# yum list installed PolicyKit-\* kde-workspace\*
Loaded plugins: presto
Installed Packages
PolicyKit.i586         0.9-6.fc11    installed
PolicyKit-kde.i586     4.2.0-3.fc11  installed

Transaction Check Error:
  file /usr/bin/polkit-kde-authorization conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/lib/kde4/kcm_pkk_authorization.so conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/lib/libpolkitkdeprivate.so.4 conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-libs-4.3.0-9.fc11.i586
  file /usr/libexec/kde4/polkit-kde-manager conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authdialog_1.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authdialog_2.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authdialog_3.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authdialog_4.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authdialog_5.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authdialog_6.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authorization_1.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/authorization_2.png conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/doc/HTML/en/PolicyKit-kde/index.cache.bz2 conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586
  file /usr/share/kde4/services/kcm_pkk_authorization.desktop conflicts between attempted installs of PolicyKit-kde-4.2.90-1.fc11.i586 and kdebase-workspace-4.3.0-9.fc11.i586

Comment 22 Alexander Todorov 2009-09-08 14:56:21 UTC
Comment #21 is with
yum-3.2.24-1.fc11.noarch
rpm-4.7.1-1.fc11.i586


from updates-testing.

Comment 23 seth vidal 2009-09-08 16:29:39 UTC
okay this is where things go off the rails

Running compare_providers() for [<YumAvailablePackageSqlite : PolicyKit-kde-4.2.90-1.fc11.i586 (0x9caf8ac)>, <YumAvailablePackageSqlite : kdebase-workspace-libs-4.3.0-9.fc11.i586 (0x9cafbec)>]
Best Order: [(<YumAvailablePackageSqlite : PolicyKit-kde-4.2.90-1.fc11.i586 (0x9caf8ac)>, -13)]
TSINFO: Marking PolicyKit-kde-4.2.90-1.fc11.i586 as update for kdebase-workspace-4.3.0-9.fc11.i586


for some reason PolicyKit-kde is succeeding in the compare providers over kdebase-workspace-libs.

I'm going to try to replicate the state your system is in.

Comment 24 seth vidal 2009-09-08 19:17:43 UTC
I've submitted a patch upstream that fixes this problem.

to easily step around this problem you can do:

yum --exclude=kdebase-workspace update PolicyKit-kde

then

yum update

and that'll get you around it. For the specifics on what was causing this issue look here:

http://lists.baseurl.org/pipermail/yum-devel/2009-September/005845.html

thanks

Comment 25 Alexander Todorov 2009-09-09 07:58:11 UTC
this work around works for me.

Comment 26 Mads Kiilerich 2009-09-28 13:25:06 UTC
I got it again trying to yum upgrade from F11 to rawhide. yum-3.2.24-2.fc11.noarch

It would be _very_ nice to get a fix in F11 pretty soon so the upgrade process could be tested.

Comment 27 Fedora Update System 2009-09-30 01:39:48 UTC
yum-3.2.24-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 Mads Kiilerich 2009-09-30 13:49:18 UTC
As said in comment 26: yum-3.2.24-2.fc11 not fix it for me.

[root@localhost ~]# rpm -q yum
yum-3.2.24-2.fc11.noarch
[root@localhost ~]# rm -rf /var/cache/yum/*
[root@localhost ~]# yum --enablerepo=rawhide upgrade
...
--> Processing Dependency: totem = 2.26.3 for package: totem-gstreamer-2.26.3-5.fc11.i586
/usr/lib/python2.6/site-packages/yum/packages.py:413: UnicodeWarning: Unicode unequal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
  if reqn != n:
--> Finished Dependency Resolution
totem-gstreamer-2.26.3-5.fc11.i586 from installed has depsolving problems
  --> Missing Dependency: totem = 2.26.3 is needed by package totem-gstreamer-2.26.3-5.fc11.i586 (installed)
--> Running transaction check
---> Package kernel-PAE.i686 0:2.6.29.6-217.fc11 set to be erased
---> Package kernel-PAE-devel.i686 0:2.6.29.6-213.fc11 set to be erased
--> Processing Dependency: totem = 2.26.3 for package: totem-gstreamer-2.26.3-5.fc11.i586
--> Finished Dependency Resolution
totem-gstreamer-2.26.3-5.fc11.i586 from installed has depsolving problems
  --> Missing Dependency: totem = 2.26.3 is needed by package totem-gstreamer-2.26.3-5.fc11.i586 (installed)
Error: Missing Dependency: totem = 2.26.3 is needed by package totem-gstreamer-2.26.3-5.fc11.i586 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Comment 29 seth vidal 2009-10-13 15:12:36 UTC
Comment 28 - the error you're having is NOT the same as this one. Open a different bug.

Comment 30 Mads Kiilerich 2009-10-13 21:03:44 UTC
Re comment 29: I have reopened bug 520163

Comment 31 Fedora Update System 2009-10-19 16:46:11 UTC
yum-3.2.24-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-3.2.24-2.fc10

Comment 32 Fedora Update System 2009-11-04 12:07:53 UTC
yum-3.2.24-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.