Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 519212 - RuntimeError: Returning partitions to state prior to edit failed
Summary: RuntimeError: Returning partitions to state prior to edit failed
Keywords:
Status: CLOSED DUPLICATE of bug 498026
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 519526 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-25 16:37 UTC by James Laska
Modified: 2013-09-02 06:39 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-25 16:56:38 UTC
Type: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (768.89 KB, text/plain)
2009-08-25 16:37 UTC, James Laska
no flags Details
Attached traceback automatically from anaconda. (112.06 KB, text/plain)
2009-08-26 11:57 UTC, James Laska
no flags Details
Attached traceback automatically from anaconda. (376.00 KB, text/plain)
2009-10-08 10:37 UTC, Alexey Torkhov
no flags Details
Attached traceback automatically from anaconda. (735.02 KB, text/plain)
2009-10-09 16:22 UTC, James Laska
no flags Details
Attached traceback automatically from anaconda. (845.72 KB, text/plain)
2009-10-09 16:39 UTC, Alexey Torkhov
no flags Details
Attached traceback automatically from anaconda. (913.55 KB, text/plain)
2009-10-09 16:54 UTC, James Laska
no flags Details
Attached traceback automatically from anaconda. (175.59 KB, text/plain)
2009-10-28 20:29 UTC, James Laska
no flags Details
Attached traceback automatically from anaconda. (17.12 MB, text/plain)
2010-02-16 11:53 UTC, Miked
no flags Details
Attached traceback automatically from anaconda. (311.08 KB, text/plain)
2010-02-24 14:46 UTC, James Laska
no flags Details

Description James Laska 2009-08-25 16:37:50 UTC
The following was filed automatically by anaconda:
anaconda 12.16 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1136, in editPartition
    raise RuntimeError, ("Returning partitions to state "
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1082, in editCB
    self.editPartition(device)
RuntimeError: Returning partitions to state prior to edit failed

Comment 1 James Laska 2009-08-25 16:37:56 UTC
Created attachment 358597 [details]
Attached traceback automatically from anaconda.

Comment 2 James Laska 2009-08-25 16:45:16 UTC
This was discovered while testing https://fedoraproject.org/wiki/QA:Testcase_anaconda_encrypted_lvm_on_raid

I initially created a 200M /boot partition and clicked 'Next'.  I was prompted to increase '/boot' by 75MB.  When clicking "GO BACK" I believe that is when the traceback occured.

Comment 3 Andy Lindeberg 2009-08-25 16:56:38 UTC

*** This bug has been marked as a duplicate of bug 498026 ***

Comment 4 James Laska 2009-08-26 11:57:05 UTC
Created attachment 358707 [details]
Attached traceback automatically from anaconda.

Comment 5 Chris Lumens 2009-08-27 13:47:43 UTC
*** Bug 519526 has been marked as a duplicate of this bug. ***

Comment 6 Alexey Torkhov 2009-10-08 10:37:03 UTC
Created attachment 364080 [details]
Attached traceback automatically from anaconda.

Comment 7 James Laska 2009-10-09 16:22:14 UTC
Created attachment 364271 [details]
Attached traceback automatically from anaconda.

Comment 8 Alexey Torkhov 2009-10-09 16:39:34 UTC
Created attachment 364272 [details]
Attached traceback automatically from anaconda.

Comment 9 James Laska 2009-10-09 16:54:06 UTC
Created attachment 364274 [details]
Attached traceback automatically from anaconda.

Comment 10 James Laska 2009-10-28 20:29:02 UTC
Created attachment 366492 [details]
Attached traceback automatically from anaconda.

Comment 11 Miked 2010-02-16 11:53:54 UTC
Created attachment 394510 [details]
Attached traceback automatically from anaconda.

Comment 12 Miked 2010-02-16 12:03:33 UTC
I was editing a partition from ext4 to software raid.  Anaconda said insufficient space available.  Clicked on cancel and then it crashed.

Comment 13 James Laska 2010-02-24 14:46:55 UTC
Created attachment 396075 [details]
Attached traceback automatically from anaconda.

Comment 14 James Laska 2010-02-24 14:52:35 UTC
Removed tracehash and moved to new bug#531629


Note You need to log in before you can comment on or make changes to this bug.