Bug 51934 - XFree86-4.1.0 fails to read S3 Prosavage KM133 video bios
XFree86-4.1.0 fails to read S3 Prosavage KM133 video bios
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-16 23:58 EDT by NILMONI DEB
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-17 00:05:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86.0.log (19.13 KB, text/plain)
2001-08-17 00:03 EDT, NILMONI DEB
no flags Details
XF86Config-4 (5.97 KB, text/plain)
2001-08-17 00:05 EDT, NILMONI DEB
no flags Details

  None (edit)
Description NILMONI DEB 2001-08-16 23:58:28 EDT
Description of Problem:
I am using XFree86-4.1.0 with S3 Prosavage KM133 integrated video.
The driver is the 1.1.18 version from 
http://www.probo.com/timr/savage40.html

When I run "X -xf86config XF86Config" I get this error messages in the 
/var/log/XFree86.0.log file ->

(EE) SAVAGE(0): Cannot read V_BIOS

Version-Release number of selected component (if applicable):
XFree86-4.1.0

How Reproducible:
always

Steps to Reproduce:
1.  run X
2. 
3. 

Actual Results:
X doesnot start and quits after error messages

Expected Results:
proper X-windows

Additional Information:
Comment 1 NILMONI DEB 2001-08-17 00:03:55 EDT
Created attachment 28233 [details]
XFree86.0.log
Comment 2 NILMONI DEB 2001-08-17 00:05:23 EDT
Created attachment 28234 [details]
XF86Config-4
Comment 3 Mike A. Harris 2001-08-17 22:31:40 EDT
This is like buying a Ford truck, and then calling GM and telling
them "something is wrong with my truck."

Report the bug to the driver author please, we have not shipped
this driver.
Comment 4 NILMONI DEB 2001-08-17 22:56:29 EDT
The reason I am using this savage driver is given in Bug 47768, caused by savage driver 
shipped with X-4.1.0 (from redhat/rawhide RPMS). Tim Roberts' current savage driver has solved
that problem. I had the understanding that Tim Roberts' savage driver is referenced by redhat developers, as is evident from ur comments in bug 37467. In fact, it was bug 37467 that gave 
me the idea of using Tim's savage driver.
Comment 5 Mike A. Harris 2001-08-18 03:59:51 EDT
That is ok to use the driver, yes.  Red Hat XFree86 does not currently
include that driver, and might not in the future either, especially
if there are known flaws and regressions in that driver.

Sure, i may point out a driver on the web somewhere in a goodwill effort
to help someone solve their problem by providing information, but that
doesn't mean that because I provide a URL or info to someone that
we support bug reports for external source code not contained in Red
Hat Linux.  Bugzilla is for tracking bugs in Red Hat Linux and related
products, including rawhide, etc.  Not for bug general bug reports.

Sorry if I have mislead you.  If I do update the driver to the latest
one 1.1.18, and you continue to have this problem however, by all means,
please come back here and reopen this bugreport so that we can track it.

One thing to note, is that the 1.1.18 driver was released with a bug, and
Tim fixed it, and repackaged the new package as 1.1.18 again for whatever
reason instead of calling it 1.1.19.  It is possible that yours is the
older one.  Sorry I can't be more help right now.

Note You need to log in before you can comment on or make changes to this bug.