Bug 520481 - [Emulex 6.0 feat] be2net request_firmware() support in Ethtool-cmd-with-flash-for-RH6
Summary: [Emulex 6.0 feat] be2net request_firmware() support in Ethtool-cmd-with-flash...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ethtool
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: beta
: 6.0
Assignee: Jay Fenlason
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On: 515262 576172 583766 604729
Blocks: 554559 555224 555228
TreeView+ depends on / blocked
 
Reported: 2009-08-31 17:52 UTC by laurie barry
Modified: 2014-08-31 23:29 UTC (History)
16 users (show)

Fixed In Version: ethtool-6-7.20090323git.1.el6
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-12 12:39:53 UTC


Attachments (Terms of Use)
Change in ethtool command to support flash f/w function (6.33 KB, patch)
2009-09-02 07:53 UTC, Subbu Seetharaman
no flags Details | Diff

Description laurie barry 2009-08-31 17:52:07 UTC
This patch adds support for the Upstream be2net related request_firmware() needed in RHEL6.  The patch is pending approval on netdev.  

RHEL6 be2net driver patch is associated with bugzilla 515262.

Laurie

Comment 2 RHEL Product and Program Management 2009-08-31 18:28:13 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Bill Nottingham 2009-09-02 00:12:07 UTC
Patch was not actually attached.

Comment 4 Subbu Seetharaman 2009-09-02 07:53:40 UTC
Created attachment 359475 [details]
Change in ethtool command to support flash f/w function


This patch must apply against the ethtool source in the src rpm :

ethtool-6-7.20090323git.fc12.src.rpm

The change is also submitted to netdev.

Subbu

Comment 5 Chris Ward 2009-11-25 10:11:24 UTC
@Reporters

We need to confirm that there is third-party commitment to 
test for the resolution of this request during the RHEL 6.0 
Beta Test Phase before we can approve it for acceptance 
into the release.

In order to avoid any unnecessary delays, please post a 
confirmation as soon as possible, including the contact 
information for testing engineers.

Any additional information about alternative testing variations we 
could use to reproduce this issue in-house would be appreciated.

Comment 6 Subbu Seetharaman 2009-11-25 10:30:09 UTC
QA resource has been allocated by ServerEngines for testing this driver through
test phase.  The QA contact is Vasavi Balanagu (vasavib@serverengines.com).

Subbu

Comment 7 Subbu Seetharaman 2009-11-25 10:34:42 UTC
This patch is not fixing any problem; but adding a mechanism to flash a f/w image to NICs using ethtool.

Subbu

Comment 8 laurie barry 2009-11-25 12:40:11 UTC
Emulex is also committed to testing Ethtool with the be2net during RHEL6 beta.

Laurie

Comment 12 Andy Gospodarek 2010-01-14 21:29:41 UTC
Jeff, we need to pull the patch in comment #9 so ethtool has the 'flash' support in RHEL6.  It's not there when I look at RHEL6 CVS.

Comment 14 Jay Fenlason 2010-02-04 23:04:47 UTC
I pulled in ethtool-2.6.33-0.1 that Jeff just build for Rawhide.  He says it has this functionality.  I'm not quite sure what state to put the bug in though.

Comment 17 Subbu Seetharaman 2010-03-24 12:55:19 UTC
I dont see ethtool -f supported in the ethtool command in the RHEL6 alpha release.  Should I wait for Beta1 for this to  show up ?  Please let me know if you need anything from me to get this functionality.

Thanks.

Subbu

Comment 19 Subbu Seetharaman 2010-04-27 14:08:30 UTC
I dont see the -f option in the ethtool command in beta1.  Has this not been integrated yet ?

Comment 20 Andrius Benokraitis 2010-04-28 15:08:24 UTC
Probably because this wasn't included in Beta 1 in time. Please compare the version numbers of ethtool in Beta 1 compared to the "fixed in" field above.

Comment 21 Subbu Seetharaman 2010-04-29 12:38:11 UTC
Fixed in version field shows : ethtool-2.6.33-0.1.el6

rpm -qa in beta1 shows the version as ethtool-6-7.20090323git.1.el6.i686.  What do I infer ?

Comment 22 Andrius Benokraitis 2010-05-04 01:43:58 UTC
Beta 1 contains ethtool-6-7.20090323git.1.el6 AFAIK.

Comment 25 Subbu Seetharaman 2010-06-15 18:10:26 UTC
Verified that ethtool -f works in snapshot6 in x86 platforms.

Subbu

Comment 26 Chris Ward 2010-07-12 12:39:53 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. One or more confirmation reports have already been received confirming this. This report is therefore being closed with a resolution of CURRENTRELEASE. You may reopen this bug report if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.