Bug 604729 - [Emulex 6.0 bug] Update be2net 10GB NIC driver to version 2.102.380r - additional patches
[Emulex 6.0 bug] Update be2net 10GB NIC driver to version 2.102.380r - additi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
high Severity high
: rc
: 6.0
Assigned To: Ivan Vecera
Red Hat Kernel QE team
: OtherQA
Depends On: 515262 576172 602451 617187
Blocks: 520481 522543 529454 583766
  Show dependency treegraph
 
Reported: 2010-06-16 11:36 EDT by Subbu Seetharaman
Modified: 2010-11-15 09:07 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 576172
Environment:
Last Closed: 2010-11-15 09:07:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subbu Seetharaman 2010-06-16 11:36:30 EDT
+++ This bug was initially created as a clone of Bug #576172 +++

Bug cloned to attach patch for recent fixes in be2net.

This patch includes the following upstream commits :

3ffd05159815d477f971a3259fc758f0c3c7e640
        be2net: convert hdr.timeout in be_cmd_loopback_test() to le32
f25b03a7bd260b939b1a6aa69ca518d9848bb63a
        be2net: replace udelay() with schedule_timeout() in mbox polling
889cd4b2e529db4988525b0b3e6fb2c095760848
        be2net: cleanup in case of error in be_open()
2892d9c2d925e0d72a7a529852942e2592a970f8
        be2net: add unlock on error path
d938a702e5ce8909ea68be97566150507bfea4df
        be2net: increase POST timeout for EEH recovery
dd131e76e562fa0c6f9dd53130e8d08d39a0b62c
        be2net: Bug fix to avoid disabling bottom half during firmware upgrade
556ae19110f2de5ace4733e0c19e5fa01fad08b3
        be2net: Bug fix in init code in probe
b681ee77f8ad248b0fdcec2e5e8c4df6e757eba3
        benet: fix the misusage of zero dma address

Additionally, this patch implements a change to return proper PHY information to get_settings ioctl.  This change will be submitted to netdev shortly.
Comment 2 Andrius Benokraitis 2010-06-16 23:21:10 EDT
I'm assuming this is to apply on *top* of everything so far including SRIOV patches?
Comment 3 Subbu Seetharaman 2010-06-17 09:30:47 EDT
Thst is correct.  Apllies on top of SRIOV patch.
Comment 4 Aristeu Rozanski 2010-07-01 12:13:33 EDT
Patch(es) available on kernel-2.6.32-42.el6
Comment 7 Andrius Benokraitis 2010-09-13 14:45:48 EDT
*IMPORTANT*

Partners - please test this bugzilla *immediately* and report back with a comment. Delays in test findings could impact future proposed inclusions due to failed partner test commitments. Your results are very important to Red Hat and its mutual customers.
Comment 8 Mike Gahagan 2010-09-13 15:20:58 EDT
[root@test1238 apic]# modinfo be2net
filename:       /lib/modules/2.6.32-71.el6.x86_64/kernel/drivers/net/benet/be2net.ko
license:        GPL
author:         ServerEngines Corporation
description:    ServerEngines BladeEngine 10Gbps NIC Driver 2.102.426r
version:        2.102.426r
srcversion:     A37FDC1E50878678DAE1DA5
alias:          pci:v000019A2d00000710sv*sd*bc*sc*i*
alias:          pci:v000019A2d00000700sv*sd*bc*sc*i*
alias:          pci:v000019A2d00000221sv*sd*bc*sc*i*
alias:          pci:v000019A2d00000211sv*sd*bc*sc*i*
depends:        
vermagic:       2.6.32-71.el6.x86_64 SMP mod_unload modversions 
parm:           rx_frag_size:Size of a fragment that holds rcvd data. (uint)
parm:           num_vfs:Number of PCI VFs to initialize (uint)
Comment 9 Subbu Seetharaman 2010-09-14 08:04:55 EDT
All these fixes are verified in RH6, snapshot 12.
Comment 10 releng-rhel@redhat.com 2010-11-15 09:07:12 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.