Bug 520676 - Port to new telepathy-mission-control
Port to new telepathy-mission-control
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anerley (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On: 526091
Blocks: FedoraMoblin20
  Show dependency treegraph
 
Reported: 2009-09-01 14:28 EDT by Jesse Keating
Modified: 2013-01-09 22:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-30 17:08:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2009-09-01 14:28:14 EDT
pc name changed from libmissioncontrol to libmcclient, and the include paths changed too.  Not sure what all porting work needs to be done, but more than I was willing to do in a quick look this morning.
Comment 1 Peter Robinson 2009-09-01 18:16:18 EDT
thanks Jesse. I've had a quick look upstream a couple of days ago and couldn't determine if there were any porting docs. I will be looking further later in the week as I get more time.
Comment 2 Brian Pepple 2009-09-01 18:26:22 EDT
Here's a link to the patch that ported nautilus-sendto to mc5.  If I can free up some time, I'll see if I can help out with porting it.

http://git.gnome.org/cgit/nautilus-sendto/commit/?id=bb014358c6a2d1da48e556fb979b85d6c03c5681
Comment 3 Brian Pepple 2009-09-01 18:28:15 EDT
(In reply to comment #2)
> Here's a link to the patch that ported nautilus-sendto to mc5.  If I can free
> up some time, I'll see if I can help out with porting it.
> 
> http://git.gnome.org/cgit/nautilus-sendto/commit/?id=bb014358c6a2d1da48e556fb979b85d6c03c5681  

Hmm, looking at the patch it looks like there using empathy, so that won't be much help.  Probably need to look at empathy's code.
Comment 4 Peter Robinson 2009-09-08 12:36:53 EDT
Will be updated upstream shortly using some new client convenience code in telepathy-glib.

http://lists.freedesktop.org/archives/telepathy/2009-September/003823.html
Comment 5 Peter Robinson 2009-09-28 14:06:07 EDT
The new telepathy-glib that is needed for the use of anerley, moblin-panel-people, moblin-panel-status with telepathy-mission-control 5 is now out

http://lists.freedesktop.org/archives/telepathy/2009-September/003911.html
Comment 6 Bastien Nocera 2009-09-28 16:59:22 EDT
<jonnylamb> hadess: git://git.collabora.co.uk/git/user/jonny/anerley.git branch "mc5"
<jonnylamb> hadess: (moblin-panel-status and moblin-panel-people patches are in similar locations)
Comment 7 Peter Robinson 2009-09-29 07:49:29 EDT
All packages are now updated and built against MC-5. Thanks to Bastien's help. The following rel-eng ticket has bee filed to get them tagged into the F-12 beta.

https://fedorahosted.org/rel-eng/ticket/2226
Comment 8 Peter Robinson 2009-09-30 17:08:08 EDT
The port to MC5 is now in rawhide. Thanks Bastien for your help!

Note You need to log in before you can comment on or make changes to this bug.