Bug 522305 - Unable to adjust LCD backlight on macbook pro 5,3
Unable to adjust LCD backlight on macbook pro 5,3
Status: CLOSED DUPLICATE of bug 539961
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-09 22:36 EDT by Jereme Kramer
Modified: 2010-01-16 23:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-16 23:03:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lshal | egrep "(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)" (52 bytes, text/plain)
2009-09-09 22:36 EDT, Jereme Kramer
no flags Details
output of lshal | egrep "(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)" (654 bytes, text/plain)
2009-09-09 22:41 EDT, Jereme Kramer
no flags Details

  None (edit)
Description Jereme Kramer 2009-09-09 22:36:02 EDT
Created attachment 360407 [details]
output of lshal | egrep
"(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)"

Description of problem:

Unable to adjust backlight on MacBook Pro 5,3 

Version-Release number of selected component (if applicable):
hal-0.5.12-29.20090226git.fc11
kernel-2.6.30.5-43
DeviceKit-power-010-0.3.2009081git.fc11
gnome-power-manager-2.26.4-3.fc11

How reproducible

Always

Steps to Reproduce:

Under gnome, running gnome-power-manager...

1. Press brightness up or down keys, or disconnect from power

Actual results:

No adjustment in screen brightness

Expected results:

Screen brightness should adjust


Additional info:

Based on recently closed bug 505531.
The problem is not solved for the MacBook Pro 5,3.
Comment 1 Jereme Kramer 2009-09-09 22:41:02 EDT
Created attachment 360408 [details]
output of lshal | egrep "(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)"
Comment 2 Takanori MATSUURA 2009-09-17 13:58:17 EDT
I'm also facing this issue. My MacBook is:

# lshal | egrep "(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)"
  power_management.quirk.vbestate_restore = true  (bool)
  system.firmware.version = '    MB31.88Z.008E.B02.0803051832'  (string)
  system.hardware.product = 'MacBook3,1'  (string)
  system.hardware.vendor = 'Apple Inc.'  (string)
  system.hardware.version = '1.0'  (string)
Comment 3 satyajit 2009-09-24 23:00:41 EDT
Im facing the same problem in Macbook pro 5,4

$ lshal | grep "system.hardware"
  system.hardware.primary_video.product = 2147  (0x863)  (int)
  system.hardware.primary_video.vendor = 4318  (0x10de)  (int)
  system.hardware.product = 'MacBookPro5,4'  (string)
  system.hardware.serial = 'W89343D47XJ'  (string)
  system.hardware.uuid = '56F03BFC-B24B-6C41-AB17-3A23A64F790E'  (string)
  system.hardware.vendor = 'Apple Inc.'  (string)
  system.hardware.version = '1.0'  (string)
Comment 4 Carl G. 2010-01-16 23:03:51 EST
---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 539961 ***

Note You need to log in before you can comment on or make changes to this bug.